Jump to content

Recommended Posts

Disclaimer: This may very well be an user error. However I can't see how...

 

TMWH user here. Since yesterday I can't get the SCS switch to work reliably. Sometimes it takes only one press to switch soi left / right, sometimes I need 4-5 tries.

 

I have the SCS switch mapped to the physical TMS switch. It worked fine before, not only switching soi but also e.g. switching to az/el on the second left press in a/a and so on. The only thing I've changed is that I've created in Joystick Gremlin long and short button mappings for a/a radar use. This works as advertised on the DMS switch. Short DMS up -> Right OSB11 for Range+ and long DMS up for RECCE.

 

After further investigation it seems like SCS left, right and down for switching between DDIs/MPCD is the problem. Up / ACM is no problem, switching between vacq, wacq etc. is no problem. Long button presses are no problem. Only setting soi is iffy. However if I change button mappings every button press is correctly detected, including long/short.

 

So: Did I do something stupid? Or is this a common problem I didn't know about?

 

I'd be really grateful if somebody could point me in the right direction...

Link to post
Share on other sites

I use a TM WH grip on a VIRPIL base, and I use the CMS switch as SCS.

I do not use any 3rd party software except TrackIR.

Switching SOI between LDDI, RDDI and AMPCD works all the time with a single press.

The symptoms you describe sound like a problem related to your TMS switch.

I would also try what happens if you don't run the Gremlin software, just to be sure.


Edited by LeCuvier

LeCuvier

Windows 10 Pro 64Bit | i7-4790 CPU |16 GB RAM|SSD System Disk|SSD Gaming Disk| MSI GTX-1080 Gaming 8 GB| Acer XB270HU | TM Warthog HOTAS | VKB Gladiator Pro | MongoosT-50 | MFG Crosswind Pedals | TrackIR 5

Link to post
Share on other sites
3 hours ago, LeCuvier said:

I use a TM WH grip on a VIRPIL base, and I use the CMS switch as SCS.

I do not use any 3rd party software except TrackIR.

Switching SOI between LDDI, RDDI and AMPCD works all the time with a single press.

The symptoms you describe sound like a problem related to your TMS switch.

I would also try what happens if you don't run the Gremlin software, just to be sure.

 

 

Thanks! I just fired up my old Joystick Gremlin profile without long button presses and everything worked flawless. At least its not a hardware problem.

I guess I will have to tinker with the Gremlin. The ability to set range, scan width and height and other stuff is just too nice. Well, there goes my afternoon. 😕

Link to post
Share on other sites

Well, I found the culprit. 🙂

The Tempo function of Joystick Gremlin sends only a very short pulse on short press - too short for DCS to register it reliably as button press it seems, at least as a press on the simulated stick in the cockpit. OSBs don't seem to be a problem.

 

However I was able to circumvent the problem by creating macros with a very short pause between the the button press and release. So once again Joystick Gremlin saves my day...

 

@BIGNEWY Maybe this thread could be sent to the Input and Output-Forum. Thanks!

Gremlin Macro.jpg

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...