Jump to content

HOTAS button inputs stop registering?


Recommended Posts

Hi all, I'm pretty new to DCS still so it might be me doing something by accident that is blocking button presses on the HOTAS being registered, but from time to time while flying I'll notice that my inputs are not being registered, but if I tap ESC twice to open and close the menu, the inputs start working as expected again.

 

Not sure if this is F-16 specific as it's the only thing I've really been flying so far, but has anyone else experienced something similar?

 

 

EDIT: 

found this from 2018, but nothing helpful there unfortunately

 

EDIT EDIT: 

After a bit more digging, it may be that the DCS window is losing focus some how, will have to do some further testing to confirm if that is the case.


Edited by yinlad
Link to post
Share on other sites

Not had any luck resolving this on my side but for some more context, I'm running DCS on my primary monitor, with secondary monitor displaying discord etc...

 

During flight DCS just stops responding to all button presses from input devices that aren't mouse and keyboard. I thought it may be other programs pulling the focus from DCS but this still happens when DCS is the only program I have actively running on the PC.

 

This happened before and after I started using Track IR and happens seemingly at random, but at least once every few minutes, forcing me to double tap escape with the keyboard to regain input presses from the HOTAS.

 

As you can imagine when this happens during combat it's sub optimal to say the least. Wondering why missiles wont fire or uncage before realizing it's the bug and I need to reach for the keyboard etc.etc.

 

I've yet to test in another airframe but will do that today to see if it's F16 specific or DCS in general


Edited by yinlad
Link to post
Share on other sites

perhaps it is the hotplug usb issue. create a file in notepad called "autoexec.cfg. save it in saved games\dcs\config

 

put this line in it. 

 

no_device_hotplug = true

  • Thanks 1

AKA_SilverDevil

==========================================

Go to Heaven for the climate, Hell for the company.

Mark Twain

Link to post
Share on other sites

Just as a guess since i had something similar: might there be any hotas buttons bound to Discord? In Settings there are binds possible in "Keybinds" and also "Overlay" where latter gave me some issues by being on my throttle - no clue if this was set by me in accident or automatically.

  • Thanks 1

bts_100.jpg.22eae5ddd2a463fc09375990ad043870.jpg

 

Hardware: MSI B450 Gaming Plus MAX | Ryzen 5 3600X (6*3.8 Ghz) | 16 GB RAM | MSI Radeon RX5700 | Samsung SSD 860 QVO 1TB | Win 10 (64-bit) TM Warthog HOTAS, MFD and rudder pedals, TrackIR5

Wishlist:  Northern Germany/Baltic Sea theater | DCS level Su-25A or SM

Link to post
Share on other sites
5 hours ago, silverdevil said:

perhaps it is the hotplug usb issue. create a file in notepad called "autoexec.cfg. save it in saved games\dcs\config

 

put this line in it. 

 

no_device_hotplug = true

 

initial test is promising. Ill update after a few more hours of flight today

Link to post
Share on other sites
5 hours ago, silverdevil said:

perhaps it is the hotplug usb issue. create a file in notepad called "autoexec.cfg. save it in saved games\dcs\config

 

put this line in it. 

 

no_device_hotplug = true

ah no dice it has just happened to me again 😞

Link to post
Share on other sites

this is now a setting in the normal options page too i found today. did this problem always occur? reaching here but maybe you are in easy mode (i thinks its called) its where all the controls are different.

AKA_SilverDevil

==========================================

Go to Heaven for the climate, Hell for the company.

Mark Twain

Link to post
Share on other sites
5 minutes ago, silverdevil said:

this is now a setting in the normal options page too i found today. did this problem always occur? reaching here but maybe you are in easy mode (i thinks its called) its where all the controls are different.

Ive always had it in the f16. Don't recall getting it in the fc3 F15 when I ran that a bit before the f16 but ill go back and do a few f15 missions to test. And Im not running the easy mode f16, no

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...