Jump to content

Missile doesn't fire in MSL mode


Recommended Posts

I don't believe it's a bug, but I cannot figure out what I'm missing. I'm sure I went through all the steps. The 2 missiles are activated (switches UP), Sight Mode switch is on MSL, I have Lock and in-range indication and the sidewinder growl goes to a higher pitch when I point to the target. But when I push & hold the button bound to Weapon Release, or hit RAlt + SPACE, no missile fires.

What might I be missing?

LeCuvier

Windows 10 Pro 64Bit | i7-4790 CPU |16 GB RAM|SSD System Disk|SSD Gaming Disk| MSI GTX-1080 Gaming 8 GB| Acer XB270HU | TM Warthog HOTAS | VKB Gladiator Pro | MongoosT-50 | MFG Crosswind Pedals | TrackIR 5

Link to post
Share on other sites

External stores selector set to safe (12 o'clock position)? and select jettison switch off (centred)?


Edited by Northstar98

Modules I own: F-14A/B, F/A-18C, Supercarrier, F-16CM, AJS-37, F-5E-3, MiG-21bis, Ka-50, A-10C (+ A-10C II), UH-1H, Mi-8MTV2, P-47D, P-51D, FC3, MiG-15bis, Yak-52, CA, C-101, Hawk

Terrains I own: Syria, The Channel, SoH

 

System (RIP my old PC): Dell XPS 15 9570 w/ Intel i7-8750H, NVIDIA GTX 1050Ti Max-Q, 16GB DDR4, 500GB Samsung PM871 SSD (upgraded with 1TB Samsung 970 EVO Plus SSD)

 

VKB Gunfighter Mk.II w. MCG Pro

 

Dreams: https://uk.pcpartpicker.com/list/mBG4dD

Link to post
Share on other sites

I had this recently with bombs. Everything looked good; no release. I reloaded. Fine after that.

 

I think there is a bug with jettison that can cause stores not be able to be pickled afterwards.

Motorola 68000 | 1 Mb | Debug port

"When performing a forced landing, fly the aircraft as far into the crash as possible." - Bob Hoover.

The JF-17 is not better than the F-16; it's different. It's how you fly that counts.

"An average aircraft with a skilled pilot, will out-perform the superior aircraft with an average pilot."

Link to post
Share on other sites

You said you hear the missile tone, so I assume you have the guns/missile/camera switch in the up position (has red cover).  That and what Northstar98 said, plus you said you have the outer toggle switches up.  Oh, and did you press and hold the weapon release button?  It takes 1-2 seconds before the missile is fired.


Edited by 609_Relentov
Link to post
Share on other sites
18 hours ago, Dragon1-1 said:

Master Arm? 

Master Arm switch? I've been trying to find one with no success. The "guns/missile/camera" switch was in UP position.

 

11 hours ago, Bravelink03 said:

Yea same, cause theres a variety of reason why this may happen, have you tried DG missile mode ?

 

 

I tried DM (Dogfight Missile) mode.

LeCuvier

Windows 10 Pro 64Bit | i7-4790 CPU |16 GB RAM|SSD System Disk|SSD Gaming Disk| MSI GTX-1080 Gaming 8 GB| Acer XB270HU | TM Warthog HOTAS | VKB Gladiator Pro | MongoosT-50 | MFG Crosswind Pedals | TrackIR 5

Link to post
Share on other sites
17 hours ago, WatchYour6 said:

LeCuvier can you send a pic of the cockpit when this happens? Just wanna see your button setup!

I found my mistake after I had posted the screenshot. It was the "Select Jettison" switch. Thanks to all for your help!

Screen_210213_121644.png


Edited by LeCuvier

LeCuvier

Windows 10 Pro 64Bit | i7-4790 CPU |16 GB RAM|SSD System Disk|SSD Gaming Disk| MSI GTX-1080 Gaming 8 GB| Acer XB270HU | TM Warthog HOTAS | VKB Gladiator Pro | MongoosT-50 | MFG Crosswind Pedals | TrackIR 5

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...