Jump to content

High frame time with 5950x


neok
 Share

Recommended Posts

Hey guys, just build a new pc for DCS VR. Im running a 3070 and 5950x 32 gig ram and 980 pro m.2 drive and the G2. I have a problem with cpu frametime being at 22-25 ms. Even with all DCS setting on Low and 50% SS. I get 45-50 frames but with stutters. Is there a setting Im missing? CPU frame time should be much lower.
 

I tried the following today with Ryzen master. Turned off SMT, then turned on Legacy Compatibility Mode (switches off ccd1 and Im left with 8 coes). Turned on Precision Boost Overdrive. Then switched to Auto overclock. .... Nothing Changed... still steady 22 to 25 cpu frametime. What in the hell is causeing this? 
 

I don’t think I’m getting peak clocks of 4.9ghz. Why would that happen?

C443525A-CD53-4C34-8671-F9302F809186.jpeg

Link to comment
Share on other sites

  • 1 month later...

I get the same thing with 3900x . I have tried everything and cant get it lower....I have literally run on as low setting as you can get and nothing changes! .... I have tried every known external change (AV, Pre Render, AGU, HPET  etc etc) and again Nada.....Its not environmental as doesn't happen with other programs...it is exclusive to DCS. 😒 

 

Looks like NO VR until Vulkan whenever that may be !!!!

Link to comment
Share on other sites

Have you guys tried the 1usmus power plan? It doesn’t really increase frame rates per se, but it greatly improved smoothness for me, especially in Syria (3900X)

 

I guess what it does is force threads to stay on the same CCX and CCD, reducing thread hop between them and the increased latency that comes with it. It’s also supposed to help with the boost problems of the 3000 series.  
 

These problems were supposed to be fixed by the windows scheduler and BIOS updates, but I personally found this power plan made it even better. Again, not so much higher frames as more consistent frames.

 

I don’t know if it will work for 5000 series, but might be worth a try.

 

https://www.guru3d.com/files-details/1usmus-custom-power-plan-for-ryzen-3000-download,7.html

 

 

Ryzen 9 3900X / Asus Crosshair VI Hero X370 / Corsair H110i / Sapphire Nitro+ 6800XT / 32Gb G.Skill TridentZ 3200 / Samsung 960 Evo M.2 / Virpil Warbrd base + VFX and TM grips / Saitek X56 Throttle / Saitek Pro Combat pedals / Rift S

Link to comment
Share on other sites

  • 3 months later...

Installed my 3090 today and still get the same stuttering. This has nothing to do with gfx settings. This is ONLY happening in DCS with the G2. If anybody has a solution please let me know. I tried everything I could find on the internet with no luck. 

Link to comment
Share on other sites

3 minutes ago, neok said:

Installed my 3090 today and still get the same stuttering. This has nothing to do with gfx settings. This is ONLY happening in DCS with the G2. If anybody has a solution please let me know. I tried everything I could find on the internet with no luck. 

 

What if you exit FpsVR in-game (or don't use it at all)? I get major stuttering in DCS if I use FpsVR overlay.

Link to comment
Share on other sites

makes no difference, im running a stock 5950X, 3090 aorus master and 32 gigs of ram. Everything is on m.2 drives. It should run smooth. Every other game in VR is . If I lower all gfx settings and put Stem VR SS to 20% I get the same issue. I dont have the issue with my cv1. Something is up with the G2/WMR and DCS combination.

 

Link to comment
Share on other sites

Can you confirm Hardware Accelerated GPU Scheduling is OFF, and do you use Resizable BAR? 

 

Turn Off Hardware Accelerated GPU Scheduling in Settings
  1. Open Start Menu and tap on Settings cog icon.
  2. In Settings, click on 'System' and open 'Display' tab.
  3. Under the “Multiple Displays” section, select “Graphics settings”.
  4. Turn off “Hardware-accelerated GPU scheduling” option.
  5. Restart the system.

Edited by Marco Schaap
Added description to turn off HAGS
Link to comment
Share on other sites

1 hour ago, neok said:

yes and yes.

I had Thud himself tweak my windows machine. So thats all tuned to perfection. 

 

I dunno who Thud is, but that's even more weird. Could you maybe post your Nvidia driver settings for DCS (or global if you don't have any specific Nvidia profile) and in-game settings including System and VR tab?


Edited by Marco Schaap
Link to comment
Share on other sites

Thud is the guy thats running https://vr4dcs.com/ 

The ingame setting don't matter, since even with everything turned down/ off, lowest resolution and even steam VR SS to 20% I still get the same stutters when looking to the side close to the ground. cpu frame time is always around 25ms.

 

My nvidia settings match what is recommended on vr4dcs:

 

https://vr4dcs.com/2020/10/19/fix-nvidia-g2-control-panel-settings/

Link to comment
Share on other sites

Bios Settings?

Try to load default values and disable XMP-Profile just for testing.

Just as a reference - on a 5900X (not the same, I know) the frametime is around 6 ms...

 

You could also try to disable one ccx and see if that makes a difference.

 

edit: latest bios and chipset driver updates?


Edited by Hiob
Link to comment
Share on other sites

Mystery-error - I hate those...

sorry man, nothing else up my sleeve atm...

 

edit: far fetched - you can force DCS to utilize only certain cores (in the taskmanager). Try different cores, see if it makes a difference.


Edited by Hiob
Link to comment
Share on other sites

Have you checked your Windows Advanced power settings - and ensure they are set to 'High' or 'Extreme', and not Balanced?

 

Start; Settings; System; Power and Sleep; Additional Power Settings - Choose or Customise a Power Plan.

AMD Ryzen 5 5600X; ASUS ROG Strix X570-F, Patriot Viper Steel 32GB (2x 16GB) 3200MHz; Seagate FireCuda 510 500GB M.2-2280 (OS); Samsung 860 EVO 2TB M.2-2280 (DCS); MSI GeForce RTX 3070 SUPRIM X 8GB OC GPU. TM Warthog Hotas; T.Flight Pedals; DelanClip.

Link to comment
Share on other sites

I'm sure you checked this already, but have yu running any other third party apps in the background (like geforce experience, rgb-software, ...)

Link to comment
Share on other sites

@neok i am going to merely suggest what i found causing some issues i had on a previous rig before this one i now have. i had windows desktop background set as 'slideshow'. look at this post:

 

  

On 3/29/2021 at 5:10 PM, silverdevil said:

...so i ran across something of interest for my noted issues. i found that one of my issues was causing windows file explorer to freeze for a second and then refresh, making the top sorted files go to the top. i did some digging and found that some people had this issue and the fix was to turn off the Windows slide show. it also seemed to affect chrome. since i stopped my slideshow, i no longer have the stutter issue. i know odd but maybe worth a shot to at least try.

 

even though it is weird for sure, anything graphics related, even those operations in the background, can cause frame times increase.

 

also look at this thread which i found during my quest.

 

https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/216461/help-me-fix-60-fps-stutter-issue-aka-frame-time-is/

 

since you said you got a new gfx card and are still having issue, i believe that your issue lies somewhere else in the maze of circuitry.

AKA_SilverDevil AKA Forums My YouTube

==============================================================

Go to Heaven for the climate, Hell for the company. Mark Twain

==============================================================

Alienware Aurora R12, 2TB M.2 PCIe SSD, RTX 3090 24GB , i9 11900KF, 128GB Quad Channel DDR4 XMP at 3400MHz, Dell AW3420DW

Link to comment
Share on other sites

On 7/19/2021 at 11:39 AM, Marco Schaap said:

Can you confirm Hardware Accelerated GPU Scheduling is OFF, and do you use Resizable BAR? 

 

Turn Off Hardware Accelerated GPU Scheduling in Settings
  1. Open Start Menu and tap on Settings cog icon.
  2. In Settings, click on 'System' and open 'Display' tab.
  3. Under the “Multiple Displays” section, select “Graphics settings”.
  4. Turn off “Hardware-accelerated GPU scheduling” option.
  5. Restart the system.

 

 

What happened to this anyway? I had this setting in WIndows 2004, but it's not present in 21H1 anymore.

dcsdashie-hb-ed.jpg

 

Link to comment
Share on other sites

this is a bit embarrassing....

 

I figured it out...

The reason for my high cpu frame time lies in all the monitor exports I'm doing when flying on flatscreen for my cockpit....
I renamed the scripts folder. It runs butter smooth now. oh well, it just took me half a year to find out.
everything is working now 🙂
As always, user error 😄
  • Like 3
  • Thanks 1
Link to comment
Share on other sites

On 7/26/2021 at 4:36 PM, neok said:

this is a bit embarrassing....

 

I figured it out...

The reason for my high cpu frame time lies in all the monitor exports I'm doing when flying on flatscreen for my cockpit....
I renamed the scripts folder. It runs butter smooth now. oh well, it just took me half a year to find out.
everything is working now 🙂
As always, user error 😄

Aww man... Glad you figured it out! 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...