Jump to content

ATi/AMD Catalyst 8.7 released


Recommended Posts

In the process of being uploaded to the master servers as of this post being made, should be complete and ready for download about now :) (edit: it may say 8.6 in the browser header, just ignore)

 

XP 32 http://game.amd.com/us-en/drivers_catalyst.aspx?p=xp/radeonx-xp

XP 64 http://ati.amd.com/support/radeonx-xp64.html

XP MCE http://ati.amd.com/support/radeonx-mce.html

Vista 32 http://ati.amd.com/support/common-vista32.html

Vista 64 http://ati.amd.com/support/common-vista64.html

  • Like 1
Link to comment
Share on other sites

Any news on the reduction of heat and power consumption on the HD 48xx cards? I´ve read that some manufacturers released new Bios versions because the first versions had too high idle clock speeds.

 

Hmmm, i *don't* think that there is any mention of what you describe, check the release notes.

 

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/gamesite/Catalyst_87_release_notes.html

 

EDIT: seems we cannot hotlink to that page, just click on one of links in my first post and check the release notes from there :)

Link to comment
Share on other sites

ah, these are same crap as all previous ones... they still haven't fixed microstuttering on multi GPU cards and CF... what a bull really... I will never again buy multi GPU card or go CF...

No longer active in DCS...

Link to comment
Share on other sites

Hm. Using the uninstall-utility first and removing the chipset-software (did they mean GPU-BIOS? I didn't do the initial translation...) as well as the previous drivers had some interesting benefits. All of a sudden many character models (and the compass) are again visible in NWN, recent versions of X-Plane play nice for once (as long as HQ AF is turned off). WTH, it works (FINALLY!), and that's cool with me.

Link to comment
Share on other sites

ah, these are same crap as all previous ones... they still haven't fixed microstuttering on multi GPU cards and CF... what a bull really... I will never again buy multi GPU card or go CF...
:huh:

Kuky! You scare me now. I've just ordered two PowerColor HD4850 for CF. On what Windows you get stuttering? Vista64? Can you give me your whole rig specification?


Edited by Poko24
Link to comment
Share on other sites

er... sorry Poko but the truth is I am not 100% happy with having CF setup right now... reason is this microstuttering I am getting every now and then... I can't figure out why sometimes I get it sometimes not... but I think it happens only online.

 

I just feel after having the HD3870X2 and now 2x HD4870 in CF I am gettings this distinct microstutters. See when you enable v-sunc it's suposed to limit the game framerate to max of monitor refresh rate... when I get this microstutter I check framerate with ingame counters (CTRL/BCKSPC) I see framerate jumping from 60 to 80 and so about every second, as if the 2x GPU's are not synced and it goes away only if I disable Catalyst AI in ATI CCC, but this in turn (they say) disables CF so I don't know what the heck. Sometimes I leave Catalyst AI on (on standard) and it works fine.. and again sometimes it stutters like crazy... gladly it's not very often but it does happen... don't know, maybe its some network issue or even server... maybe it's something else in my system... maybe it's just the drivers... I don't know. It would be best if anyone else could post if the have same issue, if there is someone else that has same cards in CF.

 

Anyway, if you just ordered the two cards you could quickly edit your order and get single 280GTX instead, they perform about the same and cost about the same also.

 

Here's my system specs:

Windows XP Pro SP3

2x 2GB of DDR2 PC8500

Asus P5Q-E motherboard

E8500 overclocked to 4GHz / watercooled

X-Fi Xtremegamer

1000rpm Raptor SATA HDD, another 7200rpm SATA HDD, SATA DVD-RW, floppy... etc etc and my flight gear (Cougar, peddals, TrackIR). Current PSU is 650W+550W Neo Link (650W for Mobo/CPU/VGA and 550W for peripherials) and I am suspecting the 650W PSU is bit on the edge for this hardware so I will be replacing the dual PSU with single 1200W one...

 

PS: but hey... even with this occasional stuttering the cards are still very good, I am also thinking it could be just my PSU that's giving me occasional system restarts and game crashes (at first I thought it was the video cards :D) and sorry to scare you... maybe I'm just too emotional when it comes to things not working 100% the way I want them to :)

No longer active in DCS...

Link to comment
Share on other sites

Too late to change my order :). My coming rig is kind similar to yours - different are mainboard (Gigabyte GA-X48-DS5) and RAM (Geil Pc1066 2x2048mb Cl5 Evo). Let's see how this will work. I post news later next week.

Link to comment
Share on other sites

er... sorry Poko but the truth is I am not 100% happy with having CF setup right now... reason is this microstuttering I am getting every now and then... I can't figure out why sometimes I get it sometimes not... but I think it happens only online.

 

I just feel after having the HD3870X2 and now 2x HD4870 in CF I am gettings this distinct microstutters. See when you enable v-sunc it's suposed to limit the game framerate to max of monitor refresh rate... when I get this microstutter I check framerate with ingame counters (CTRL/BCKSPC) I see framerate jumping from 60 to 80 and so about every second, as if the 2x GPU's are not synced and it goes away only if I disable Catalyst AI in ATI CCC, but this in turn (they say) disables CF so I don't know what the heck. Sometimes I leave Catalyst AI on (on standard) and it works fine.. and again sometimes it stutters like crazy... gladly it's not very often but it does happen... don't know, maybe its some network issue or even server... maybe it's something else in my system... maybe it's just the drivers... I don't know. It would be best if anyone else could post if the have same issue, if there is someone else that has same cards in CF.

 

Anyway, if you just ordered the two cards you could quickly edit your order and get single 280GTX instead, they perform about the same and cost about the same also.

 

Here's my system specs:

Windows XP Pro SP3

2x 2GB of DDR2 PC8500

Asus P5Q-E motherboard

E8500 overclocked to 4GHz / watercooled

X-Fi Xtremegamer

1000rpm Raptor SATA HDD, another 7200rpm SATA HDD, SATA DVD-RW, floppy... etc etc and my flight gear (Cougar, peddals, TrackIR). Current PSU is 650W+550W Neo Link (650W for Mobo/CPU/VGA and 550W for peripherials) and I am suspecting the 650W PSU is bit on the edge for this hardware so I will be replacing the dual PSU with single 1200W one...

 

PS: but hey... even with this occasional stuttering the cards are still very good, I am also thinking it could be just my PSU that's giving me occasional system restarts and game crashes (at first I thought it was the video cards :D) and sorry to scare you... maybe I'm just too emotional when it comes to things not working 100% the way I want them to :)

 

Hey Kuky :)

 

shot in the dark here....do you by chance have mirrors enabled? (especially medium or low) if so, try turning them off and see if your microstuttering continues.

Link to comment
Share on other sites

Hey Mustang... yes I do have mirrors on and they are on High settings... I'll give it a go... but I'd hate not to have mirrors on :(

 

Rgr, i understand that :thumbup:

 

It's just that, whenever i have mirrors enabled on my HD3850 i get a good FPS but it "jitters" along (what you'd call the microstutter) seeing as we are both running ATi cards i thought it might be the same thing, i might be wrong though.

Link to comment
Share on other sites

After upgrading to 8.6 I had to disable cat AI to stop the entire screen from rolling and generally going crazy. Oddly enough- the display issues seemed to "follow" my mouse cursor up & down the screen. and NATURALLY- there are no problems at all- except in LOMAC. Whooda thunk it?

 

I don't know if disabling AI kills X-fire,too- but last I played it (lomac) was working.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...