Jump to content

Reverb G2


Komrad

Recommended Posts

12 minutes ago, Pikey said:

4 pages on a thread about over aliasing and not one mirror screenshot? You could rule out 4m of cable, a HMD and a human from the equation pretty quickly!

I will try to get a through the lens shot some time today. I once built an eye relief device that attaches a rifle scope to my mobile phone case. Took amazing long distance photos (less the cross hair of course). The device simply applied the same eye relief needed viewing a scope... I figure the same can be achieved for a VR head set.

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

30 minutes ago, Sr. said:

I will try to get a through the lens shot some time today. I once built an eye relief device that attaches a rifle scope to my mobile phone case. Took amazing long distance photos (less the cross hair of course). The device simply applied the same eye relief needed viewing a scope... I figure the same can be achieved for a VR head set.

no no, you missed the point 😄 . The OP complains of blurry aliasing for quite some time and concluded it was the headset. However the video mirror on the desktop shows the actual graphics rendering to a point where you can tell if you are not seeing what you think you should be, without the guesswork. The idea is that, avoid these very long efforts at describing the intangible, because its often the case that the explanations are too difficult and subjective to make it easy for soemone else to help. There's a lot of poeple trying VR who get paralysed by the headset being out of focus, can't rearrange it, forget they need their glasses because they assume you dont need them, etc etc. Reverb especially has sensitive sweetspots, etc.

Mobile phones dont do a bad job but I reckon you custom made rifle scope might be interesting. Additionally there are similar apparatus for viewing and taking pictures of microscopes, telescopes with mobiles, adapters...


Edited by Pikey

___________________________________________________________________________

SIMPLE SCENERY SAVING * SIMPLE GROUP SAVING * SIMPLE STATIC SAVING *

Link to comment
Share on other sites

1 hour ago, Pikey said:

no no, you missed the point 😄 . The OP complains of blurry aliasing for quite some time and concluded it was the headset. However the video mirror on the desktop shows the actual graphics rendering to a point where you can tell if you are not seeing what you think you should be, without the guesswork. The idea is that, avoid these very long efforts at describing the intangible, because its often the case that the explanations are too difficult and subjective to make it easy for soemone else to help. There's a lot of poeple trying VR who get paralysed by the headset being out of focus, can't rearrange it, forget they need their glasses because they assume you dont need them, etc etc. Reverb especially has sensitive sweetspots, etc.

Mobile phones dont do a bad job but I reckon you custom made rifle scope might be interesting. Additionally there are similar apparatus for viewing and taking pictures of microscopes, telescopes with mobiles, adapters...

 

🙂

 

No joy with the HMD.

 

Works great on a mobile phone though. Took these a few years ago at my buddie's place. We were doing a Deer "inventory".

These we taken from several hundred yard with my Samsung Galaxy and the attachment I made out of a gel phone case, some PVC and a short length of 1.5" rubber hose.

 

Max out the scope, then pinch zoom on the phone screen.


 

20171110_164012.jpg

20171110_171821.jpg

  • Like 1

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

Well I had High Hopes for the Reverb G2 and was let down.. Don't get me wrong the image is nicevery clear and crisp but the fact that 3 things where a nogo for me was the let down..

 

1. Speakers had a gap between the ears (I fixed this with my own mod) so all is good.

 

2. Headset FOV seems way less even then my Odyssey Plus. (No Fix for this because my prescription lenses)

 

3. My Headset dies 2 weeks after having it. (Called support they are sending out a new cable)

 

So this is my Personal Opinion. I am unsure but the headset dying because of the cable seems to be a big problem for HP. if this was a occasional murmur on the net I would give it a pass.. But when I called the guy said there are 6 in front of me getting cables..

 

As far as I am concerned HP really dropped that ball on this headset. And I am still unsure if the new cable I am getting is an OLD Batch or a newer designed cable? The other thing that is bad is that I was told I have an up to 2 month backorder for the cable 😞

 

Now Why dont I just return itI already bought the Prescription lenses and they where 115USD Plus I would probally have to pay to ship it back and this thing is pretty big so it would be 40-50USD to ship it back..

 

so basically because I am in it for 115USD for the lenses and don't feel like spending 1KUSD on a Index I am just going to wait it out.. I hope HP sorts this mess out soon..

I would also like them to if they had not already implement some kind of QC..

 

 

ASRock Z590 PHantom Gaming 4/AC / Intel i7 10700K @ 5.0Ghz / Noctua DHS-14 / Samsung 980 Pro M.2 1TB / Asus 1080GTX OC /  G. Skill Trident Z CAS 14 - 32GB RAM 3400MHZ XMP Profile / Oculus Rift S VR / HOTAS Cougar & MFD's / Buttkicker game simulation

Link to comment
Share on other sites

  • 2 weeks later...

This post has been so useful!!! I was really struggling with G2 but thanks to Captain Helmets recommendations it is SOOOOO much better. However I just wanted to check my CPU usage. At the moment I just cannot get below 27 CPU Frame time no matter what settings I have and wanted to check this is correct? Has anyone got experience with a 3950x?

 

My Spec / Settings are as follows:

 

CPU: Ryzen 3900x set to SMT OFF profile and running at 4300 on all cores. No Auto OC or PB.

GPU: RTX 2080TI (Asus ROG Strix) - Overclocked to 1800 and 16100 Mem clock. 

MEM: 16GB 3600 DDR4 (another 16 arriving shortly!)

 

DCS set to PD 1.

SVR Set to Global 100% / DCS 54%

Textures: High

Terrain: Low

Water: High

Visibility: Med

Shadows: Med (Hate it without shadows!)

MSAA x 4 (no difference on x 2 really)

CLutter 100%

Tree Vi 80%

Preload - Half way on Slider. 

Ani - x 8

Terrain Shadows: Flat (with Flat Tree remover etc)

 

Thanks for any help

 

PS Obviously trying to get hold of a 3080 but alas no joy. But now wondering if it would it be better to get a 5950x CPU first?  

 

 

Capture.PNG


Edited by funkster
Link to comment
Share on other sites

1 hour ago, funkster said:

This post has been so useful!!! I was really struggling with G2 but thanks to Captain Helmets recommendations it is SOOOOO much better. However I just wanted to check my CPU usage. At the moment I just cannot get below 27 CPU Frame time no matter what settings I have and wanted to check this is correct? Has anyone got experience with a 3950x?

 

My Spec / Settings are as follows:

 

CPU: Ryzen 3950x set to SMT OFF profile and running at 4300 on all cores. No Auto OC or PB.

GPU: RTX 2080TI (Asus ROG Strix) - Overclocked to 1800 and 16100 Mem clock. 

MEM: 16GB 3600 DDR4 (another 16 arriving shortly!)

 

DCS set to PD 1.

SVR Set to Global 100% / DCS 54%

Textures: High

Terrain: Low

Water: High

Visibility: Med

Shadows: Med (Hate it without shadows!)

MSAA x 4 (no difference on x 2 really)

CLutter 100%

Tree Vi 80%

Preload - Half way on Slider. 

Ani - x 8

Terrain Shadows: Flat (with Flat Tree remover etc)

 

Thanks for any help

 

PS Obviously trying to get hold of a 3080 but alas no joy. But now wondering if it would it be better to get a 5950x CPU first?  

 

 

Capture.PNG

 

What windows release are you running? I have a very similar setup to yours(3900x with 2080ti) and my cpu frame times looked just like yours when I upgraded to windows 20H2 from 1909. Not sure what happened either some windows setting got reset or what, but when I upgraded to 20H2 my cpu frame times tanked. My solution was to go back to 1909 and my cpu frame times went back to being much better...nowhere near 27 ms.

 

I'll have to research further what was actually going on, but for now downgrading windows helped me.

Link to comment
Share on other sites

1 hour ago, funkster said:

This post has been so useful!!! I was really struggling with G2 but thanks to Captain Helmets recommendations it is SOOOOO much better. However I just wanted to check my CPU usage. At the moment I just cannot get below 27 CPU Frame time no matter what settings I have and wanted to check this is correct? Has anyone got experience with a 3950x?

 

My Spec / Settings are as follows:

 

CPU: Ryzen 3950x set to SMT OFF profile and running at 4300 on all cores. No Auto OC or PB.

GPU: RTX 2080TI (Asus ROG Strix) - Overclocked to 1800 and 16100 Mem clock. 

MEM: 16GB 3600 DDR4 (another 16 arriving shortly!)

 

DCS set to PD 1.

SVR Set to Global 100% / DCS 54%

Textures: High

Terrain: Low

Water: High

Visibility: Med

Shadows: Med (Hate it without shadows!)

MSAA x 4 (no difference on x 2 really)

CLutter 100%

Tree Vi 80%

Preload - Half way on Slider. 

Ani - x 8

Terrain Shadows: Flat (with Flat Tree remover etc)

 

Thanks for any help

 

PS Obviously trying to get hold of a 3080 but alas no joy. But now wondering if it would it be better to get a 5950x CPU first?  

 

 

Capture.PNG

 

 

Wow. I'm running a 3900X (I do enable "Game Mode" in Ryzen Master), but even with it Off I get the following.

Is your RAM running an XMP profile? (mine same speed you listed, but 64GB) with a 1080ti

 

A 3900X and 3950X bench very similarly. 

CPU.JPG


Edited by Sr.
Edit: also running Win10 Pro 20H2

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

38 minutes ago, toffy said:

 

What windows release are you running? I have a very similar setup to yours(3900x with 2080ti) and my cpu frame times looked just like yours when I upgraded to windows 20H2 from 1909. Not sure what happened either some windows setting got reset or what, but when I upgraded to 20H2 my cpu frame times tanked. My solution was to go back to 1909 and my cpu frame times went back to being much better...nowhere near 27 ms.

 

I'll have to research further what was actually going on, but for now downgrading windows helped me.

  Funny enough 20H2!! Do you believe this is the issue? 

 

29 minutes ago, Sr. said:

 

 

Wow. I'm running a 3900X (I do enable "Game Mode" in Ryzen Master), but even with it Off I get the following.

Is your RAM running an XMP profile? (mine same speed you listed, but 64GB) with a 1080ti

 

A 3900X and 3950X bench very similarly. 

CPU.JPG

 

 

Yeah I run DOCP in bios (same thing I believe).  There is definitely something not right comparing it to you/toffy! Might try rolling back the OS to 1909.  Doesnt appear I can roll back now 😞

 


Edited by funkster
Link to comment
Share on other sites

19 minutes ago, funkster said:

  Funny enough 20H2!! Do you believe this is the issue? 

 

 

Yeah I run DOCP in bios (same thing I believe).  There is definitely something not right comparing it to you/toffy! Might try rolling back the OS to 1909.  Doesnt appear I can roll back now 😞

 

 



I'm also running 20H2

 

You may have a few other services/apps that are hogging CPU. A big one for me in the past was AWCC (Alienware Command Center), it's only there because I have an AW display. I disabled it once I realized how much it was taxing CPU cycles.


Edited by Sr.
  • Like 1

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

3 hours ago, funkster said:

This post has been so useful!!! I was really struggling with G2 but thanks to Captain Helmets recommendations it is SOOOOO much better. However I just wanted to check my CPU usage. At the moment I just cannot get below 27 CPU Frame time no matter what settings I have and wanted to check this is correct? Has anyone got experience with a 3950x?

 

 

 

 

 

 

I'm glad that sharing my experiences were helpful to someone else!  There is a lot of trial and test involved.

I run a stock 3900x as well with a rtx2070, and while I can't remember the frame times off the top of my head my cpu time stays in the green on lighter single player missions.

I wouldn't be surprised if 16GB of ram is one of your limiting factors here.  Those spikes could possibly be page file reads and writes.  Also make sure you have XMP mode enabled so your ram is running at proper speed.  Ram may not be the main cause of your issues, but increasing your ram should make things more stable.

The magnitude of the penalty for using MSAA depends on what you are looking at; jumping from 2x to 4x definitely hits my gpu frame times, but if you can get away with it good for you!  I try to balance resolution vs MSAA.   Resolution makes your cockpit more readable and helps with spotting distant planes, MSAA helps with shimmer of high contrast edges like thin wires, bright sun on the tops of buildings, and especially runway lights.  Flying into Nellis at dusk with Vegas in the distance looks great with some MSAA.

Make sure all of your Microsoft "game mode" and "game dvr" options are disabled in your Windows settings (this is different than your bios game mode).  Also hardware accelerated gpu scheduling causes a lot of issues for me so make sure that is disabled as well.

In the nvidia control panel if you set "Virtual Reality pre-rendered frames" above 1 that can also hurt your cpu frame times, so I would keep that at 1 if you haven't.

Link to comment
Share on other sites

4 hours ago, funkster said:

 

Capture.PNG

 

 

for the purposes of diagnostics i would turn off MSAA, Shadows, and mirrors ...but i suspect its something environmental eating your CPU frametime )as @Sr. observes

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

1 minute ago, speed-of-heat said:

 

for the purposes of diagnostics i would turn off MSAA, Shadows, and mirrors ...but i suspect its something environmental eating your CPU frametime )as @Sr. observes

Another culprit for me was GEForce Experience. Since I rarely capture video, I decided to uninstall it. Others have luck simply disabling the shadowplay until they need it.

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

for me there were a few big culprits:

 

- HPET absolutely should be turned off (at least on intel, not sure about the Ryzan side of the house)

- ICue is a CPU cancer

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

4 hours ago, Sr. said:



I'm also running 20H2

 

You may have a few other services/apps that are hogging CPU. A big one for me in the past was AWCC (Alienware Command Center), it's only there because I have an AW display. I disabled it once I realized how much it was taxing CPU cycles.

 

Wow ! Interesting but if you disable AWCC will it still run your overclock settings/Thermals? Not like I need too with my new R11 but I still have a R9 - i7-9700K w/ a 2080 super that was struggling with my G2. This R11 I have no problems at all with mostly everything on high settings. 

ALIENWARE R11 - I9 10900KF @ 4.8-4.9 GHz OC Disabled - M.2 NVMe 2TB - RTX3090 NV Driver 471.41 OC Disabled - XFURY 64GB -3400 MHz RAM

Monitor AW3420DW @ 120Hz - TM Warthog Hotas & TPR Rudder pedals - Monstertech Mounts - TrackerIR w/ProClip -HP G2 - Tacview/Disabled

RealSimulator FSSB-R3 Lightning Base - F16SRGRH Stick - Open Beta 2.7

Start Date April 2020

 

Link to comment
Share on other sites

8 minutes ago, Burt said:

 

Wow ! Interesting but if you disable AWCC will it still run your overclock settings/Thermals? Not like I need too with my new R11 but I still have a R9 - i7-9700K w/ a 2080 super that was struggling with my G2. This R11 I have no problems at all with mostly everything on high settings. 


I only have a Alienware 240hz monitor, so it was unnecessary for me.
My rig is home built.


Edited by Sr.

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

Gotcha, yeah I hope to build one in the near future.

ALIENWARE R11 - I9 10900KF @ 4.8-4.9 GHz OC Disabled - M.2 NVMe 2TB - RTX3090 NV Driver 471.41 OC Disabled - XFURY 64GB -3400 MHz RAM

Monitor AW3420DW @ 120Hz - TM Warthog Hotas & TPR Rudder pedals - Monstertech Mounts - TrackerIR w/ProClip -HP G2 - Tacview/Disabled

RealSimulator FSSB-R3 Lightning Base - F16SRGRH Stick - Open Beta 2.7

Start Date April 2020

 

Link to comment
Share on other sites

Thanks all. 

 

1 hour ago, captainHelmet said:

 

I'm glad that sharing my experiences were helpful to someone else!  There is a lot of trial and test involved.

I run a stock 3900x as well with a rtx2070, and while I can't remember the frame times off the top of my head my cpu time stays in the green on lighter single player missions.

I wouldn't be surprised if 16GB of ram is one of your limiting factors here.  Those spikes could possibly be page file reads and writes.  Also make sure you have XMP mode enabled so your ram is running at proper speed.  Ram may not be the main cause of your issues, but increasing your ram should make things more stable.

The magnitude of the penalty for using MSAA depends on what you are looking at; jumping from 2x to 4x definitely hits my gpu frame times, but if you can get away with it good for you!  I try to balance resolution vs MSAA.   Resolution makes your cockpit more readable and helps with spotting distant planes, MSAA helps with shimmer of high contrast edges like thin wires, bright sun on the tops of buildings, and especially runway lights.  Flying into Nellis at dusk with Vegas in the distance looks great with some MSAA.

Make sure all of your Microsoft "game mode" and "game dvr" options are disabled in your Windows settings (this is different than your bios game mode).  Also hardware accelerated gpu scheduling causes a lot of issues for me so make sure that is disabled as well.

In the nvidia control panel if you set "Virtual Reality pre-rendered frames" above 1 that can also hurt your cpu frame times, so I would keep that at 1 if you haven't.

 

Thanks again Cap. I disabled all the usual culprits (game mode etc) and have DOCP enabled in bios which i believe is XMP? (Motherboard is Asus prime 570x pro). I will check the pre rendered frames as i might have this on 3...might be it!

 

47 minutes ago, speed-of-heat said:

for me there were a few big culprits:

 

- HPET absolutely should be turned off (at least on intel, not sure about the Ryzan side of the house)

- ICue is a CPU cancer

 

What's HPET? 

 

I never install Geforce experience but do have ICUE ..so will disable that as well. 


Edited by funkster
Link to comment
Share on other sites

1 minute ago, funkster said:

What's HPET? 

 

I never install Geforce experience but do have ICUE ..so will disable that as well. 

check my guide My 3090 Settings for my G2 (2.5.6) - Virtual Reality - ED Forums (eagle.ru) it has a section for that

  • Like 1

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

I hey not done the disabling of the HPET yet. Seems pretty simple to do through your guide and may do this evening to see if there is a difference.

  • Like 1

ALIENWARE R11 - I9 10900KF @ 4.8-4.9 GHz OC Disabled - M.2 NVMe 2TB - RTX3090 NV Driver 471.41 OC Disabled - XFURY 64GB -3400 MHz RAM

Monitor AW3420DW @ 120Hz - TM Warthog Hotas & TPR Rudder pedals - Monstertech Mounts - TrackerIR w/ProClip -HP G2 - Tacview/Disabled

RealSimulator FSSB-R3 Lightning Base - F16SRGRH Stick - Open Beta 2.7

Start Date April 2020

 

Link to comment
Share on other sites

Disabling HPET and overclocking my cpu are the two things I have yet to test.  I don't think I will overclock the 3900x as there doesn't seem to be a whole lot to gain from it.  I just used processLasso to manage my cpu affinity and make sure that my dcs and steamVR processes are assigned to the fastest physical cores and don't interfere with one another.

  • Like 1
Link to comment
Share on other sites

FWIW, disabling HPET has never made any difference to my VR performance, one way or the other.

Intel i9 10900K 5.2GHz · MSI Gaming X Trio RTX 3090 · ASUS ROG STRIX Z590-F Wi-Fi · Acer 4K 32" XB321HK · Samsung 970 500Gb M.2 NVMe · 2 x Samsung 850 Evo 1Tb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 10 · Thrustmaster TPR Pedals · TrackIR5 · Thrustmaster F/A-18 Hornet Grip · Virpil WarBRD Base · Virpil Throttle MT-50 CM3 · Virpil Alpha Grip · Virpil Control Panel 2 · Thrustmaster F-16 MFDs · HTC Vive Pro 2

Link to comment
Share on other sites

5 hours ago, funkster said:

Thanks speed. You guys are awesome !

 

 

Let us know if you are able to resolve your issues. I have nearly the identical system you have including SMT disabled, but with 32 gb of RAM and when I was running DCS in 20H2 my fpsVR looked exactly like your picture. 


Edited by toffy
Link to comment
Share on other sites

 

4 hours ago, toffy said:

Let us know if you are able to resolve your issues. I have nearly the identical system you have including SMT disabled, but with 32 gb of RAM and when I was running DCS in 20H2 my fpsVR looked exactly like your picture. 

 

Sure thing.  I will be doing some more testing later today so will feedback. 

Link to comment
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...