Jump to content

Recommended Posts

So I have got a very annoying problem with my new G2, that I have tried everything I can think of to solve.

 

The problem is I have a shocking case of aliasing (at least that's what is looks like).  This aliasing (for want of a better word) is visible in the cockpit to some degree but the outside views are horrendous. 

Every single object (mid to long distance) has this horrible shaking/vibrating effect.  I don't think this problem is related specifically to DCS because the same problem occurs with MSFS 2020.

 

I have tried increasing mssa settings within DCS and increasing the resolution per eye setting within steamvfr but all that does is lower performance without solving the problem.

My system is a 5950x and RTX 3090 wth 32 gigs of ram.  I have tried the earliest driver that is available for the 3090 and the latest with hotfix.

 

I am very close to assuming there is something wrong with the G2 itself, but have posted here in the hope that you experienced VR guys can provide a solution.

 

Thanks.

 

Link to post
Share on other sites

Can't say I am seeing what you are describing here in my Reverb G2.

What resolution are you running in it?

I am running 100% resolution with Motion Smoothing forced on and high gfx settings.

No MSAA.


Edited by dburne

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites

Unfortunately it takes some math to figure out what resolution you are actually using. Streamvr has its global setting, which then gets multiplied by the per app setting for dcs, then dcs has the pixel density slider in the vr tab. Assuming your global setting is 100%, the per ap setting is 100% and your pixel density is 1.0 you should be getting the full 140% super sample that hp has deemed necessary for combating the barrel distortion of the headset’s lenses. 
 

That said even with everything at 100% I still see a ton of aliasing with medium to far distance objects like you describe.  For fun I cranked it up to 200% to see if it looked any better, and it did help but the effect was still there.  Its especially bad when sitting on the tarmac and looking out the side of the cockpit.  Im assuming the problem is magnified because in stereo the aliasing will be slightly different in each eye. 
 

I think the only real fix would be a more efficient anti aliasing implementation.  I am happy to be wrong if some one else has found a way to minimize the shimmering. 

Link to post
Share on other sites
15 hours ago, dburne said:

Can't say I am seeing what you are describing here in my Reverb G2.

What resolution are you running in it?

I am running 100% resolution with Motion Smoothing forced on and high gfx settings.

No MSAA.

 

Thanks for the reply, no what I am seeing does not seem to be widely reported from viewing various forums.

 

Bryan.

Link to post
Share on other sites
6 hours ago, captainHelmet said:

Unfortunately it takes some math to figure out what resolution you are actually using. Streamvr has its global setting, which then gets multiplied by the per app setting for dcs, then dcs has the pixel density slider in the vr tab. Assuming your global setting is 100%, the per ap setting is 100% and your pixel density is 1.0 you should be getting the full 140% super sample that hp has deemed necessary for combating the barrel distortion of the headset’s lenses. 
 

That said even with everything at 100% I still see a ton of aliasing with medium to far distance objects like you describe.  For fun I cranked it up to 200% to see if it looked any better, and it did help but the effect was still there.  Its especially bad when sitting on the tarmac and looking out the side of the cockpit.  Im assuming the problem is magnified because in stereo the aliasing will be slightly different in each eye. 
 

I think the only real fix would be a more efficient anti aliasing implementation.  I am happy to be wrong if some one else has found a way to minimize the shimmering. 

Taking info from various forums including this one I have tried numerous different settings but at best the problem is at best slightly improved, but it makes me feel sick looking at the view outside, so much so that I have decided to return the G2.

 

Thanks for the reply.

 

Bryan.

Link to post
Share on other sites
3 hours ago, Komrad said:

Taking info from various forums including this one I have tried numerous different settings but at best the problem is at best slightly improved, but it makes me feel sick looking at the view outside, so much so that I have decided to return the G2.

 

Thanks for the reply.

 

Bryan.

Hey Bryan,

Check if you are running at 90hz or 60hz.  I have the 3080 and was playing with settings.  Tried 60hz and it did something that I cant quite describe, but it sounds like what you are talking about.  Buildings and shadows were off, shimmering and almost 3d, but in VR?  Hard to explain, but yeah it made me almost barf.

My personal settings are 100percent in steam, almost all high, no MSAA though.  The key to my best settings was to turn rear projection on WMR to auto.  It drops the frame rates to 45, but it's perfect across the board and rock solid.  I had micro stuttering even at 85fps averages, but the windows rear projection made everything perfect.

 

Link to post
Share on other sites

I think I have the same problem. Very noticeable over the cities. The roofs and balconies of the building drive me crazy. The only solution for me is to set the MSAA to x4, but there is currently an error with the MSAA settings. The settings take effect only after restarting the game.

Ryzen 5900X, 32GB DDR4@3600CL16, ASUS Strix GTX 1080 Ti, PB328Q 32" 2560x1440, Samsung EVO 960 1TB, 2x1000GB RAID 1, 2000GB,

Thrustmaster Warthog + MFG Crosswind, HMD Odyssey+

Link to post
Share on other sites
On 1/25/2021 at 4:55 PM, L8Knight said:

Hey Bryan,

Check if you are running at 90hz or 60hz.  I have the 3080 and was playing with settings.  Tried 60hz and it did something that I cant quite describe, but it sounds like what you are talking about.  Buildings and shadows were off, shimmering and almost 3d, but in VR?  Hard to explain, but yeah it made me almost barf.

My personal settings are 100percent in steam, almost all high, no MSAA though.  The key to my best settings was to turn rear projection on WMR to auto.  It drops the frame rates to 45, but it's perfect across the board and rock solid.  I had micro stuttering even at 85fps averages, but the windows rear projection made everything perfect.

 

Yeah, it's defiantly running at 90hz, at least that's what it's set for.  It's like a blurry filter has been placed over the scenery and no amount of playing around with the settings will remove it.  I think the lenses are possibly defective, will speak to HP support and they can damm well troubleshoot it!

 

Bryan.

  • Thanks 1
Link to post
Share on other sites
2 hours ago, Komrad said:

Yeah, it's defiantly running at 90hz, at least that's what it's set for.  It's like a blurry filter has been placed over the scenery and no amount of playing around with the settings will remove it.  I think the lenses are possibly defective, will speak to HP support and they can damm well troubleshoot it!

 

Bryan.


 

That’s exactly my experience too but only DCS. The stuff in wmr look pretty good. I also wear glasses and it might be my vision. I remember when I got my new glasses it took me a couple of days to let my Brain adapt to the changes. But same here:

ALIENWARE R9 - I7 9700K @ 4.6 - M.2 NVMe 2TB - RTX2080 Super -32gb HyperX Fury Ram AWCC OC Ram2 Enabled @2933Mhz

Monitor AW3420DW @ 120Hz - TM Warthog Hotas & TFRP Rudder pedals - Monstertech Mounts - TrackerIR w/ProClip -HP G2 - Tacview

Stable and Open Beta

Start Date April 2020

 

Link to post
Share on other sites

Hey Brain what did you end up doing? Do you really think it a lense issue? 
 

ALIENWARE R9 - I7 9700K @ 4.6 - M.2 NVMe 2TB - RTX2080 Super -32gb HyperX Fury Ram AWCC OC Ram2 Enabled @2933Mhz

Monitor AW3420DW @ 120Hz - TM Warthog Hotas & TFRP Rudder pedals - Monstertech Mounts - TrackerIR w/ProClip -HP G2 - Tacview

Stable and Open Beta

Start Date April 2020

 

Link to post
Share on other sites
On 1/28/2021 at 2:36 AM, Burt said:

Hey Brain what did you end up doing? Do you really think it a lense issue? 

 


 

HP have agreed to ship a new G2 but it's on backorder, I'm in the UK so not surprised.  As to whether it was the lenses I can't say, but my Wife tried the headset on and could see the same problem with blurred/flickering terrain so it's certainly not my eyes.

 

Strange thing is HP asked for a camera shot through the lenses but try a I might I could not get the phone positioned in such a way to get any kind of image in the photo.  Weird but it seemed as though the lenses were misaligned in some way, how people get those through the lenses videos beats me.

 

Bryan. 

 

 

 

Link to post
Share on other sites

Okay great well it’s good to hear that they at least care. What’s funny is that my wife looked in mine and said it was blurry too so I don’t really know what to think now. It’s just that every YouTube video of a vr headset they are recording their screen which is incredible so that’s what made me get this G2 but I’m at this state right now with honestly not as much testing as I should be doing just do not see the clarity everyone is saying... wmr stuff yes it’s okay but DCS nope. But I did finally get my correct ipd so hopeful I will retest this weekend. I mean it doesn’t matter if I set the resolution to 50- 100- -150 or 200 % and the multiplier at several settings it still the same scotch tape over the lense look but getting 90fps kinda like there is no acceleration what so ever. But I will retest tomorrow. Thanks for your reply and hopefully you get it soon.


Edited by Burt

ALIENWARE R9 - I7 9700K @ 4.6 - M.2 NVMe 2TB - RTX2080 Super -32gb HyperX Fury Ram AWCC OC Ram2 Enabled @2933Mhz

Monitor AW3420DW @ 120Hz - TM Warthog Hotas & TFRP Rudder pedals - Monstertech Mounts - TrackerIR w/ProClip -HP G2 - Tacview

Stable and Open Beta

Start Date April 2020

 

Link to post
Share on other sites

Hello Bryan,

 

Here is something to try if you already havent,

 

Settings in DCS are not taken into account until you restart the game. Changing MSAA and other settings in DCS also do not always seem to take ffect unless you clear the current shaders and let DCS rebuild them based on your new graphics settings. At least it's often like that on my end.

 

To clear shaders open your Saved Games folder and go into DCS or DCS.OpenBeta folder. In there delete all files in folders "fxo" and "metashaders2". Please note that it will take longer time to start the game and then enter flight after this as DCS rebuilds the shaders.

 

Cheers


Edited by jonass1
Link to post
Share on other sites
On 2/2/2021 at 8:44 AM, jonass1 said:

Hello Bryan,

 

Here is something to try if you already havent,

 

Settings in DCS are not taken into account until you restart the game. Changing MSAA and other settings in DCS also do not always seem to take ffect unless you clear the current shaders and let DCS rebuild them based on your new graphics settings. At least it's often like that on my end.

 

To clear shaders open your Saved Games folder and go into DCS or DCS.OpenBeta folder. In there delete all files in folders "fxo" and "metashaders2". Please note that it will take longer time to start the game and then enter flight after this as DCS rebuilds the shaders.

 

Cheers

 

Hi, yes already tried that, tried again but no difference.  I am certain it's the headset.

 

Bryan.

Link to post
Share on other sites

I am see the same thing with my new g2 as well. I have run SS at 100 and up to 150% with no change. i also run 16x AF in game no MSAA and still no help. It does seem a bit blurry at distance as well. My reverb G1 does not have this issue with things at a distance beyond the pit when I run above settings.

System Specs: i9 9900KS, EVGA 2080 TI FTW 3 Ultra OC'd, 32gb Gskill Trident Z Royal ram(for the bling), Samsung 970 PRO M.2 SSD,. Thrustmaster HOTAS Warthog throttle and VKB GF3/MCG PRO stick, MFG Crosswind V2, HP REVERB.

 

DCS modules: F-14, F-18, F-16, A-10, Nevada and PG

Link to post
Share on other sites

Is this maybe a 3080 card issue with the G2?  I have a G2 running on a 2080Ti and have zero issues with any of the above described behavior.  FPS are solid and I'm running 100% SS across the board and MSAA at 2x.  Nice clear, stable and hi rez image with none of the shimmering - as I expected the G2 to be.  It is definitely better than the G1 and the G1 I still have was/is very good.  

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites
14 hours ago, Notso said:

Is this maybe a 3080 card issue with the G2?  I have a G2 running on a 2080Ti and have zero issues with any of the above described behavior.  FPS are solid and I'm running 100% SS across the board and MSAA at 2x.  Nice clear, stable and hi rez image with none of the shimmering - as I expected the G2 to be.  It is definitely better than the G1 and the G1 I still have was/is very good.  

 

So you have zero shimmer of lines or edges on the carrier deck or runways? I have a 2080ti as well and have run both an older driver and the newest. I am running 100% SS with 2x MSAA no shadows and in the pit there is no shimmering but outside on the carrier deck anything at a distance has a bit of a shimmer of Aliasing. Also set it at 16x AF. The deck crew all look slightly blurry unless i go to external view and get right up to them then they look fine with no shimmer or blur. I spoke to the absolutely useless HP tech support yesterday and the guy said that there is nothing they can do to improve it and they can get another headset out to me. THen wasted 5 more minutes of my time and said I have to send mine in first for eval then they would send another one out. Problem is they have none to send out and the normal eval time is 7-10 business days. Given the stock issues it could be weeks to get a replacement and that is only if they decide mine is faulty. I am considering returning it all together and sticking with my G1 which looks just as good. I took pics inside the lens and the colors look exactly the same as well. People say they see better colors but that is clearly a placebo effect of it being "new and improved". The pictures I took show zero difference in saturation or contrast. Everything still looks washed out like the G1.

System Specs: i9 9900KS, EVGA 2080 TI FTW 3 Ultra OC'd, 32gb Gskill Trident Z Royal ram(for the bling), Samsung 970 PRO M.2 SSD,. Thrustmaster HOTAS Warthog throttle and VKB GF3/MCG PRO stick, MFG Crosswind V2, HP REVERB.

 

DCS modules: F-14, F-18, F-16, A-10, Nevada and PG

Link to post
Share on other sites

I have a 2080ti too and with the G2 I had shimmering and aliasing even with msaa 2x and 100% steamvr resolution.

Cockpit looked fine (within the tiny tiny sweet spot), external objects showed a very rapid degradation with distance (10 meters +).

 

Is a mix of useless AA tech (MSAA is pretty useless in 2D 3440x1440 monitor too) and not enough ppi for simming without shimmering.

 

Some people just don't/won't notice.

Link to post
Share on other sites
8 hours ago, BMGZ06 said:

 

So you have zero shimmer of lines or edges on the carrier deck or runways? I have a 2080ti as well and have run both an older driver and the newest. I am running 100% SS with 2x MSAA no shadows and in the pit there is no shimmering but outside on the carrier deck anything at a distance has a bit of a shimmer of Aliasing. Also set it at 16x AF. The deck crew all look slightly blurry unless i go to external view and get right up to them then they look fine with no shimmer or blur. I spoke to the absolutely useless HP tech support yesterday and the guy said that there is nothing they can do to improve it and they can get another headset out to me. THen wasted 5 more minutes of my time and said I have to send mine in first for eval then they would send another one out. Problem is they have none to send out and the normal eval time is 7-10 business days. Given the stock issues it could be weeks to get a replacement and that is only if they decide mine is faulty. I am considering returning it all together and sticking with my G1 which looks just as good. I took pics inside the lens and the colors look exactly the same as well. People say they see better colors but that is clearly a placebo effect of it being "new and improved". The pictures I took show zero difference in saturation or contrast. Everything still looks washed out like the G1.

 

Not that I've noticed.  I'll go back and look closer.  I just tend to concentrate on the flying and the mission itself rather than nitpicking every little detail.  Maybe that's just me......


Edited by Notso

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites
1 minute ago, Notso said:

 

Not that I've noticed.  I'll go back and look closer.  I just tend to concentrate on the flying and the mission itself rather than nitpicking every little detail.  Maybe that's just me......

 

I am chasing the recent FPS drop i got after going to 461.40 driver. It screwed everything up and i went back to old driver with clean install and still no joy. Was getting 90fps over the water at start of F18 case I PG mission. Now getting no more than 53fp spikes and noticeable stutters. My system also forced a win 10 update that took a long time to install. I went as far as disabling HPET, dynamic ticks, and a bunch of other crap and nothing helps now. It was running smooth at 100% SS 3152 x 3086 res I think no MSAA or shadows. I may have to reinstall win 10

System Specs: i9 9900KS, EVGA 2080 TI FTW 3 Ultra OC'd, 32gb Gskill Trident Z Royal ram(for the bling), Samsung 970 PRO M.2 SSD,. Thrustmaster HOTAS Warthog throttle and VKB GF3/MCG PRO stick, MFG Crosswind V2, HP REVERB.

 

DCS modules: F-14, F-18, F-16, A-10, Nevada and PG

Link to post
Share on other sites

Reinstall windows? Yikes that ridiculous. 
I gave the G2 tweaking a break I just got so frustrated with all this. I’m not so worried about the FPS right now I’m looking for the clarity. It’s like I’m looking through the lenses with scotch tape over them. I am hoping it’s not a bad G2 and I may have to call support and ask. I have noticed even in wmr it’s alittle blurry also and words are also out of focus. I finally got my correct ipd so I’m gonna get back to it. I want clarity first and then deal with the fps. Also in the hornet what’s up with the white line circles when I move forward and back? 
anyways good luck.

ALIENWARE R9 - I7 9700K @ 4.6 - M.2 NVMe 2TB - RTX2080 Super -32gb HyperX Fury Ram AWCC OC Ram2 Enabled @2933Mhz

Monitor AW3420DW @ 120Hz - TM Warthog Hotas & TFRP Rudder pedals - Monstertech Mounts - TrackerIR w/ProClip -HP G2 - Tacview

Stable and Open Beta

Start Date April 2020

 

Link to post
Share on other sites
On 2/3/2021 at 6:49 PM, Notso said:

Is this maybe a 3080 card issue with the G2?  I have a G2 running on a 2080Ti and have zero issues with any of the above described behavior.  FPS are solid and I'm running 100% SS across the board and MSAA at 2x.  Nice clear, stable and hi rez image with none of the shimmering - as I expected the G2 to be.  It is definitely better than the G1 and the G1 I still have was/is very good.  

How is this possible? Can you please provide a screenshot of your DCS settings? I don't see how you're running the G2 @ 100%SS, 2x MSAA, on a 2080ti with no shimmering. Over water I could see that but not on the SC or airbases.


Edited by pimp

i9 9900k @5.1GHz h100i |Asus ROG Strix Z390 E-Gaming | Samsung NVMe m.2 970 Evo 1TB | LPX 64GB DDR4 3200MHz

EVGA RTX 2080ti FTW3 Ultra | Reverb G2 | HOTAS Warthog | Saitek Flight Pedals

Link to post
Share on other sites
4 hours ago, Burt said:

Reinstall windows? Yikes that ridiculous. 
I gave the G2 tweaking a break I just got so frustrated with all this. I’m not so worried about the FPS right now I’m looking for the clarity. It’s like I’m looking through the lenses with scotch tape over them. I am hoping it’s not a bad G2 and I may have to call support and ask. I have noticed even in wmr it’s alittle blurry also and words are also out of focus. I finally got my correct ipd so I’m gonna get back to it. I want clarity first and then deal with the fps. Also in the hornet what’s up with the white line circles when I move forward and back? 
anyways good luck.

I also noticed this slight blur in WMR and in DCS. My G1 is actually sharper in all areas. I already tried to deal with HP support and to say they are terrible is an understatement. No clue what they are talking about and just say I can send it in for replacement but they do not know when a replacement will be shipped. IT takes 7-10 days to evaluate my headset before they send anything out and that is if they have any to send. They wont send a replacement first anymore. Also was told if I wanted to return it that I will be charged restocking fee.lol HP is an awful company. Linue Tech Tips did their secret shopper again recently and they had an awful experience with HP as well. HP just doesn't care. I may sell my G2 and G1 and get an Index.

System Specs: i9 9900KS, EVGA 2080 TI FTW 3 Ultra OC'd, 32gb Gskill Trident Z Royal ram(for the bling), Samsung 970 PRO M.2 SSD,. Thrustmaster HOTAS Warthog throttle and VKB GF3/MCG PRO stick, MFG Crosswind V2, HP REVERB.

 

DCS modules: F-14, F-18, F-16, A-10, Nevada and PG

Link to post
Share on other sites

I did another round of settings adjustments today. I was surprised to find that i got better frame rates AND better image quality with 54% steamVR resolution and msaa at 4x than 100% and no Msaa.  It doesn’t fix all of the super carrier aliasing but a lot shimmering while flying is greatly reduced.  It looks great. 
 

After changing the msaa setting you have to restart dcs for the change to take effect. You can see the effect of the msaa by pausing the game and adjusting the msaa mask in the vr settings tab.  Its a shame that there is no performance benefit with the mask. Even a low value of .23 is enough to look great. 

 

That said, I set the hmd mask to .2 which makes the fov like a spy glass and saw no performance improvement either.  So it seems like there is some optimization room. Judging by the way the reflections and effects show up outside the mask I dont think its culling geometry outside of the mask. 


Edited by captainHelmet
Link to post
Share on other sites
5 hours ago, captainHelmet said:

I did another round of settings adjustments today. I was surprised to find that i got better frame rates AND better image quality with 54% steamVR resolution and msaa at 4x than 100% and no Msaa.  It doesn’t fix all of the super carrier aliasing but a lot shimmering while flying is greatly reduced.  It looks great. 
 

After changing the msaa setting you have to restart dcs for the change to take effect. You can see the effect of the msaa by pausing the game and adjusting the msaa mask in the vr settings tab.  Its a shame that there is no performance benefit with the mask. Even a low value of .23 is enough to look great. 

 

That said, I set the hmd mask to .2 which makes the fov like a spy glass and saw no performance improvement either.  So it seems like there is some optimization room. Judging by the way the reflections and effects show up outside the mask I dont think its culling geometry outside of the mask. 

 

Hi Captainhelmet, 

thanks you for sharing your experience and tweaks. I'm a french simmer and got my G2 a couple of days ago. I was expecting a "Waouh" effect right  out of the box on my high end rig (I9 9900K 32Gb RAM / RTX3090). So far I was simming in VR with Reverb G1 and was actually enjoying a lot the smoothness with all sliders maxed out and MSAA 4, Steam VR SS  at 140%. Ghosting at very low altitude / high speed on F18 was barely noticeable when overflying the battlefield with numerous explosions smoke. Like many simmers, I was teased by the G2 ipd manual adjustment device and the promise of an unprecedented clarity, brightness. 

Eventually it's a tremendous disappointment as with no tweaking, right out of the box, unsustainable ghosting is spoiling my visual experience. Yes I can't deny a better clarity, an eye candy colorful image but at the expense of a smaller sweetspot and a laggy ghosting side effect when looking around with the same DCS / Steam VR setting as for the G1. 

I was thinking that the hardware design technology was pretty similar between the two generations. Infact I have to lower my settings and/or Steam VR SS at the point the compromise is not visually acceptable.

So thank you in advance to share with us your progress in tweaking the G2. 

Greetings

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...