Jump to content

Are there any good X52 programming tutorials for DCS?


Barbar
 Share

Recommended Posts

try this...

 

Take a look my mods :joystick: dcs_icons_32.png

CPU: i7 7700 | GPU: GeForce GTX 1080 8GB DDR5 | Motherboard: ASUSTeK PRIME B250M-A | RAM: 2x16GB DDR4-2400 | Output: Kingston HyperX Cloud II | Edifier C2XD 2.1 | Controlls: Saitek X-56 Rhino | Saitek Flight Rudder Pedals | Saitek Multi/Radio/Switch Panels | Thrustmaster MFD Cougar | Logitech G13 | OpenTrack with LaserClip | VoiceAttack with VAICOM Pro plugin

Link to comment
Share on other sites

On 1/22/2021 at 12:48 AM, AtlasR1se said:

At least you have the software, been trying to get hold of it for ages and the downloadable version is 32 bit and won't run on my system.

 

If you want dcs to see your pinkie and mode switches, you should enable clutch mode and disable latched clutch option. If you still want the terrible software, I uploaded 64 bit version for you.
https://www.mediafire.com/file/3ox4m0m5upx1g8g/X52_HOTAS_x64_8_0_213_0.exe/file


Edited by Barbar
Link to comment
Share on other sites

Hi Barbar, thank you very much for the kind upload.

 

Where do I find the options to enable clutch and disable latched options. 

Sorry for being a pain in the proverbial, I got no clue as I'm a bit of a Biff when it comes to these things.

 

Thanks in advance.

  • Like 1
Link to comment
Share on other sites

11 minutes ago, AtlasR1se said:

Hi Barbar, thank you very much for the kind upload.

 

Where do I find the options to enable clutch and disable latched options. 

Sorry for being a pain in the proverbial, I got no clue as I'm a bit of a Biff when it comes to these things.

 

Thanks in advance.

You are welcome Atlas. Unlike what I said, I think enabling clutchmode does not affect DCS seeing pinkie and mode switches. I enabled it and it worked for once, but DCS keeps unseeing those buttons so i am sorry for misinforming you. If you still want to enable or disable clutch modes, you need to go to Windows Control Panel>View devices and printers, right click on X52 and click game controller settings, make sure the X52 is selected and click Properties, then click MFD and you should see clutch mode options on bottom right of the window.

  • Like 1
Link to comment
Share on other sites

15 hours ago, AtlasR1se said:

Once again Barbar, thank you.

 

You my kind man are a true Gent, I will let you shoot me down with an AMRAAM sometime.

 

I am glad I could help you.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...