Jump to content

Recommended Posts

Hi All,

 

I just reinstalled DCS 2.5 beta onto a brand new PC however i am getting in game freezes always. I tried turning down lots of options to test but problem still persists. Anyone can advise on how to resolve this please as i have no idea what to do anymore. I do believe my system can handle DCS now .

All advise is greatly appreciated.

 

Thank you

 

Below are my specs;

 

AMD RYZEN 9 5950X | 4.9 GHZ | 16 Cores 32 Threads

MOTHERBOARD (ULTRACORE) : ASUS ROG STRIX X570-F Gaming

GRAPHICS CARD (ULTRACORE) : ASUS RTX 3090 TUF GAMING OC 24GB

THERMAL COMPOUND : Premium Enthusiast Grade Thermal Compound

RANDOM ACCESS MEMORY (Ultracore/Explorer) : 32GB Corsair Vengence RGB PRO 3600mhz ( 4X8GB )

CPU COOLING SYSTEM (Desktop) : WATERCOOLING : NZXT Kraken Z73 360mm (LED Display)

Primary Solid State Drive (NVME | M.2 | DESKTOP) : 1TB AORUS GEN4 SSD (R: 5000 | W: 4400) (B550|X570 MB Only)

Secondary Solid State Drive Bay : 1TB NVME Gen4 SSD AORUS

If you want Peace, be prepared to fight for it ! :pilotfly:



 

 

Link to post
Share on other sites

Hi. Assuming you don't have HDDs on such a powerful brand new machine, and assuming you haven't messed with Windows pagefile, here are a few things to do/check. After doing each step, check if game performance gets any better.

 

1/ Add these folders as exceptions in your antivirus.

  • C:\Users\your-name\Saved Games\DCS.openbeta\
  • \DCS World OpenBeta\

2/ Ensure GPU scheduling is turned OFF (if your PC is not up-to-date, the option may not show; means it's OFF).

3/ Go to "C:\Users\your-name\Saved Games\DCS.openbeta", and empty both "fxo" and "metashaders2" folders.

4/ Go to "C:\ProgramData\NVIDIA Corporation\NV_Cache" and delete its content (you won't be able to delete all files, just click "Ignore" if your get a warning).

5/ Ensure V-Sync is disabled ingame. Prefer the use of your NVIDIA V-sync.

6/ Ensure NVIDIA Frame rate limiter is disabled.

7/ Ensure NVIDIA Power Management Mode is set to Maximum performance.

8/ In Windows power management setings, select High Performance.

9/ If you don't use it, disable NVIDIA Share.

10/ If you don't use it, disable Windows Game Bar DVR.

11/ Enable Precision Boost Override in BIOS.

 

Still having stutters after all this? Please attach:

  • your dcs.log file ( C:\Users\your-name\Saved Games\DCS.openbeta\Logs\dcs.log )
  • your dxdiag log (here's how to make one)
Link to post
Share on other sites
14 hours ago, Flappie said:

Hi. Assuming you don't have HDDs on such a powerful brand new machine, and assuming you haven't messed with Windows pagefile, here are a few things to do/check. After doing each step, check if game performance gets any better.

 

1/ Add these folders as exceptions in your antivirus.

  • C:\Users\your-name\Saved Games\DCS.openbeta\
  • \DCS World OpenBeta\

2/ Ensure GPU scheduling is turned OFF (if your PC is not up-to-date, the option may not show; means it's OFF).

3/ Go to "C:\Users\your-name\Saved Games\DCS.openbeta", and empty both "fxo" and "metashaders2" folders.

4/ Go to "C:\ProgramData\NVIDIA Corporation\NV_Cache" and delete its content (you won't be able to delete all files, just click "Ignore" if your get a warning).

5/ Ensure V-Sync is disabled ingame. Prefer the use of your NVIDIA V-sync.

6/ Ensure NVIDIA Frame rate limiter is disabled.

7/ Ensure NVIDIA Power Management Mode is set to Maximum performance.

8/ In Windows power management setings, select High Performance.

9/ If you don't use it, disable NVIDIA Share.

10/ If you don't use it, disable Windows Game Bar DVR.

11/ Enable Precision Boost Override in BIOS.

 

Still having stutters after all this? Please attach:

  • your dcs.log file ( C:\Users\your-name\Saved Games\DCS.openbeta\Logs\dcs.log )
  • your dxdiag log (here's how to make one)

Hi Flappie,

 

Thank you for your reply. Few questions i need to ask.I didn't mess with windows pagefile but what am i supposed to look out for in the pagefile should i go into it since its a brand new system. By the way ,i'm using Win 10 Professional (64 bit). For questions 6 ,you are referring to the nvidia control panel and question 9, where can i find Nvidia Share?

 

Thank you 

 

Regards

If you want Peace, be prepared to fight for it ! :pilotfly:



 

 

Link to post
Share on other sites

Since your Windows was just installed, and since you don't know where to look for the pagefile settings, it means Windows is already handling it automatically for you.

You can launch this command in the "cmd" Windows utility to get some pagefile info:

wmic pagefile list /format:list

It will show the pagefile size in MB (AllocatedBaseSize) and its path (C:\, D:\, E:\...).

 

6/ Yes. In the NVIDIA control panel, the option is called "Max Frame rate". Set if to OFF.

9/ Here is how to disable NVIDIA Share. It is bundled with GeForce Experience. If you haven't GeForce Experience installed (I don't), then you don't need to do anything.

 

Link to post
Share on other sites

Hi Flappie,

 

Just to update you, ive done as what you have mentioned and certains things like Geforce Experience is uninstalled, in NCP , i have also set the MAx Frame limiter to off. I tired to reduce the settings in game to low and problem still persists. BAsing on your first reply, i hv also done most of the options given whilst the pagefile i did not touch. I also have rolled back the drive from the current latest drive to the one before. So what i plan to do is to try uninstall DCS and reinstall on another drive and see. WIll update again.

 

Thank you

If you want Peace, be prepared to fight for it ! :pilotfly:



 

 

Link to post
Share on other sites
  • 2 weeks later...

Hi,

 

Sorry i wasn't able to update as i was working over the past few days. Finally manage to resolve the issue and found the Razer Synapse 3 was conflicting with my SSD for some strange reason i have no answer too. After i uninstall the software, its smooth as silk. I have emailed Razer about this weird issue and awaiting for them to get back to me. Thank you for the help  Flappie and the rest. 

 

Regards,

 

  • Thanks 1

If you want Peace, be prepared to fight for it ! :pilotfly:



 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...