Jump to content

Recommended Posts

Hello, I just recently got the viggen and wanted to fly it with a friend. I noticed in couldn't select it in MP and whenever I fly it in SP I can only spectate my plane, not fly it. I have uninstalled reinstalled it, repaired DCS, activated deactivated, checked to see if all files were there and in the right place, ran a license check, just about everything I could think or have seen, and nothing has helped. I made a ticket since I have seen only little information on this subject and is very bizarre to me and all my dcs friends. I was hoping maybe someone here might already have a fix to spare the tech team's time. Any help would be appreciated, thank you.

Link to post
Share on other sites

Have you checked the DCS module manager if the Viggen module is porperly installed and activated?

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to post
Share on other sites
3 hours ago, Tonk99 said:

I was hoping maybe someone here might already have a fix to spare the tech team's time. Any help would be appreciated, thank you.


maybe if you attach your dcs.log file we could gather more info about your issue, as at the moment all we can do is guess.

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites
11 hours ago, Rudel_chw said:


maybe if you attach your dcs.log file we could gather more info about your issue, as at the moment all we can do is guess.

 

11 hours ago, Lynnux said:

Had the same problem once with a module. Had to contact the support.

 

12 hours ago, QuiGon said:

Have you checked the DCS module manager if the Viggen module is porperly installed and activated?

Thanks for your guys' suggestion and help. I contacted support and it seemed to be some sort of weird or corrupt dll avionics file for the module. I manually uninstalled it and repaired DCS and it worked.

  • Like 1
Link to post
Share on other sites
2 hours ago, Tonk99 said:

Thanks for your guys' suggestion and help. I contacted support and it seemed to be some sort of weird or corrupt dll avionics file for the module. I manually uninstalled it and repaired DCS and it worked.

That's good to hear and thanks for reporting back to tell us how it worked out. That might help others with the same problem! :thumbup:

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to post
Share on other sites

Thank you for posting this.  I'm having this problem as well.  I've owned the Viggen for 6 months so I'm not sure if this is the result of a recent patch/update or what the root cause may have been.

 

I tried uninstalling and reinstalling the module but that has not solved the problem. @Tonk99Can you be more specific about what dll was corrupt so that I can uninstall it and repair DCS in the same way?  Thanks!

 

Update:  After deleting and reinstalling the module a few times, I finally got it to work. Very strange.  At one point, the module just disappeared from the tab at the bottom of the main menu entirely...as if it didn't even exist in the game at all.  Hopefully it will be a non-issue moving forward.


Edited by Stewmanji

Hangar: A-7 | A-10C | AV-8B | F-14B | F-15C | F-15E | F-16C | F-18C | KA-50 | Mi-8 | SA342 | UH-1H

Link to post
Share on other sites
On 1/9/2021 at 3:40 PM, Stewmanji said:

Thank you for posting this.  I'm having this problem as well.  I've owned the Viggen for 6 months so I'm not sure if this is the result of a recent patch/update or what the root cause may have been.

 

I tried uninstalling and reinstalling the module but that has not solved the problem. @Tonk99Can you be more specific about what dll was corrupt so that I can uninstall it and repair DCS in the same way?  Thanks!

 

Update:  After deleting and reinstalling the module a few times, I finally got it to work. Very strange.  At one point, the module just disappeared from the tab at the bottom of the main menu entirely...as if it didn't even exist in the game at all.  Hopefully it will be a non-issue moving forward.

 

To make this more clear I looked further into the problem. It was the avionics dll that was the problem. And further looking into it, stupid me just figured out that it was my antivirus that thought a part of the dll was a trojan which of course it isn't.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...