Jump to content

Random CTD with all modules


Recommended Posts

Hi, I keep getting CTD with all modules after the last update

the crash happen for no apparent reason it's random and happens sometimes after few minutes and sometimes after half an hour, sometimes not at all, nut the crashlogs look quite the same: 

 

anyone has a clue?

 

SB11

 

crashlog.JPG

CPU: intel Core i7 9700K ~ 3.6 GHZ , nVidia RTX2060 SUPER, 32GB 3300 Mhz RAM, DELL 24" LED. Windows 10

Link to post
Share on other sites

What you've posted is just a screenshot of a tiny bit (crash dump) of your dcs.log file. I neeed the broader picture to tell you what happened, and I need it as text file, in order to search for specific words in it. Please drag and drop it here. It's located here in your PC:

 

C:\Users\your-name\Saved Games\DCS...\Logs\dcs.log

Flappie's_dcs.log

Link to post
Share on other sites

Thank you. Here's the interesting part: "DX device removed". It means DirectX couldn't communicate with the GPU anymore.

 

2021-01-04 16:58:47.155 ERROR_ONCE DX11BACKEND: texture 'mig-29_nose_spec' not found. Asked from 'NGMODEL'
2021-01-04 16:58:47.155 ERROR_ONCE DX11BACKEND: texture 'mig-29_tex03_spec' not found. Asked from 'NGMODEL'
2021-01-04 17:15:41.016 ERROR   DX11BACKEND: DX device removed. Reason: 0x887A0006
2021-01-04 17:15:44.376 WARNING LOG: 339 duplicate message(s) skipped.
2021-01-04 17:15:44.376 ERROR   DX11BACKEND: failed to create vertex buffer. Reason: DXGI_ERROR_DEVICE_REMOVED
2021-01-04 17:15:44.376 ERROR   DX11BACKEND: Failed assert `false && "failed to create vertex buffer"` at Projects\render\dx11backend_win8\Source\DX11BufferManager.cpp:379
2021-01-04 17:15:44.377 INFO    EDCORE: try to write dump information
2021-01-04 17:15:44.379 INFO    EDCORE: # -------------- 20210104-171544 --------------
2021-01-04 17:15:44.380 INFO    EDCORE: DCS/2.5.6.59625 (x86_64; Windows NT 10.0.19041)
2021-01-04 17:15:44.382 INFO    EDCORE: C:\WINDOWS\SYSTEM32\d3d11.dll
2021-01-04 17:15:44.383 INFO    EDCORE: # C0000005 ACCESS_VIOLATION at 33B498A0 00:00000000
2021-01-04 17:15:44.388 INFO    EDCORE: SymInit: Symbol-SearchPath: '.;C:\Program Files\Eagle Dynamics\DCS World OpenBeta;C:\Program Files\Eagle Dynamics\DCS World OpenBeta\bin;C:\WINDOWS;C:\WINDOWS\system32;SRV*C:\websymbols*http://msdl.microsoft.com/download/symbols;', symOptions: 530, UserName: 'Ilan'
2021-01-04 17:15:44.389 INFO    EDCORE: OS-Version: 10.0.19041 () 0x100-0x1
2021-01-04 17:15:44.901 INFO    EDCORE: 0x00000000001298A0 (d3d11): CreateDirect3D11SurfaceFromDXGISurface + 0x10420
2021-01-04 17:15:44.901 INFO    EDCORE: 0x0000000000044048 (dx11backend): createRenderer + 0x2B0B8
2021-01-04 17:15:44.901 INFO    EDCORE: 0x0000000000004006 (GraphicsVista): Graphics::CustomMaterial_Impl::GetMaterialCaps + 0x816
2021-01-04 17:15:44.902 INFO    EDCORE: 0x0000000000031131 (GraphicsVista): Graphics::RenderObject::render + 0x21
2021-01-04 17:15:44.902 INFO    EDCORE: 0x00000000002BD2D1 (CockpitBase): cockpit::ceSimpleLineObject::self_render + 0xA1
2021-01-04 17:15:44.902 INFO    EDCORE: 0x00000000002C5892 (CockpitBase): cockpit::ceSimple::draw + 0xE2
2021-01-04 17:15:44.902 INFO    EDCORE: 0x00000000002C5920 (CockpitBase): cockpit::ceSimple::draw + 0x170
2021-01-04 17:15:44.903 WARNING LOG: 2 duplicate message(s) skipped.
2021-01-04 17:15:44.903 INFO    EDCORE: 0x00000000002B2830 (CockpitBase): cockpit::ccIndicatorPage::draw + 0x60
2021-01-04 17:15:44.903 INFO    EDCORE: 0x00000000002AB7D5 (CockpitBase): cockpit::ccIndicator::draw + 0x75
2021-01-04 17:15:44.903 INFO    EDCORE: 0x00000000002ABB8E (CockpitBase): cockpit::ccIndicator::draw_to_viewport + 0xDE
2021-01-04 17:15:44.903 INFO    EDCORE: 0x00000000002B1A1D (CockpitBase): cockpit::ccIndicatorBake::addSource + 0x2ED
2021-01-04 17:15:44.904 INFO    EDCORE: 0x00000000002B15E6 (CockpitBase): cockpit::ccIndicatorBake::OnBeginFrame + 0xB6
2021-01-04 17:15:44.904 INFO    EDCORE: 0x000000000004AA2E (GraphicsCore): Graphics::fireRendererCallbacks + 0x15E
2021-01-04 17:15:44.904 INFO    EDCORE: 0x000000000015A094 (Visualizer): smSceneManager::CreateSceneManager + 0x5684
2021-01-04 17:15:44.904 INFO    EDCORE: 0x00000000007B02A7 (DCS): CoreUtils::TempFilesManager::operator= + 0x3BE537
2021-01-04 17:15:44.904 INFO    EDCORE: 0x00000000007C3AB3 (DCS): CoreUtils::TempFilesManager::operator= + 0x3D1D43
2021-01-04 17:15:44.905 INFO    EDCORE: 0x0000000000794834 (DCS): CoreUtils::TempFilesManager::operator= + 0x3A2AC4
2021-01-04 17:15:44.905 INFO    EDCORE: 0x0000000000794BF9 (DCS): CoreUtils::TempFilesManager::operator= + 0x3A2E89
2021-01-04 17:15:44.905 INFO    EDCORE: 0x00000000018572FC (DCS): AmdPowerXpressRequestHighPerformance + 0xBEA2F8
2021-01-04 17:15:44.905 INFO    EDCORE: 0x000000000098462E (DCS): CoreUtils::TempFilesManager::operator= + 0x5928BE
2021-01-04 17:15:44.906 INFO    EDCORE: 0x0000000000017034 (KERNEL32): BaseThreadInitThunk + 0x14
2021-01-04 17:15:44.906 INFO    EDCORE: 0x000000000004D0D1 (ntdll): RtlUserThreadStart + 0x21
2021-01-04 17:15:45.149 INFO    EDCORE: Minidump created.

 

Here are four threads dealing with the same kind of crashlog ("DXGI_ERROR_DEVICE_REMOVED"). The OPs all had their issue fixed, according to them. Feel free to read them and try what they have tried:

  1. Cause: faulty PSU
  2. Cause: SSLR enabled
  3. Cause: overclocked GPU
  4. Cause: RAM overclocked
  5. Solution: slightly downclocked GPU
  6. Solution: check for absence of dust and/or GPU well placed in its slot

It can also be an issue with the graphics driver, sometimes.

Not so long ago, people had a lot of crashes like this when switching from F10 view to F1 view over Syria. Do your crashes happen at this very moment?

Link to post
Share on other sites

Thanx Flappie

I know two of this thread because I've been there before. Thing is my previous crashes were solved after an update...

my PSU is not faulty, SSLR was no problem, and I'm not OC GPU, CPU or RAM. rig was dusted 2 weeks ago. Crashes became frequent after the last update. right now DCS is unplayable for me as every mission (in the Caucuses, Persian Golf or Syria with the F-18, F-14, F-16) ends with a crash, sometimes after 5 minutes sometimes after 20, sometimes after 45. Totally random. 

haven't had these kind of crashes in a long time - and now it came back BIG TIME. I hope you could help me better thus time...

 

SB11

CPU: intel Core i7 9700K ~ 3.6 GHZ , nVidia RTX2060 SUPER, 32GB 3300 Mhz RAM, DELL 24" LED. Windows 10

Link to post
Share on other sites

One question.  Are you running DCS as an admin?  I had some CTDs recently and tracked it down to the fact that i wasn't running as an admin.

System: 9700, 64GB DDR4, 2070S, NVME2, Rift S, Jetseat, Thrustmaster F18 grip, VPC T50 stick base and throttle, CH Throttle, MFG crosswinds, custom button box, Logitech G502 and Marble mouse.

Server: i5 2500@3.9Ghz, 1080, 24GB DDR3, SSD.

Link to post
Share on other sites
1 hour ago, Flappie said:

OK. 😐

1/ Can you please check in your crashlog this bit is still present?

 


Graphics::CustomMaterial_Impl::GetMaterialCaps 

 

This is the function that's crashing DCS in your previous log.

 

2/ Are you using shader mods?

 

No. can't find this line in my last crashlog

 

SB11

1 hour ago, Mr_sukebe said:

One question.  Are you running DCS as an admin?  I had some CTDs recently and tracked it down to the fact that i wasn't running as an admin.

Not that I'm aware of.... Will try that too... Thanx

 

SB11

CPU: intel Core i7 9700K ~ 3.6 GHZ , nVidia RTX2060 SUPER, 32GB 3300 Mhz RAM, DELL 24" LED. Windows 10

Link to post
Share on other sites
1 hour ago, Flappie said:

Then please attach your latest dcs.log showing your most recent crash. It may point to something else.

 

 

dcs.20210108-084139.log

1 hour ago, Flappie said:

Then please attach your latest dcs.log showing your most recent crash. It may point to something else.

 

This is the last one:

dcs.20210108-084139.log

CPU: intel Core i7 9700K ~ 3.6 GHZ , nVidia RTX2060 SUPER, 32GB 3300 Mhz RAM, DELL 24" LED. Windows 10

Link to post
Share on other sites

Thank you. The function that triggered the crash is different from the previous log, indeed. Same source of issue, though: "DXGI_ERROR_DEVICE_REMOVED".

 

2021-01-08 08:31:50.887 INFO    Dispatcher: loadMission Done: Сontrol passed to the player
2021-01-08 08:31:58.300 INFO    GRAPHICSVISTA: Creating Resource "Unicode" of type 1
2021-01-08 08:41:35.680 ERROR   DX11BACKEND: DX device removed. Reason: 0x887A0005
2021-01-08 08:41:39.564 WARNING LOG: 404 duplicate message(s) skipped.
2021-01-08 08:41:39.564 ERROR   DX11BACKEND: failed to create structed buffer. Reason: DXGI_ERROR_DEVICE_REMOVED
2021-01-08 08:41:39.564 ERROR   DX11BACKEND: CreateShaderResourceView FAILED. Reason: E_INVALIDARG
2021-01-08 08:41:39.566 ERROR   DX11BACKEND: DX device removed. Reason: 0x887A0005
2021-01-08 08:41:39.566 INFO    EDCORE: try to write dump information
2021-01-08 08:41:39.568 INFO    EDCORE: # -------------- 20210108-084139 --------------
2021-01-08 08:41:39.570 INFO    EDCORE: DCS/2.5.6.59625 (x86_64; Windows NT 10.0.19041)
2021-01-08 08:41:39.571 INFO    EDCORE: C:\WINDOWS\SYSTEM32\d3d11.dll
2021-01-08 08:41:39.572 INFO    EDCORE: # C0000005 ACCESS_VIOLATION at 435898A0 00:00000000
2021-01-08 08:41:39.576 INFO    EDCORE: SymInit: Symbol-SearchPath: '.;C:\Program Files\Eagle Dynamics\DCS World OpenBeta;C:\Program Files\Eagle Dynamics\DCS World OpenBeta\bin;C:\WINDOWS;C:\WINDOWS\system32;SRV*C:\websymbols*http://msdl.microsoft.com/download/symbols;', symOptions: 530, UserName: 'Ilan'
2021-01-08 08:41:39.578 INFO    EDCORE: OS-Version: 10.0.19041 () 0x100-0x1
2021-01-08 08:41:40.105 INFO    EDCORE: 0x00000000001298A0 (d3d11): CreateDirect3D11SurfaceFromDXGISurface + 0x10420
2021-01-08 08:41:40.105 INFO    EDCORE: 0x0000000000030897 (dx11backend): createRenderer + 0x17907
2021-01-08 08:41:40.105 INFO    EDCORE: 0x00000000000798F3 (edterrainGraphics41): edtg41::TerrainRenderable::dumpRenderItem + 0x694C3
2021-01-08 08:41:40.105 INFO    EDCORE: 0x00000000000CE577 (edterrainGraphics41): createInstancerRenderable + 0x36ED7
2021-01-08 08:41:40.105 INFO    EDCORE: 0x00000000000DC428 (edCore): ed::this_thread::yield + 0x318
2021-01-08 08:41:40.106 INFO    EDCORE: 0x00000000000D39CA (edCore): ed::make_render_thread_tasks + 0x1A
2021-01-08 08:41:40.106 INFO    EDCORE: 0x00000000007C3AE8 (DCS): CoreUtils::TempFilesManager::operator= + 0x3D1D78
2021-01-08 08:41:40.106 INFO    EDCORE: 0x0000000000794834 (DCS): CoreUtils::TempFilesManager::operator= + 0x3A2AC4
2021-01-08 08:41:40.106 INFO    EDCORE: 0x0000000000794BF9 (DCS): CoreUtils::TempFilesManager::operator= + 0x3A2E89
2021-01-08 08:41:40.107 INFO    EDCORE: 0x00000000018572FC (DCS): AmdPowerXpressRequestHighPerformance + 0xBEA2F8
2021-01-08 08:41:40.107 INFO    EDCORE: 0x000000000098462E (DCS): CoreUtils::TempFilesManager::operator= + 0x5928BE
2021-01-08 08:41:40.107 INFO    EDCORE: 0x0000000000017034 (KERNEL32): BaseThreadInitThunk + 0x14
2021-01-08 08:41:40.107 INFO    EDCORE: 0x000000000004D0D1 (ntdll): RtlUserThreadStart + 0x21
2021-01-08 08:41:40.319 INFO    EDCORE: Minidump created.

 

I don't have many ideas left at the moment. Try emptying these folders (NVIDIA shaders + DCS temp files):

  • C:\ProgramData\NVIDIA Corporation\NV_Cache
  • C:\Users\your-name\AppData\Local\Temp\DCS.openbeta

You will probably get a message saying Windows can't remove some files in "NV_Cache". That's OK, just hit "Ignore".

Link to post
Share on other sites

just tried COD on max setting. Got to 77c and didn't crash. Wonder why DCS puts so much stress on the system..?

 

SB11

CPU: intel Core i7 9700K ~ 3.6 GHZ , nVidia RTX2060 SUPER, 32GB 3300 Mhz RAM, DELL 24" LED. Windows 10

Link to post
Share on other sites

DCS is much more demanding for a PC (distance of view is way more important because of TGPs, textures are larger, ...).

Your RTX 2060 Super should be OK unless it reaches 89°C.

 

Have you tried this step, below? It worked for another user yesterday.

 

Quote

Try emptying these folders (NVIDIA shaders + DCS temp files):

  • C:\ProgramData\NVIDIA Corporation\NV_Cache
  • C:\Users\your-name\AppData\Local\Temp\DCS.openbeta

You will probably get a message saying Windows can't remove some files in "NV_Cache". That's OK, just hit "Ignore".

 

Link to post
Share on other sites

Yes I have, it’s just a guess but, can it be a CPU overheating that causes the crashes? I have an i7 9700

 

SB11

CPU: intel Core i7 9700K ~ 3.6 GHZ , nVidia RTX2060 SUPER, 32GB 3300 Mhz RAM, DELL 24" LED. Windows 10

Link to post
Share on other sites

The "DXGI_DEVICE_REMOVED" message is returned by DirectX when your graphics card does't answer to its calls. Here is some reading about this error:

 

image.png

 

It doesn't mean your GPU is broken. It means it was too busy (hanging) to answer DirectX calls. We need to find what's make it hang.

I don't have anymore ideas. You should open a support ticket.

Link to post
Share on other sites

OK I’m not sure what did it but I emptied appdata/local/temp AND dusted off the CPU (GPU was clean but CPU was choked!) so far Im crash free for the last 8 missions. 🤞

thanx for the support I’ll keep yall posted

 

SB11

CPU: intel Core i7 9700K ~ 3.6 GHZ , nVidia RTX2060 SUPER, 32GB 3300 Mhz RAM, DELL 24" LED. Windows 10

Link to post
Share on other sites

I promised to keep you posted so here it is: No crashes since CPU cleanup - and CPU is staying lower than 75C. I don't know if emptying the C:\Users\my_name\AppData\Local\Temp|\DCS.Openbeta helped - but it sure didn't hurt.


Edited by silentbob11
  • Thanks 1

CPU: intel Core i7 9700K ~ 3.6 GHZ , nVidia RTX2060 SUPER, 32GB 3300 Mhz RAM, DELL 24" LED. Windows 10

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...