Jump to content

After the recent update, whenever I try to start DCS, it gets stuck on the logo screen


Recommended Posts

After updating my game on the 17th of December 2020, I'm unable to start it.

  • When I click my desktop shortcut, the updater shows up for a splitsecond,  DCS logo shows up, but that's as far as it goes. If I click the logo i get a popup that says DCS is not responding.
  • When first started, the DCS icon on the taskbar is blank, however, after minimizing and then clicking it, the DCS icon appears.
  • Same thing happens when I try to start DCS directly from the install folder.
  • I have deleted my ImagesShop forder but nothing happened

Not sure what's up. If anyone knows how to fix this help would be appreciated.

Link to post
Share on other sites

I've had similar things happening when the TrackIR app is misbehaving for some reason. In those cases I recovered by killing it (TrackIR) and restarting it.

(probably not what happens here, but it does match the behaviour, so just in case...). 

Link to post
Share on other sites

If picon's solution doesn't work for you, try this:

  • if you have an NVIDIA graphics card: force fullscreen to "false" in C:\Users\your-name\Saved Games\DCS...\Config\options.lua
  • If you have an AMD graphics card: force fullscreen to "true" in C:\Users\your-name\Saved Games\DCS...\Config\options.lua and configure a Radeon profile for DCS so you can launch it from there.
Link to post
Share on other sites

How long did you wait for DCS to start? A few updates ago I've had the same happening, seemed as if DCS was not responding. Eventually I tried just letting it boot up for like 10 minutes while not touching or clicking anything, and suddenly DCS just continued booting. The start-ups afterwards were back at the regular boot-time. Maybe something like shaders re-compiling or whatsoever. 

Intel i9 10850k | Noctua NH-U12A | Gigabyte Z490 Aorus Elite AC | Patriot Viper Steel 64gb @3600MT/s | Gigabyte RTX 2070 Windforce | Samsung 970 EVO 1TB NVMe

Link to post
Share on other sites

I've reinstalled the program, did a full factory reset on my PC, waited 50 minutes for DCS to get out of the loading screen, but it still won't work goddamit

5 hours ago, Flappie said:

If picon's solution doesn't work for you, try this:

  • if you have an NVIDIA graphics card: force fullscreen to "false" in C:\Users\your-name\Saved Games\DCS...\Config\options.lua
  • If you have an AMD graphics card: force fullscreen to "true" in C:\Users\your-name\Saved Games\DCS...\Config\options.lua and configure a Radeon profile for DCS so you can launch it from there.

I can't even do this since there is nothing in that folder

Link to post
Share on other sites

Hi @Ornithopter. Here's your issue:

 

2020-12-19 02:34:22.960 ALERT   Dispatcher: Error starting Game GUI: [string "./MissionEditor/MissionEditor.lua"]:86: invalid order function for sorting
2020-12-19 02:34:22.960 INFO    EDCORE: (dDispatcher)enterToState_:2

 

Go to "C:/Users/GamePC3/Saved Games/DCS.openbeta", rename your "MissionEditor" folder into "MissionEditor_old", then launch DCS. You should be fine.

Link to post
Share on other sites

hey pilots,

 

my problem is, I get a authentification error: error 500, so i have to bind every single module. then I see the DCS logo when it starts but then there is only a black screen.

 

I tried everything.... rename MissionEditor, repair it a few times but no result. I hope anyone can help.

 

This happend since I updated yesterday.

 

Thanks

 

specs: i7 6700k/32GB/nvidia 980ti 6GB/ 257GB SSD

dcs.log


Edited by StoESs
Link to post
Share on other sites

The team are looking into a solution for the shadow pc issue

 

thanks

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites
7 hours ago, Flappie said:

Hi @Ornithopter. Here's your issue:

 



2020-12-19 02:34:22.960 ALERT   Dispatcher: Error starting Game GUI: [string "./MissionEditor/MissionEditor.lua"]:86: invalid order function for sorting
2020-12-19 02:34:22.960 INFO    EDCORE: (dDispatcher)enterToState_:2

 

Go to "C:/Users/GamePC3/Saved Games/DCS.openbeta", rename your "MissionEditor" folder into "MissionEditor_old", then launch DCS. You should be fine.

 

I tried this and the GUI continues to hang.  I'm not sure now if I'm in the correct thread, and will start another if that would help you sort one person's issue at a time.  For now though, the error in my log file is still exactly the same as the cut/paste above (MissionEditor.lua problem), despite rebuilding the MissionEditor directory in both Saved Games, as you suggested, and DCS root as well, via a Repair.

 

I'm not completely familiar with the term "Shadow PC" as it pertains here, so apologies if I'm posting my initialization problems in the wrong thread.


Edited by Ornithopter
Link to post
Share on other sites

I'm having the same symptoms, if not the same problem.

I've also updated to the latest Beta and now the game either crashes when starting in VR-off mode, or, when launching in VR (Rift-S), it gets to the main screen but the mouse only moves inside a very small area, the size of the inicial DCS World splashcreen. Plus it disapears from the Windows taskbar and there is never the mirror of what I'm seeing in VR on the regular screen.

 

Here's my log:

https://www.dropbox.com/s/5cb9up5kcv444gw/dcs.20201219-173122.log?dl=0

 

Link to post
Share on other sites
45 minutes ago, Pirimeister said:

I'm having the same symptoms, if not the same problem.

I've also updated to the latest Beta and now the game either crashes when starting in VR-off mode, or, when launching in VR (Rift-S), it gets to the main screen but the mouse only moves inside a very small area, the size of the inicial DCS World splashcreen. Plus it disapears from the Windows taskbar and there is never the mirror of what I'm seeing in VR on the regular screen.

 

Here's my log:

https://www.dropbox.com/s/5cb9up5kcv444gw/dcs.20201219-173122.log?dl=0

 

 

Looking at your logs, it seems your install gets farther than mine does, so I doubt we have the same problem. Out of curiosity, have you deleted your metashaders and fxo folders from your DCS saved games directory?

 

Edit: Well i'm dumb. Posted in the wrong thread. Feel free to delete this, mods 🙂


Edited by acceleraptor
Link to post
Share on other sites
Just now, acceleraptor said:

Out of curiosity, have you deleted your metashaders and fxo folders from your DCS saved games directory?

 No, I haven't.

One thing I forgot to add is that I was able to start the game in VR-off mode once, but after that it always crashes.

Link to post
Share on other sites
2 hours ago, BIGNEWY said:

The team are looking into a solution for the shadow pc issue

 

thanks

 

Just to add to this, I'm having the issue, but not with Shadow PC. In my case it's a QEMU VM. The thread linked before has a stack trace/call stack from where I _think_ the issue was occuring. Might help the devs track things down 🙂

1 minute ago, Pirimeister said:

 No, I haven't.

One thing I forgot to add is that I was able to start the game in VR-off mode once, but after that it always crashes.

 

Give that a try. It should be the metashaders2 and fxo directories in %USERPROFILE%\Saved Games\DCS that you delete. That will force a shader recompile.

Link to post
Share on other sites

I just tried you suggestion, but it didn't work. Thanks you for the tip, anyway.

 

I'm sorry if I'm hijacking the thread with my situation. I made a small video of my screen and the way the mouse moves.

What it shows is my desktop (my background image is of the Mi-8 cockpit, that's not the game running) and the mouse moving inside that invisible box. You can hear the DCS World main screen music coming from my Rift-S and if I was skilled enough to capture video from the Rift, you would see the mouse moving the same way, within the same limits.

 

https://www.dropbox.com/s/5cb9up5kcv444gw/dcs.20201219-173122.log?dl=0

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...