Jump to content

howto reduce flickering edges


Recommended Posts

hi guys, i am trying to optimize my rendering quality. what hurts my eyes most is the flickering edges. mainly on terrain and buldings. i want to get rid of this!

 

i use a rift cv1, so my resolution is not huge. i have set PPD to 1.6 in OculusTrayTool, in DCS it is set to 1.0.

 

there are some things i am confused about:

  • increasing or lowering PPD does not really affect the flickering that much. of course the image is a bit smoother with PPD 1.6 instead PPD 1.2, but the difference is not as dramatic as in other VR applications i use (like Assetto Corsa). and the edges of i.e. buildings flicker just as much with both settings.
  • following an advice i tried setting AntiAliasing in NVidia Settings.
    • first i tried activating "Antialiasing - FXAA"
    • then i tried activating "Antialiasing - Mode" and set "Antialiasing - Setting" to sth like 2x or even 4x.
    • both did not change image quality in DCS at all! even the fps did not change, even when i set "Antialiasing - Setting" to 8x, which should have an impact on my fps.

 

what am i missing?

Link to post
Share on other sites

Most settings in the Nvidia control panel have no effect in VR. The main exception is power management which should be set to prefer maximum performance.

The one setting that helps reduce the flickering jaggies is MSSA. Unfortunately it has a big hit on performance. 

The other thing that helps is a VR headset with physically higher resolution panels. I've progressed through CV1, Rift S and now Quest 2. There is a marked reduction in flickering edges at it's native resolution.

I would suggest trying some MSSA with other settings dialled down a tad if required.


Edited by Lensman

Intel Core i7 6700K @ 4.5GHz. Asus-Z170-PRO MB

CORSAIR H105 HYDRO CPU COOLER.

EVGA GTX 1080Ti FTW3 Elite.

16GB DDR4 2666MHZ HYPERX SAVAGE.

SAMSUNG M.2 SSD 128GB SM951 Boot Drive.

SAMSUNG SSD 500GB EVO Working Drive.

Windows 10 Professional

Link to post
Share on other sites

Yes, the MSSA setting in DCS. By all means try the Nvidia control panel settings and see what you think. Beware of placebo effects..just saying😉

Intel Core i7 6700K @ 4.5GHz. Asus-Z170-PRO MB

CORSAIR H105 HYDRO CPU COOLER.

EVGA GTX 1080Ti FTW3 Elite.

16GB DDR4 2666MHZ HYPERX SAVAGE.

SAMSUNG M.2 SSD 128GB SM951 Boot Drive.

SAMSUNG SSD 500GB EVO Working Drive.

Windows 10 Professional

Link to post
Share on other sites

as i said, i also felt those settings in nvidia panel had no effect. just thought maybe i missed some hidden "apply" button 😉

 

anyway THANKS for your advice!

i made a big step forward: as i also felt the MSAA setting in DCS had no effect, i retried. and i was right, no effect. until i stopped the sim and restarted it. then i had the improvement. before, i was just trying to set MSAA without restarting the sim (as for other settings, DCS restarts automatically, i thought this one does not need to).

 

so now, i have a much better picture, with PPD 1.4 and MSAA 2x. this has approx the same performance as PPD 1.6 and MSAA Off, which i had before 🙂

 


Edited by Fantomas
Link to post
Share on other sites

may i ask you one more thing?

you say you use a Quest2. i guess you use it via OculusLink? how is performance and picture with this?

 

some months ago, i tried a Quest1 with OculusLink, and summa summarum it was not better than my Rift CV1. there was a clear performance cost (because the picture needs to be compressed before sending it trough the cable), and compression also caused the picture to be washed out and blurred.

Link to post
Share on other sites

Ah, pleased you sorted the MSSA setting 🙂

Picture quality is impressive with Quest 2 via link. It's an encouraging  improvement over my Rift S. As I mentioned previously, the 100% increase in physical pixels compared to the Rift S gives a much smoother detailed image. The downside is that this comes with a processing overhead. My 1080ti GPU is showing it's age and I will upgrade to something like an RTX 3080 as soon as I can snag one. The RTX cards have the advantage of much improved encoding hardware that the Link cable demands.

Having said that, I'm enjoying WW2 dogfights with a handful of planes and getting smooth gameplay.

My hardware:

Intel Core i7 6700K @ 4.5GHz. Asus-Z170-PRO MB - CORSAIR H105 HYDRO CPU COOLER
EVGA GTX 1080Ti FTW3 Elite - 16GB DDR4 2666MHZ HYPERX SAVAGE.
SAMSUNG M.2 SSD 128GB SM951 Boot Drive - SAMSUNG SSD 500GB EVO Working Drive.
Windows 10 Professional

Intel Core i7 6700K @ 4.5GHz. Asus-Z170-PRO MB

CORSAIR H105 HYDRO CPU COOLER.

EVGA GTX 1080Ti FTW3 Elite.

16GB DDR4 2666MHZ HYPERX SAVAGE.

SAMSUNG M.2 SSD 128GB SM951 Boot Drive.

SAMSUNG SSD 500GB EVO Working Drive.

Windows 10 Professional

Link to post
Share on other sites

Yep, much improved since the Link came out of Beta. You need the v23 updates for the headset and PC app 🙂

Intel Core i7 6700K @ 4.5GHz. Asus-Z170-PRO MB

CORSAIR H105 HYDRO CPU COOLER.

EVGA GTX 1080Ti FTW3 Elite.

16GB DDR4 2666MHZ HYPERX SAVAGE.

SAMSUNG M.2 SSD 128GB SM951 Boot Drive.

SAMSUNG SSD 500GB EVO Working Drive.

Windows 10 Professional

Link to post
Share on other sites

I know this sounds crazy, but try setting Shadows to at least Medium. Entirely removed all in cockpit flickers on hard edges.

 

Intel i7 10700K @ 4.5 GHz / ASUS ROG STRIX Z490-F Gaming / 32 Gb G.Skill DDR4 / Inno3d RTX 3090 / 512 Gb Samsung 850 EVO System SSD / 512 Gb Samsung 850 EVO DCS SSD / Win 10 x64 Pro / WINWING F/A-18 HOTAS

 

A-10C, AV-8B, F-5E, F-86F, FC3, FW190D-9, Hawk, Ka50 2, P-51D, Spitfire, UH-1H, F/A-18C, F-14, F-16, Supercarrier, Christen Eagle 2

 

Nevada, Normandy, Persian Gulf, The Channel

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...