Jump to content

Trim no longer functional


Recommended Posts

Trim no longer works after today's patch.


Even clicking the trim buttons on the stick in-game ensuring no double binds or anything... no trim.


Can anyone else confirm this?


Two ship with a friend and I were not able to trim on a multiplayer server just now.

Link to comment
Share on other sites

Trim still wroks fine here.


I tried the instant action cold start mission, using manual startup and autostart. No issues with trim. Someone else needs to verify this using a non forcefeedback stick.

PC: ASUS PX58D-E | i7 950 ( o.c. 4.0 ) | 16Gb 1600 RAM (3-channel) | Geforce 1080Ti FTW3 | OCZ Revodrive 350Z SSD | Asus Xonar D2X | MSFFB2 + DIY rudder pedals | OS: Win10-64bit


DCS modules: Ka-50 | UH-1 | P-51 | FW-190D-9 | MiG-15 | MiG-21 | M-2000C | L-39 | FC3 | F-5E | F-14

Link to comment
Share on other sites



I wonder if that goes under my list of the same issue I had with the litening in the A10C2 last night; couldn't lase, turned it off and back on and apparently I could lase again.


Will continue to fiddle with when I have a chance, will produce a track if need be.


Seems odd it happened to two of us in three different aircraft.

Link to comment
Share on other sites

  • 2 months later...

Hey, the triming seems to be broken in my case too.


What's even more weird, when I bind the mig21 trim to hotas, it seems to trim alierons xD yep I know how stupid this seems but plane is banking when applying a trim and my forcefeedback joystick is moving out of zero position to the trimmed side.

More over, triming by keyboard bind seems to do something (the elevators start to move as well as the virtual stick) but after I grab my Microsoft  Sidewinder joystick it resets to neutral position. Also, usually triming in other planes moves the force feedback neutral position (like on Mig 19) here it does nothing in case of triming by keyboard.

In general I'm unable to trim by any way which would be working as intended...


This is 100 reproducible in my case. It's not trim subsystem that is off.

Does anybody else has the FF and can try the trimming in Mig21?

Link to comment
Share on other sites

  • 2 weeks later...

Ok I solved this mistery.

I had to swap the axis in FF assignment settings.


This was the reason why I thought my vertical trim trimmed alierons.


Trim with FF Joysticks are actually changing the "zero" position (like in reality, simulating trim force on stick). This exactly reflects the real stick but if your system expose FF asis in different order than joystick axis, it will push the stick sideways instead of forward/backward.

Edited by Rosly
  • Thanks 1
Link to comment
Share on other sites


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...