Jump to content

Diplayport "No Signal" Issue


Recommended Posts

Hi. I'll try to tell the story briefly.

 

Currently I have MSI GTX 1660Ti card. It has 1xHDMI and 3xDisplayports

 

I have 27" Samsung monitor with 1 HMDI port. This is my main monitor connected via HDMI already.

And two 8"TFT screens (bought from AliExpress), each has 1xHDMI and 1xVGA port.

 

For connecting the 1660 to 8"TFTs, I've bought two "DP to HDMI" cables from a local store but something isn't working.

 

All cables connected to monitors. Main (27") monitor working but TFTs say "no signal" message on their blue screen. I change and search screen modes to get input from the 1660... no luck.

I changed 1660's power option, re-installed drivers, struggled in "multiple displays" section of NVidia Control Panel... no luck.

Windows' Screen Res page, "Detect" etc... no luck.

 

I thought something wrong with cables, but (for example) when I unplug 27" monitor's (HDMI) cable, one of 8" TFTs opens and shows my desktop!!! If I exchange the cables I can see my desktop on the other TFT too.

So, I thought the cables must be OK. I plug my 27" monitor's HDMI back again, and TFTs go black.

 

Apparently, 1660's ports are fine,

Cables look like working,

TFTs working,

but I can't get my desktop image on the three monitors at the same time!

 

Why is that?

 

Should I try other cable variations? "DP to VGA" cables? Or, DP>HDMI converter + HDMI cable?

 

Note: I had GTX 970 and these TFTs, and I could use multimonitor setup without any problem (with DVI-VGA cables of course).

 

If anyone any idea and help me, I'll be very pleased.

Thanks so much.

i7-2600 @3.4GHz | Corsair 16GB @1600MHz. | MSI GTX1660Ti Gaming X | Samsung 256GB SSD (Win7HPx64)

Samsung 32" | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars & 2 x 8"TFTs | Logitech G13, G230, G510, PZ55 SwitchPanel & Farming Sim Panel | TIR5

>>MY MODS<< | Discord: Devrim#1068

Mi-24P Hind EN Cockpit WIP: %99,9

Link to post
Share on other sites

Update: I bought two DP to VGA cables and everything works.

 

VGA is life. VGA is the future. :D :D

i7-2600 @3.4GHz | Corsair 16GB @1600MHz. | MSI GTX1660Ti Gaming X | Samsung 256GB SSD (Win7HPx64)

Samsung 32" | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars & 2 x 8"TFTs | Logitech G13, G230, G510, PZ55 SwitchPanel & Farming Sim Panel | TIR5

>>MY MODS<< | Discord: Devrim#1068

Mi-24P Hind EN Cockpit WIP: %99,9

Link to post
Share on other sites

I would have thought you would need an active adapter as it is going from a digital signal to an analog one.. not sure why your cables work unless they are active cables?

MSI MPG Z390 Gaming Plus / Intel i7 9700K @ 4.8Ghz / Coolermaster 212x / Samsung 860 Evo SSD 1TB / Asus 1080GTX OC / G. Skill RipJaws 32GB RAM 3200MHZ XMP PRofile / Samsung Odyssey Plus VR / HOTAS Cougar & MFD's / Buttkicker game simulation

Link to post
Share on other sites

Thanks guys.

i7-2600 @3.4GHz | Corsair 16GB @1600MHz. | MSI GTX1660Ti Gaming X | Samsung 256GB SSD (Win7HPx64)

Samsung 32" | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars & 2 x 8"TFTs | Logitech G13, G230, G510, PZ55 SwitchPanel & Farming Sim Panel | TIR5

>>MY MODS<< | Discord: Devrim#1068

Mi-24P Hind EN Cockpit WIP: %99,9

Link to post
Share on other sites

The adapters Devrim got most likely have a chip inside as afaik there is now other way to "translate" the signal from digital ones and zeroes to analog voltage amplitudes.

  • Like 1

Asus Z370-E - 8700K@5G_delidded - 32GB - 1080GTX-Ti EK-waterblock - 1x 960Evo 250GB - 3x Samsung 850/860Pro 256GB Raid-0 - 32GB PageFile - 2x Seagate 2TB - Heatkiller IV - MoRa3-360LT@4x180mm fans - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win10Pro64 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...