Jump to content

[REPORTED]New kneeboard I cannot move it


Recommended Posts

And how I do that? (in system options I have interface adjust size to 1 already) (I have it in spanish)

I have changed my monitorsetup with this:

 

_ = function(p) return p; end;

name = _('Japo_3Pantallas_ver2');

Description = 'Japo configuration'

Viewports =

{

Center =

{

x = 0;

y = 0;

width = screen.width;

height = screen.height;

viewDx = 0;

viewDy = 0;

aspect = screen.aspect;

}

}

Gui =

{

x = 1920;

y = 0;

width = 1920;

height = 1080;

}

 

UIMainView = Gui

 

it is the way I like most, because it is deformed as I usually like (don't like the 3 screens option, but in 3cameras.lua option I have same problem with kneeboard) and msgs from missions appear in the center monitor.

If I put the 1 monitor setup then I can move the kneeboard, but I have the msgs on the most right side of my right monitor.

 

Thanks

Link to post
Share on other sites

Changing the GUI scale didn't work for me either. However I reverted to one of the default monitor layouts luas and it started working. I think the new kneeboard doesn't like it when the GUI is a different width and height to the overall screen width and height.

 

Added my monitor layout LUA for reference. I've got two monitors for DCS, both 1920x1080 for a combined 3840x1080 screen resolution.

Helios.lua


Edited by PickleMonster
Added Monitor Layout Details
Link to post
Share on other sites

I can confirm there is something strange with new kneeboard. As it stands with 5120x1440 and 1920x1280 screen side by side, it renders the kneeboard partially out of whole canvas. In addition the UI elements are not aligned with kneeboard.

 

I can confirm this by changing ViewportHandling.lua#update_screenspace_displacement default_x into 3100 and then you can see the UI will render around right edge of the main viewport but kneeboard will render left of the UI at 3100px.

cd17415a1fb3b61d36b0c59d8d1099d8.thumb.jpg.a3d0ec2b868cf186e89cd489f3d9c848.jpg

Link to post
Share on other sites

Having similar issues with 2560x4096 resolution, the kneeboard is all over the place (lower right corner, over MFD viewports). If I try to move it with say, kneeboardbuilder, the borders and the kneeboard itself get misaligned and distorted. no idea how to fix...

Link to post
Share on other sites

I think I found the problem. The UI for the kneeboard is directly linked to the offset of the GUI. This means that if you have the below code:

 

Gui =

{

x = 100;

y = 100;

width = 1920;

height = 1080;

}

[/code]

 

Your kneeboard GUI (control handles, border, and buttons) will be 100 pix off right and downwards.

From my testing it looks like this bug is NOT linked directly to screen resolutions, number of screens, or number of viewports.

300530422_2020-11-1909_47_41-DigitalCombatSimulator.thumb.jpg.b476771d4801212f834c64a80c5cd121.jpg

Link to post
Share on other sites
I think I found the problem. The UI for the kneeboard is directly linked to the offset of the GUI. This means that if you have the below code:

 

Gui =

{

x = 100;

y = 100;

width = 1920;

height = 1080;

}

[/code]

 

Your kneeboard GUI (control handles, border, and buttons) will be 100 pix off right and downwards.

From my testing it looks like this bug is NOT linked directly to screen resolutions, number of screens, or number of viewports.

 

So do you suggest adding or modifying a "GUI" section to the monitorsetup with no x/y offsets? but then we end up with the same issue? I'm going to go try and report back...

Link to post
Share on other sites

 

So do you suggest adding or modifying a "GUI" section to the monitorsetup with no x/y offsets? but then we end up with the same issue? I'm going to go try and report back...

 

I have not tried finding a workaround. If I were to do so, I would arrange my monitor .lua and screen config to have the GUI at (0,0). I would think that fixes the problem until ED can fix it.

Looking forward to what you find out.

Link to post
Share on other sites

I confirm.

 

i had the second monitor on the left of the main one and one my GUI was :

x=1920

y=0

with those settings i wasn't able to move the Kneeboard.

 

I change the settings by putting my second monitor to the right of the main one so

x=0

y=0.

Now i have the kneeboard GUI on top of the actual Kneeboard and i can move it.

 

Link to post
Share on other sites

Solved, had to modify my monitor layout and now while not ideal, the kneeboard is usable again. Solved by setting "gui" at 0/0 with no offset as suggested by Bailey. I still feel this is a bug that should be reported.

Basically went from this

unknown.png

to this

unknown.png

and it still didn't work because to have the kneeboard aligned with the kneeboard gui, the game gui has to start from 0,0. In the first case that would be ontop of monitor 1, aligned vertically with the top o monitor 6, second scenario would have that point above the left-high corner of monitor 4.

 

To be somewhat successful, I now have to switch to this configuration

unknown.png

every time I want to play the game (and had to change all helios profiles and monitorconfig.lua along with it) so now the kneeboard gets drawn in the red rectangle but pages and gui are aligned so I can drag the borders all the way to monitor 1 which is where I need them.

Not ideal, but it is a workaround until we have a more elegant solution.

 

And anyway I play in VR most of the time, so this problem is next to non-existent.

Link to post
Share on other sites

Reported

 

It is a strange one, in our internal version it works, only breaks in public versions.

 

we will get to the bottom of it, thank you

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites

I have found a temporary solution. It is not IC Safe. (It does not pass Integrity Check). Let's say my GUI section in monitor.lua is:

 

Gui =
{
x = 1920;
y = 200;
width = 1920;
height = 1080;
}
UIMainView = Gui

 

Assuming that I am on a dual screen setup of some kind, that would equate to about 1 screen width to the right and 200 pixels down.

 

You need to make the file here: "\DCS World OpenBeta\Scripts\Aircrafts\_Common\Cockpit\KNEEBOARD\indicator\init.lua" look like this at the bottom:

 

allow_manual_viewport_placement = true
manual_viewport_dlg = "Scripts/UI/KneeboardCanvas.dlg"
manual_viewport_margin_left = 1920
manual_viewport_margin_right = -1920
manual_viewport_margin_up = 200
manual_viewport_margin_bottom = -200

 

Notice the pattern in numbers. They are copies of x and y from the Gui code. This will reset the KneeboardGui area back onto the Kneeboard image. Hopefully that can get you playing SP with the new kneeboard enough to hold ya over till a fix comes out.

Link to post
Share on other sites

In single monitor setup new Kneeboard works (almost) ok. I can scroll it and bookmark pages, but can not move it.

 

https://i.imgur.com/GhRMDRl.jpg

 

Problems start in multimonitor setup. Kneeboard (as previously) renders in lower right corner of all monitors and has no frame around it.

 

https://i.imgur.com/Un6YCs1.jpg

 

When I edited ViewportHandling.lua (only dedicated_viewport line) to move KB - it moves to desired position, but frame is somewhere else.

 

https://i.imgur.com/NSQrMX6.jpg

 

PS I don't have GUI section in multi monitor lua file.

Link to post
Share on other sites

When trying to move the kneeboard, there is an invisible sweetspot. This sweetspot starts at the top of and goes down to an imaginary line drawn across the kneeboard that starts at the bottom X on the right of the kneeboard. Think of it as an invisible title bar. That’s what I have experienced.

Link to post
Share on other sites
When trying to move the kneeboard, there is an invisible sweetspot. This sweetspot starts at the top of and goes down to an imaginary line drawn across the kneeboard that starts at the bottom X on the right of the kneeboard. Think of it as an invisible title bar. That’s what I have experienced.

 

Thanks, that worked.

  • Like 1
Link to post
Share on other sites
After the latest update, I'm still having the same issue that Baily posted if I change the GUI scale to a value greater than 1. I only have one monitor. Has anyone submitted a bug report on this?

 

ED knows. They said it will hopefully be fixed in the next scheduled update.

Link to post
Share on other sites
  • 2 weeks later...

I played the trick by Bailey and now it works for me!! Thanks mate :clap_2:. Anyhow, this is what I get. There were no chance I managed to move it in the first place. Not only I have two screens for exported instruments, they are different sizes and resolutions, maybe that's related to the problem.

 

Screen_201207_194922.png

 

S!

"I went into the British Army believing that if you want peace you must prepare for war. I believe now that if you prepare for war, you get war."

-- Major-General Frederick B. Maurice

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...