Jump to content

CTD with the F14A


Recommended Posts

Any of you have this mod installed? VSN_F4E.

 

in my case that was the problem.

 

 

I removed all the aircraft from the mods folder, and that fixed it.. but that's not the ideal soloution

[sIGPIC][/sIGPIC]

i5 9400 @ 2.9 Ghz

16 GB RAM

250 GB SSD

GTX 2060 8GB

Windows 10 64 bit

Link to post
Share on other sites

It would appear that *some* 3rd party aircraft mods will work. I don't know why. Several VSN aircraft and the Super Hornets all cause issues. Not only do they cause a CTD if you attempt to fly 14A but if you place it in a mission as an AI controlled aircraft the mission will work but it's the wrong version of the F14A. And the one I selected is the yellow flyable one and I'd removed the VSN_F14A just in case of a conflict. I have no idea why this is happening but it won't work for example with only the VSNF35 installed. I use that aircraft in many missions. So.....until or unless this is fixed, the F14A doesn't exist in my DCS. The F14B seems to work just fine.

  • Like 1
Link to post
Share on other sites

And why are you complaining here, HB cant anticipate what mods you do have personally installed in DCS, If you want compatibility go ask the mod makers to make the mods compatible with official 3rd party module release.

Link to post
Share on other sites
And why are you complaining here, HB cant anticipate what mods you do have personally installed in DCS, If you want compatibility go ask the mod makers to make the mods compatible with official 3rd party module release.

 

because these addons use CORE files.. and why are you here, when you don't seem to be bug reporting, just complaining about those who have CTD's ? it through process of elimination that the 3rd party issue came to light!!

[sIGPIC][/sIGPIC]

i5 9400 @ 2.9 Ghz

16 GB RAM

250 GB SSD

GTX 2060 8GB

Windows 10 64 bit

Link to post
Share on other sites

same here!

 

CTD when i attempt to fly the F14A as player, and it shows as old F14A as AI. this is something not right!

 

I have repaired the DCS installation, removed and reinstalled the F14 module, i even removed custom /liveries/F14a/ folder , none of it helped.

 

Removing mods is not a solution this must be properly fixed. TIA

dcs.log-20201119-094859.zip

My custom made aircraft skins and other content for DCS World!

 

WIN 10  / 64Gb RAM DDR4 @ 4000mhz / i9-10900KF @ 5.3ghz / NVIDIA GeForce 3090 RTX / SSD Samsung EVO 970 / VIRPIL / MFG Crosswind / Pimax 5k+ 

Link to post
Share on other sites
same here!

 

CTD when i attempt to fly the F14A as player, and it shows as old F14A as AI. this is something not right!

 

I have repaired the DCS installation, removed and reinstalled the F14 module, i even removed custom /liveries/F14a/ folder , none of it helped.

 

Removing mods is not a solution this must be properly fixed. TIA

 

If you have Mods like VSN planes in your users folder, you must delete them.

Link to post
Share on other sites

 

because these addons use CORE files.. and why are you here, when you don't seem to be bug reporting, just complaining about those who have CTD's ? it through process of elimination that the 3rd party issue came to light!!

 

This is not a bug nor it is HB issue, F-14A model works perfectly fine for me, and others that dont use mods. So if you want to use mods go ask the modmaker to make it compatible with official F-14A module release.

Link to post
Share on other sites

 

This is not a bug nor it is HB issue, F-14A model works perfectly fine for me, and others that dont use mods. So if you want to use mods go ask the modmaker to make it compatible with official F-14A module release.

 

it is really strange why the VSN mods will affect the F14A in this way ??? they were installed in /Saved Games/DCS/Mods/Aircraft/ folder, definitely not in the core dcs folder, so why?

  • Like 1

My custom made aircraft skins and other content for DCS World!

 

WIN 10  / 64Gb RAM DDR4 @ 4000mhz / i9-10900KF @ 5.3ghz / NVIDIA GeForce 3090 RTX / SSD Samsung EVO 970 / VIRPIL / MFG Crosswind / Pimax 5k+ 

Link to post
Share on other sites

Put the Canadian F-14 (F-14, eh?) in my Syria familiarization mission and had no issues at all. Must not have any of the offending mods...but that's because historically I've found they tend to jack things up sooner or later and I've severely limited the mods I use.

 

I have to agree that if you want a modded system one of the disadvantages is reduced stability; the developers can't be held accountable for the programming skills, or the willingness to update, of every player/hacker/coder in DCS. ED has already said they're updating many of those 8E+7 lines of code, and that's not going to be good for the mod ecosystem.

 

As for how mods in ~/Saved Games affects the F-14, those libraries get loaded just like the libraries in ~/DCS World, and they affect the functionality of the system in the same way. That's the beauty of linked libraries; you can insert code from any number of locations, which can simplify installation and management without affecting function.

 

Now, about side number 205 on that VF-21 skin... :thumbup:

Link to post
Share on other sites

 

This is not a bug nor it is HB issue, F-14A model works perfectly fine for me, and others that dont use mods. So if you want to use mods go ask the modmaker to make it compatible with official F-14A module release.

 

Golo your presence is useless here. The fact that you think you have the ultimate opinion, that, because you don't use mods - this problem doesn't exist, is essentially the proof in the pudding that you have no concept of this issue, so leave it to the people who do.

 

Your participation here does nothing but gum up the process of problem solving.

  • Like 1

Intel i7 9700k CPU

Nvidia GTX 1080Ti

16GB RAM

Samsung 256GB SSD

Thrustmaster T16000m HOTAS

Link to post
Share on other sites

It cannot be expected that ED and/or all 3rd party addons be made compatible with every single DCS mod out there. No DCS developers have the resources to do this, if an official addon breaks a mod, contact the mod creator.

Systems Engineer & FM Modeler

Heatblur Simulations

Link to post
Share on other sites
It cannot be expected that ED and/or all 3rd party addons be made compatible with every single DCS mod out there. No DCS developers have the resources to do this, if an official addon breaks a mod, contact the mod creator.

 

Creason the issue is that this has never been a problem until you released your F-14A. None of the modders have any idea what is causing it, because it doesn't affect any other module out there. It doesn't even affect the B for christ sake so why is the A so sensitive.

 

Plus the fact that these affects are happening as a result of mods placed in savegames, which by nature isn't suppose to be changing core game files, and haven't had a single negative affect until now.;

  • Like 1

Intel i7 9700k CPU

Nvidia GTX 1080Ti

16GB RAM

Samsung 256GB SSD

Thrustmaster T16000m HOTAS

Link to post
Share on other sites

 

Creason the issue is that this has never been a problem until you released your F-14A. None of the modders have any idea what is causing it, because it doesn't affect any other module out there. It doesn't even affect the B for christ sake so why is the A so sensitive.

 

Plus the fact that these affects are happening as a result of mods placed in savegames, which by nature isn't suppose to be changing core game files, and haven't had a single negative affect until now.;

 

That being so, however much we do not want for this to happen it's simply not possible for us to test against each and every unsupported community mod.

We don't know either why it is happening, but if what's behind this is discovered and it's an easy fix on our side we will ofc fix it.

 

We haven't done anything out of the ordinary as far as we know and have no idea wherein the issue lies. It could be becuase of the old F-14A existing and it could be something completely unrelated in core DCS, even if triggered by us somehow.

Link to post
Share on other sites

If it's of any help...every crash shows an "Access Violation in the F-14 Avioncis.dll" I attempted to use a version of the VSN F-35 mod that uses the SFM and doesn't call any core files like the F15.dll that the old version used. And the crash still occurs. I completely understand the point of views that have been expressed. "3rd party devs can't be responsible for mod compatibility". However, any help in identifying why these certain mods are causing incompatibility would be appreciated :)

 

# -------------- 20201119-182721 --------------

DCS/2.5.6.57949 (x86_64; Windows NT 10.0.19042)

F:\DCS World OpenBeta\Mods\aircraft\F14\bin\F14-Avionics.dll

# C0000005 ACCESS_VIOLATION at E514451D 00:00000000

Link to post
Share on other sites

I agree too, no one can expect devs to test everything, especially mods that are less available even for the community, let alone devs. I certainly hear that. I would hope that this forum topic could encourage both sides to support each other, to try to troubleshoot the issue.

Intel i7 9700k CPU

Nvidia GTX 1080Ti

16GB RAM

Samsung 256GB SSD

Thrustmaster T16000m HOTAS

Link to post
Share on other sites

We'll always help any modder that approaches us, if there is anything we can do on our side. But unfortunately they need to approach us. The variety of mods is simply so large, that we must not consider them a priori. I say must not, because the rabbit hole becomes quickly so deep and endless, that as a dev you would never get out of it. We also do not allow our testers to test with mods, for that same reason. We can and only ever will take responsibility for a clean build. That's in all games like that. However, that does not mean that we're not willing to give our full support to any modder that needs it. We embrace modding, we believe it to be especially important in simming and we're here to help, anytime. But please understand that with the plethora of mods or modders, they simply have to approach us, it would be impossible to do it the other way around. Thank you.


Edited by IronMike

Heatblur Simulations

 

Please feel free to contact me anytime, either via PM here, on the forums, or via email through the contact form on our homepage.

 

http://www.heatblur.com/

 

https://www.facebook.com/heatblur/

Link to post
Share on other sites
If it's of any help...every crash shows an "Access Violation in the F-14 Avioncis.dll" I attempted to use a version of the VSN F-35 mod that uses the SFM and doesn't call any core files like the F15.dll that the old version used. And the crash still occurs. I completely understand the point of views that have been expressed. "3rd party devs can't be responsible for mod compatibility". However, any help in identifying why these certain mods are causing incompatibility would be appreciated :)

 

These entries in the VSN mods "entry.lua" cause the errors

 

mount_vfs_model_path ("Bazar/World/Shapes")

mount_vfs_texture_path ("Bazar/World/textures")

  • Like 1
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...