Jump to content

export.lua conflicts


Andy t
 Share

Recommended Posts

I am trying to use win wing's exports along with dcs export scripts. It appears that these two "step on each other's toes". Whichever line occurs later in the file, "wins". In the attached example of my export.lua below, the win wing's functionality wouldn't work, while DCS-export scripts (used by ctytler's excellent streamdeck plugin) works. By putting the win wing's export, the behavior is reversed.

Before winwing, I was having the same issue with DCS-UFC and DCS-exportscripts not coexisting as well.

What could be causing this issue with my export.lua? Are others able to have multiple apps that rely on DCS state export co-exist? Any guides on interpreting DCS's export.lua and other .lua files?

 

local wwtlfs=require('lfs')
-- win wing
dofile(wwtlfs.writedir()..'Scripts/wwt/wwtExport.lua')
local Tacviewlfs=require('lfs');dofile(Tacviewlfs.writedir()..'Scripts/TacviewGameExport.lua')
-- load the DCS ExportScript for DAC and Ikarus
dofile(lfs.writedir()..[[scripts\DCS-ExportScript\ExportScript.lua]])
local vaicomlfs = require('lfs'); dofile(vaicomlfs.writedir()..[[scripts\VAICOMPRO\VAICOMPRO.export.lua]])
pcall(function() local dcsSr=require('lfs');dofile(dcsSr.writedir()..[[Mods\Services\DCS-SRS\Scripts\DCS-SimpleRadioStandalone.lua]]); end,nil);

Link to comment
Share on other sites

  • 2 months later...
  • 5 months later...

I believe I have this working... Was having the same issue myself, whichever was down the bottom was winning.

Updated the below, not actually sure if this solved it or if I was doing something wrong before this, need to test more tomorrow.

My WW panels and throttle are all syncing now and I can see UFC data on my stream deck though.

 

local vaicomlfs = require('lfs'); dofile(vaicomlfs.writedir()..[[Scripts\VAICOMPRO\VAICOMPRO.export.lua]])
-- load the DCS ExportScript for DAC and Ikarus
local dcsexportlfs = require('lfs'); dofile(dcsexportlfs.writedir()..[[Scripts\DCS-ExportScript\ExportScript.lua]])
local wwtlfs = require('lfs')
dofile(wwtlfs.writedir()..[[Scripts\wwt\wwtExport.lua]])

Link to comment
Share on other sites

  • 3 months later...
On 6/29/2021 at 1:31 PM, Simm0 said:

I believe I have this working... Was having the same issue myself, whichever was down the bottom was winning.

Updated the below, not actually sure if this solved it or if I was doing something wrong before this, need to test more tomorrow.

My WW panels and throttle are all syncing now and I can see UFC data on my stream deck though.

 

local vaicomlfs = require('lfs'); dofile(vaicomlfs.writedir()..[[Scripts\VAICOMPRO\VAICOMPRO.export.lua]])
-- load the DCS ExportScript for DAC and Ikarus
local dcsexportlfs = require('lfs'); dofile(dcsexportlfs.writedir()..[[Scripts\DCS-ExportScript\ExportScript.lua]])
local wwtlfs = require('lfs')
dofile(wwtlfs.writedir()..[[Scripts\wwt\wwtExport.lua]])

Thanks..it seems like you helped  with same problem for me


Edited by hreich

[sIGPIC][/sIGPIC]

Pilot from Croatia

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...