Jump to content

Slightly stuttering when looking around with headtracker since the latest update


Recommended Posts

Hi ED Team, hi DCS pilots,

 

since the DCS 2.5.6.57264 Open Beta update I am experiencing a slightly stuttering when I look around with my headtracking clip (DelanClip with PS3 Eye Camera and Opentrack). The game frame rate stays between 40 and 60 fps (it is locked at 60 fps) and DCS runs without any stutters even over the large towns at the Syria or the Persian Gulf map . But the head movement isn't fluent anymore. Especially when I turn my head slowly there is a permanently slightly stuttering (no frame rate decreasing). This destroys the immersion for me and wasn't definitely not existent before the update. I already deleted the fxo and metashaders2 folders and also cleaned and repaired the DCS installation.

 

Do you have any hints for me? Are there other users with similar experiences?

 

Best regards,

Rene

dcs.log

ASUS ROG Strix B450-F Gaming, AMD Ryzen 2700X, 64 GB Corsair Vengeance LPX DDR4-3000, Sapphire Nitro+ Radeon 5700XT SE, Samsung 970 EVO M.2 NVMe 250 GB (OS), Samsung 970 EVO M.2 NVMe 1 TB (DCS World), DelanClip Gamer, Thrustmaster Warthog Hotas, Logitech (Saitek) Pro Flight Rudder Pedals, Buddy-Fox A-10C UFC, Windows 10 Pro

Link to post
Share on other sites

head tracking stutter can in some cases be related to vsync, or fullscreen settings (which is again related to vsync, i guess).

 

to make sure, do a test with vsync on/off and fullscreen on/off. maybe also try alt+enter to toggle window modes while in game. if this helps, but you want to keep using fullscreen/vsync, you could also try to disable windows fullscreen optimization for the dcs.exe.

My personal wishlist after 2 years with dcs: https://forums.eagle.ru/showthread.php?t=216873

Link to post
Share on other sites

Hi twistking,

 

thank you for your tips. (Ingame-)Vsync wasn't active but Enhanced sync within the AMD Radeon settings was enabled. I tested DCS without this (deleted fxo and metashaders2 folders before), but unfortunately it didn't help. Fullscreen already is enabled in DCS and in Radeon settings and I also disabled the Windows fullscreen optimization for the dcs.exe several months ago. I am experiencing this slighty stuttering only since the latest update. I changed nothing else on my system or in DCS.

 

EDIT: And another interesting observation. When I deactivate headtracking and I use the mouse instead for view steering, it also stutters (much worser than with headtracking), but only within the cockpit. The steering of the external view by mouse is absolutely fluently.

 

Best regards,

Rene

ASUS ROG Strix B450-F Gaming, AMD Ryzen 2700X, 64 GB Corsair Vengeance LPX DDR4-3000, Sapphire Nitro+ Radeon 5700XT SE, Samsung 970 EVO M.2 NVMe 250 GB (OS), Samsung 970 EVO M.2 NVMe 1 TB (DCS World), DelanClip Gamer, Thrustmaster Warthog Hotas, Logitech (Saitek) Pro Flight Rudder Pedals, Buddy-Fox A-10C UFC, Windows 10 Pro

Link to post
Share on other sites

Here there are two tracks they (hopefully) show the issue. The first one (F-16C Caucasus) shows the slightly stuttering by using DelanClip headtracker. The second one (F-15C Nevada) shows heavily stutters by using the mouse for view steering. In the first case the frame rate is between 60 fps and 41 fps (over large forestry areas) without any stuttering as long I look straight ahead or to the side without head moving (in flight). As soon I move my head there is a slightly stuttering without any impact to the frame rate.

In the second case the frame rate is rock solid at 60 fps. As soon I move the mouse there are heavily stutters also without any impact to the frame rate.

F-16C Caucasus Stuttering with Headtracking.trk

F-15C Nevada Stuttering with View steering by Mouse.trk

ASUS ROG Strix B450-F Gaming, AMD Ryzen 2700X, 64 GB Corsair Vengeance LPX DDR4-3000, Sapphire Nitro+ Radeon 5700XT SE, Samsung 970 EVO M.2 NVMe 250 GB (OS), Samsung 970 EVO M.2 NVMe 1 TB (DCS World), DelanClip Gamer, Thrustmaster Warthog Hotas, Logitech (Saitek) Pro Flight Rudder Pedals, Buddy-Fox A-10C UFC, Windows 10 Pro

Link to post
Share on other sites

Tracks won't help. If i play your track, it replay's your recording with my settings. If these give me a smooth ride, so does playing your tracks.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to post
Share on other sites

I have the same but it seems it isn't always present. Seems like it starts a bit into a mission.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to post
Share on other sites
I have the same, but in VR . "hangs" for a split second, fairly regularly. LIke every 10 seconds or so

 

I had this problem a while ago but after disabling HAGS within Windows 10 it more or less stopped doing this, take a look and see if you have it enabled.

Link to post
Share on other sites

 

I had this problem a while ago but after disabling HAGS within Windows 10 it more or less stopped doing this, take a look and see if you have it enabled.

 

Mine is already off, but I continue to get the same behavior.

 

8700k @ 5.3ghz

32GB

solo SSD for install

2080Ti OC'd

 

Whether I use my exports or run a single screen... the micro stutters are there since the last update.

Link to post
Share on other sites

Here is a video of the issue. Pay attention when I look out the sides, it becomes super apparent at that point. Happens in F2/F3 views, too. Adjusting graphical settings to the lowest doesnt do anything either as it's not a frame issue. I'm a solid 60 the entire time or much higher when I lower settings. This is with all exports and DCS BIOS, etc shut off. I also did a flat spin so you can see just how terrible it gets.

 

Oh... and the game crashed -- lol!

 

Link to post
Share on other sites

I am having similar issues. In my case its GSYNC and extracting displays across multiple monitors. It seems that running DCS in windowed mode across multiple monitors messes up GSYNC so the refresh rate overshoots the FPS by 20Hz and is more erratic causing the stutter. In testing windowed mode on one monitor works smooth as silk, as well as fullscreen.

 

Before the update I had no issues, and it was smooth as silk. However, in my testing every game is doing this now which leads me to think its an Nvidia or Windows issue, both which updated around the same time.

[sIGPIC][/sIGPIC]

ATPL - B737 - Class I Instructor Rating - Seaplane

Link to post
Share on other sites
Here is a video of the issue.

That's already severe stutter. Mine is hardly like that, it's barely noticable on my end.

 

 

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to post
Share on other sites

That's already severe stutter. Mine is hardly like that, it's barely noticable on my end.

 

The same as mine. Just a slight stuttering and only during head movements without any impact to the frame rate. The stuttering in the video of Guppy is very heavy.

 

ASUS ROG Strix B450-F Gaming, AMD Ryzen 2700X, 64 GB Corsair Vengeance LPX DDR4-3000, Sapphire Nitro+ Radeon 5700XT SE, Samsung 970 EVO M.2 NVMe 250 GB (OS), Samsung 970 EVO M.2 NVMe 1 TB (DCS World), DelanClip Gamer, Thrustmaster Warthog Hotas, Logitech (Saitek) Pro Flight Rudder Pedals, Buddy-Fox A-10C UFC, Windows 10 Pro

Link to post
Share on other sites

 

I had this problem a while ago but after disabling HAGS within Windows 10 it more or less stopped doing this, take a look and see if you have it enabled.

 

I wasn't even aware of this new feature. Mine is set to off i think because from what i've read it needs to be turned on manually, but who knows maybe in my case 'on' might actually be beneficial. Also haven't tested the new nvidia driver yet. Thx man, got some testing to do tomorrow

 

SATAL : "Summary - Tomcat limited to 2 AIM-54A mk74 Phoenix per aircraft for both Diamond and Gold leagues. All other Phoenix types, AIM-54A mk60 and AIM-54C, are currently banned."

Link to post
Share on other sites

Same here, regardless of settings. I can crank everything up and fly in VR getting this, or I can switch to "looks like Flanker 2.5" in pancake with fps in excess of 150 and still get the stuttering, with both TIR4+TCP and VR in the CV1 (didn't bother trying the Q1/VD and I can't link, no cable here for that). Especially noticable when doing VR zoom.

 

 

 

2004 64 Pro · Gigabyte GA Z77-D3H (BIOS v.23b) · Intel i5 3570k @4.4 · Crucial Ballistix Tactical 32GB CL8 DDR3-1600 · Micron M550 256GB + Crucial MX500 1TB

MSI GTX 1080 Gaming X 8G (452.06) · SB X-Fi Elite Pro (6.0.230.12) · VIA HD onboard audio (6.0.1.8700) · Eizo EV2436WFS-BK · Teufel Concept E Magnum

MS FFB2 · MFG Crosswind · MS P2 + PP (sliders) · Dual Saitek Pro Flight Throttle Quadrant · HOTAS Warthog Throttle · TrackIR 4 (5.1.3) · Rift CV1

 

 

Generally no screen sync at all except for the ASW in Rift, AA always off, no SS, PD = 1.0. Scheduling is off, of course at was the first thing I did after the 2004 update. Only tried it once when trying to get the other sim to run, even there it was better without, so I kept if off.

dcs-dashie-ed.jpg.c4fa047dc1c71d5ceb1913aa54b2a11e.jpg

Link to post
Share on other sites

I think this issue is a Windows 10 update one. I reverted back to the previous beta, the one before the big update and I still get slight glitches, whereas I didn't before.

i7 8700k @ 5.0ghz. Strix GTX1080Ti. 32GB RAM @ 3600. 2x Hyper X SSD’s with DCS on one. Oculus Rift S. Asus PG278-QR. Liquid Series PC with liquid CPU and GPU cooling.

Link to post
Share on other sites
I think this issue is a Windows 10 update one. I reverted back to the previous beta, the one before the big update and I still get slight glitches, whereas I didn't before.

 

It's not, I'm on a very outdated version of Windows 10 (from like January) and I also got this problem with latest versions of DCS. It's most severe on a map that I had to move to an HDD and symlink back to save space on SSD (Nevada to be precise). Something about the new memory management, I can run higher texture settings now and maintain stability, but I get this stutter, it's like it's reading from disk way more now. I assume reducing terrain textures to low might improve this, haven't checked yet.

Link to post
Share on other sites

I am also seeing this issue in VR and before this update everything was smooth even with fast head movement unless there were a lot of AI assets near. This issue makes landing on the deck very difficult with a stutter every 10-20sec and I also get it when flying close to another plane either AI or player.

System Specs: i9 9900KS, EVGA 2080 TI FTW 3 Ultra OC'd, 32gb Gskill Trident Z Royal ram(for the bling), Samsung 970 PRO M.2 SSD,. Thrustmaster HOTAS Warthog throttle and VKB GF3/MCG PRO stick, MFG Crosswind V2, HP REVERB.

 

DCS modules: F-14, F-18, F-16, A-10, Nevada and PG

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...