Jump to content

Vaicom creates both Saved Games folders


Recommended Posts

My Vaicom always writes to both a DCS directory and a DCS.openbeta directory in the Saved Games directory. Is this normal behaviour? Is there anyway to stop it doing so? I only run the open beta branch so I don't need Vaicom creating a DCS directory every time it runs.

 

The main problem is that Simshaker for Aviators looks for a DCS directory in the saved games directory and uses that by default. Only if there is no DCS directory does it then look for and use the DCS.openbeta directory. So I would like to have Vaicom stop pointlessly creating the DCS directory if possible.

 

Thanks for any help with this.

Link to post
Share on other sites
My Vaicom always writes to both a DCS directory and a DCS.openbeta directory in the Saved Games directory. Is this normal behaviour? Is there anyway to stop it doing so? I only run the open beta branch so I don't need Vaicom creating a DCS directory every time it runs.

 

The main problem is that Simshaker for Aviators looks for a DCS directory in the saved games directory and uses that by default. Only if there is no DCS directory does it then look for and use the DCS.openbeta directory. So I would like to have Vaicom stop pointlessly creating the DCS directory if possible.

 

Thanks for any help with this.

No - it should only update one of them - i am guessing you have an old entry somewhere in the registry.

 

Please could you start VA / Vaicom with Vaicom debug on and see what entries you have at the start of the log relating to paths

 

Away from PC - sent using Tapatalk

 

 

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

Hey, thanks for the fast response!

 

I was in the middle of attaching my Vaicom startup log when my internet connection went down (on mobile now).

 

In any case, the log mentions the install directory, and both the DCS directory and the DCS.openbeta directory.

 

Is there a registry entry I can change/remove to focus Vaicom on only the openbeta one?

 

Link to post
Share on other sites

There is, but seeing the log will help me ensure I give you the correct advice

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

Okay, internet access returned.

 

Here's the startup log:

 

 

3:11:46.116 Plugin 'VAICOM PRO 2.5' initialized.

3:11:46.108 Ready for commands.

3:11:46.107 Startup finished.

3:11:46.099 Listening suspended

3:11:45.837 Chatter initialized.

3:11:45.837 Resources added.

3:11:45.834 Adding chatter resources.. Default

3:11:45.834 Chatter theme set to Default

3:11:45.833 Adding themepack collections

3:11:45.826 No new DCS modules to import.

3:11:45.825 Success.

3:11:45.825 Building master labels table...

3:11:45.824 Success.

3:11:45.817 Building master keywords table...

3:11:45.816 Adding 0 imported menu commands.

3:11:45.814 Adding 0 imported ATC aliases.

3:11:45.812 Done.

3:11:45.811 Updating aliases..

3:11:45.808 Success.

3:11:45.807 Loading F10 menu items...

3:11:45.806 Success.

3:11:45.796 Loading keywords database...

3:11:45.775 Done.

3:11:45.774 Importing RIO extension pack...

3:11:45.739 Checking VA profile.

3:11:45.738 DCS World version STEAM not found.

3:11:45.722 6/7 DCS-side files were updated.

3:11:45.717 Reset: gameMessages.lua

3:11:45.716 Reset: TabSheetBar.lua

3:11:45.715 Reset: common.lua

3:11:45.713 Reset: speech.lua

3:11:45.712 Reset: RadioCommandDialogsPanel.lua

3:11:45.710 Reset: VAICOMPRO.export.lua

3:11:45.709 Unchanged: Export.lua

3:11:45.708 Saved Games folder = D:\Saved Games\DCS.openbeta

3:11:45.706 Install path = F:\DCS World

3:11:45.702 Using Registry entry for 2.5 OpenBeta

3:11:45.701 DCS World installation found: version 2.5 OpenBeta

3:11:45.601 6/7 DCS-side files were updated.

3:11:45.596 Reset: gameMessages.lua

3:11:45.594 Reset: TabSheetBar.lua

3:11:45.593 Reset: common.lua

3:11:45.591 Reset: speech.lua

3:11:45.590 Reset: RadioCommandDialogsPanel.lua

3:11:45.588 Reset: VAICOMPRO.export.lua

3:11:45.586 Unchanged: Export.lua

3:11:45.585 Saved Games folder = D:\Saved Games\DCS

3:11:45.583 Install path = F:\DCS World

3:11:45.582 Using Registry entry for 2.5

3:11:45.582 DCS World installation found: version 2.5

3:11:45.572 Executing automatic lua code installation.

3:11:45.470 License: PRO

3:11:45.469 Plugin version 2.5.22.2 (release)

3:11:45.018 Initializing..

3:11:45.018 Press LCtrl+LAlt+C for config.

3:11:45.018 VAICOM PRO for DCS World. License: PRO

3:11:44.849 Plugin support enabled.

 

 

Link to post
Share on other sites

I think you need to go into the Registry editor and delete key HKEY_CURRENT_USER>SOFTWARE>Eagle Dynamics>DCS World

 

Don't delete the OpenBeta registry key (although if you do you can fix this using the Fix Reg option of the Vaicom Config custom path)

 

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

Awesome! That seems to have solved the issue. Log now looks like :

 

 

4:48:45.658 Plugin 'VAICOM PRO 2.5' initialized.

4:48:45.647 Ready for commands.

4:48:45.646 Startup finished.

4:48:45.640 Listening suspended

4:48:45.400 Chatter initialized.

4:48:45.399 Resources added.

4:48:45.396 Adding chatter resources.. Default

4:48:45.396 Chatter theme set to Default

4:48:45.395 Adding themepack collections

4:48:45.389 No new DCS modules to import.

4:48:45.387 Success.

4:48:45.387 Building master labels table...

4:48:45.386 Success.

4:48:45.376 Building master keywords table...

4:48:45.375 Adding 0 imported menu commands.

4:48:45.374 Adding 0 imported ATC aliases.

4:48:45.372 Done.

4:48:45.371 Updating aliases..

4:48:45.369 Success.

4:48:45.367 Loading F10 menu items...

4:48:45.367 Success.

4:48:45.354 Loading keywords database...

4:48:45.333 Done.

4:48:45.331 Importing RIO extension pack...

4:48:45.295 Checking VA profile.

4:48:45.294 DCS World version STEAM not found.

4:48:45.237 6/7 DCS-side files were updated.

4:48:45.232 Reset: gameMessages.lua

4:48:45.230 Reset: TabSheetBar.lua

4:48:45.229 Reset: common.lua

4:48:45.228 Reset: speech.lua

4:48:45.227 Reset: RadioCommandDialogsPanel.lua

4:48:45.224 Reset: VAICOMPRO.export.lua

4:48:45.223 Unchanged: Export.lua

4:48:45.223 Saved Games folder = D:\Saved Games\DCS.openbeta

4:48:45.221 Install path = F:\DCS World

4:48:45.220 Using Registry entry for 2.5 OpenBeta

4:48:45.220 DCS World installation found: version 2.5 OpenBeta

4:48:45.219 DCS World version 2.5 not found.

4:48:45.211 Executing automatic lua code installation.

4:48:45.110 License: PRO

4:48:45.110 Plugin version 2.5.22.2 (release)

4:48:44.657 Initializing..

4:48:44.657 Press LCtrl+LAlt+C for config.

4:48:44.657 VAICOM PRO for DCS World. License: PRO

4:48:44.487 Plugin support enabled.

 

 

 

 

And no extra folder was created. Thank you so very much. That was driving me spare. I hugely appreciate your help with this.

 

Cheers

Link to post
Share on other sites

My pleasure and glad to find another HHGTTG fan on here judging from your user name :thumbup:

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

Excellent - I haven't got there yet (relistening to the classics at the moment)

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...