Jump to content

VR frame times suddenly spike


Recommended Posts

As title states, I'll occasionally see sudden and persistent frame time spikes. Scenario will be I take off with a solid framerate, 45 on the ground, and easily above in the air with as high as 90, but probably 65-70 average. These will be busy missions, MP servers (private dedicated server for my friends and I). I'll take off and fly to an AO, during this time my frame rates will be good, but when I engage an enemy the first time (usually first time) I'll suddenly see spikes in frame times resulting in a persistent low framerate, in the low teens. I'll alt + tab into desktop and check out task manager, nothing crazy going on, and sometimes that fixes it, just switching windows. Sometimes it hangs around a little and I'll be looking through task manager and suddenly I'll see steamVR graph go to green and everything will be fine. Then sometimes that's all it takes and the rest of the mission goes smoothly, other times I'll get a hiccup again. I can't find anything that is causing this.

 

 

System Specs: i9 9900K 5.1ghz, Strix RTX2080 OC, 32gb DDR4 4000mhz, game on a 1tb NVME. temps all look good. All my frame rate / frame time data comes from fpsVR. Steam SS 100%, PD 1.0.

 

Edit: HMD is Valve Index, set to 90hz, no motion smoothing


Edited by Astronaut
Link to post
Share on other sites

Have you gout anything in exports.lua...?

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

try commenting it out ad to minus symbols at the front or just rename exports.lua, it should be ok

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites
As title states, I'll occasionally see sudden and persistent frame time spikes. Scenario will be I take off with a solid framerate, 45 on the ground, and easily above in the air with as high as 90, but probably 65-70 average. These will be busy missions, MP servers (private dedicated server for my friends and I). I'll take off and fly to an AO, during this time my frame rates will be good, but when I engage an enemy the first time (usually first time) I'll suddenly see spikes in frame times resulting in a persistent low framerate, in the low teens. I'll alt + tab into desktop and check out task manager, nothing crazy going on, and sometimes that fixes it, just switching windows. Sometimes it hangs around a little and I'll be looking through task manager and suddenly I'll see steamVR graph go to green and everything will be fine. Then sometimes that's all it takes and the rest of the mission goes smoothly, other times I'll get a hiccup again. I can't find anything that is causing this.

 

 

System Specs: i9 9900K 5.1ghz, Strix RTX2080 OC, 32gb DDR4 4000mhz, game on a 1tb NVME. temps all look good. All my frame rate / frame time data comes from fpsVR. Steam SS 100%, PD 1.0.

 

Edit: HMD is Valve Index, set to 90hz, no motion smoothing

 

This happens to me as well, I kind of just chalk it up as DCS being DCS. Out of curiosity, when you switch to task manager do you have the GPU usage column enabled? If so, try organizing by that and see if Desktop Windows Manager is really high GPU usage. It's strange, but ya seemingly switching to task manager will clear it up after 5-30 seconds.

Link to post
Share on other sites

: is Valve Index, set to 90hz, no motion smoothing

 

I would definitely set motion smoothing to be enabled... I don't know your in game settings, but I suspect this is at least in part the cause of you stuttering.

 

 

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

 

This happens to me as well, I kind of just chalk it up as DCS being DCS. Out of curiosity, when you switch to task manager do you have the GPU usage column enabled? If so, try organizing by that and see if Desktop Windows Manager is really high GPU usage. It's strange, but ya seemingly switching to task manager will clear it up after 5-30 seconds.

 

Yes! This is the exact same thing as me. Desktop Windows Manager will spike as well. I'll try motion smoothing again, I didn't get a chance to test out settings after last post, the one time I tried this weekend to play I got a CTD (Just DCS things) about 15-20 min into my flight, I wouldn't have had time to retry it so meh. I had GPUZ up, fpsVR, and task manager, figured something didn't play nice.

 

 

Link to post
Share on other sites

 

Yes! This is the exact same thing as me. Desktop Windows Manager will spike as well. I'll try motion smoothing again, I didn't get a chance to test out settings after last post, the one time I tried this weekend to play I got a CTD (Just DCS things) about 15-20 min into my flight, I wouldn't have had time to retry it so meh. I had GPUZ up, fpsVR, and task manager, figured something didn't play nice.

 

 

DWM spiking sounds like... well... you're letting Windows manage your screens. Xbox game bar, and fullscreen optimizations, and Hardware GPU scheduling and all that stuff should be disabled. Fullscreen optimizations especially, if you don't disable it, DCS is not truly running in fullscreen. It's running in borderless Windowed mode and dwm.exe will manage that. Somehow MS thinks borderless windowed mode is more efficient. Not for DCS.

 

You can try to run dwm.exe on separate core than DCS but this might cause some glitches on your desktop.

 

Also, those monitoring apps like Afterburner and fpsVR will take quite a bit of resources as well. I've seen them take up to 15% of CPU. So use them for troubleshooting but turn them off for playing. Afterburner for example, you actually have to disable monitoring from options. Just closing the window doesn't turn it off.

Link to post
Share on other sites

 

DWM spiking sounds like... well... you're letting Windows manage your screens. Xbox game bar, and fullscreen optimizations, and Hardware GPU scheduling and all that stuff should be disabled. Fullscreen optimizations especially, if you don't disable it, DCS is not truly running in fullscreen. It's running in borderless Windowed mode and dwm.exe will manage that. Somehow MS thinks borderless windowed mode is more efficient. Not for DCS.

 

You can try to run dwm.exe on separate core than DCS but this might cause some glitches on your desktop.

 

Also, those monitoring apps like Afterburner and fpsVR will take quite a bit of resources as well. I've seen them take up to 15% of CPU. So use them for troubleshooting but turn them off for playing. Afterburner for example, you actually have to disable monitoring from options. Just closing the window doesn't turn it off.

 

So thanks for the tips.

Game bar, game mode, hardware accelerated gpu scheduling, fullscreen optimization all disabled already. I've gone through all the "VR Optimization guides", done the Nvidia control panel stuff. I don't normally have afterburner (percisionX1) running and really just use fpsVR because of these stutters. I added in GPUZ just to see if there was anything else going on I could see while I was testing it out but didn't even get to the "bug" before the CTD. Haven't used GPUZ while the issue was happening yet. I would normally think it's windows 10 related (and might still be I dunno, but if so I have no idea how to fix it), but it reliably happens when I dive in to drop the first bomb on a target (it's happened A-A but not as much). The reliably of when it happens leads me to think there's something DCS related that triggers it. And yeah, after 5-30 seconds it works its self out.

 

edit: as some additional info, I've been playing on Syria almost exclusively since it came out, I had been taking a bit of a break from the game before due to real life.

e7769982e308ca705f1f36d7503553be.png.4673ac233a32e80ff8794722f479e86f.png

Link to post
Share on other sites

So short update

 

I checked the full screen box, verified all the settings and flew a mission. Fired off since mavericks from the f-16 no issues, did a gun strafe of sure helos at an airport and same issue, 17-20fps for about 25 seconds. Alt + tab to desk top and then it went back to normal, back into the game and it's 45-65 fps. I don't get it

Link to post
Share on other sites

What av are you using? Do you have any mods installed at all? Try renaming your dcs directory in saved games, dcs will re-create when it next launches....

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites
What av are you using? Do you have any mods installed at all? Try renaming your dcs directory in saved games, dcs will re-create when it next launches....

 

I don't know what you are referring to with "av". I have your shaders IC pass mod, bailey's DICE, SRS, MAM, CAM, and A-4E, but I was having this issue even before. And none of those assets were being used in the missions I'm doing.

I had some driver issues over the summer so I did a fresh windows install, and a fresh DCS Open Beta (standalone) install a few months ago. It was doing this even with the fresh install no mods.

Link to post
Share on other sites

AV = Anti Virus

 

 

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

also worthwhile checking the WDM priority it should be normal

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

I had some preliminary luck with one solution. I changed my pagefile from automatically managed to 16384 - 16384. Today I did a mission and did not get any of the sudden and persistent frametime spikes. It doesn't make a ton of sense to me but I don't know what the code is accessing and moving around behind the scenes. This is just a single instance of it not spiking though, so I wouldn't say it's for sure solved. I just had one good trial.

Link to post
Share on other sites
I had some preliminary luck with one solution. I changed my pagefile from automatically managed to 16384 - 16384. Today I did a mission and did not get any of the sudden and persistent frametime spikes. It doesn't make a ton of sense to me but I don't know what the code is accessing and moving around behind the scenes. This is just a single instance of it not spiking though, so I wouldn't say it's for sure solved. I just had one good trial.

 

Why so large normally the recommended page file is 1/4 ram plus the amount you need for a crash dump?

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

 

Why so large normally the recommended page file is 1/4 ram plus the amount you need for a crash dump?

 

The recommended size for maximum setting is actually 4 times the RAM capacity. https://www.poweradmin.com/blog/pagi...usage-counter/

You only set it lower if you have not enough space. Setting min and max to the same value minimizes disk activity during OS's page file management because the allocated size is fixed. The less RAM you have, the more important a large pagefile becomes.

i9 10920X @4.8GHz, 3090 OC, 64 GB RAM @3600, Valve Index, HOTAS & Rudder: all Virpil with FFB base mod (G940)

Link to post
Share on other sites

errr https://docs.microsoft.com/en-us/windows/client-management/determine-appropriate-page-file-size

 

"Varies based on page file usage history, amount of RAM (RAM ÷ 8, max 32 GB) and crash dump settings."

 

 

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites
errr https://docs.microsoft.com/en-us/windows/client-management/determine-appropriate-page-file-size

 

"Varies based on page file usage history, amount of RAM (RAM ÷ 8, max 32 GB) and crash dump settings."

 

 

From the same page: "Page file sizing depends on the system crash dump setting requirements and the peak usage or expected peak usage of the system commit charge. Both considerations are unique to each system, even for systems that are identical. This means that page file sizing is also unique to each system and cannot be generalized."

 

DCS commits 39GB on my end if i choose to fly on the syria map for instance. I would recommend to set a minimum=maximum of 64 GB for the pagefile because of DCS high peak usage.

i9 10920X @4.8GHz, 3090 OC, 64 GB RAM @3600, Valve Index, HOTAS & Rudder: all Virpil with FFB base mod (G940)

Link to post
Share on other sites

never seen dcs actually touch my page file... (i dont mean dont have one) ymmv

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

This is RAM usage and pagefile usage during that same session. And like I said, I had the issue again with the larger pagefile so I don't think that actually did anything to help me. Looks like the GPU might be trying to pull something from RAM or SSD and gets hung up.

9681234dfeabbb937d37ca0cb6b2f95c.thumb.png.b67b5ff15cc6294fcb51e21a18020739.png

Link to post
Share on other sites

I would guess thats right on a 8gb card , and you might need to reduce some of your graphics settings to accommodate

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...