Jump to content

Fix for SLI flashing clouds in LOMAC


Recommended Posts

I have tried to make SLI work for quite some time with LOMAC and spent countless hours scouring the inetnet for a solution to no avail. Running the game with SLi enabled results in flickering clouds and flashing MFD displays(A10). At the very least I wanted to have SLI on so I wouldnt have to keep switching it on and off every time I play a different game....very annoying. I didnt spent $ 3500.00+ on a system to have to disable hardware. It seemed to me to be a driver issue because with Sli off the game runs just fine. I finally came across this great program that allowed me to run the game WITH SLi enabled.

Im using Vista x64 Nvidia driver version 174.74 beta and nHancer 2.4.0 beta 7 It should work with older versions.

 

Workaround

1) Go to http://www.nhancer.com/ and download the latest build for your OS, I'm using the 64 bit version. This nice program allows you to get at settings you can't normally access through the Nvidia control panel.

2) Install nHancer and then start the program.

3) Go to the Options menu and click on the last item ( allow override of predefined settings), make sure its checked and enabled

4) Unser the settings box make sure the profile radio button is checked.

5)In the Profiles window scroll down to "Lock on" and select it. Below that there is a checkmark for "Profile can be activated manually" check that box.

6) Select the "SLI MODE" tab and select Alternate Frame Rendering from the dropdown box. There is a checkbox for Lock On under the COmpatibility flags. By default on my system it isnt selected but it may be of interest. It doesnt seem to do anything to the game with it checked or unchecked.

7) Click on the enhancements tab on the right side of the window, put a check in for Anti-Aliasing, underneath that select the SLI radio button and the SLI 32xQ ( You can use lower settings here but it doesnt really affect performance) and put a check next to the Super- Transparency AA.

8) Close the window you are done. Right click the nHancer icon in your system tray ( lower right side on your taskbar) and go to the Activate Profile item, select the Lock on profile.

9) Run the Game as normal. You will have to manually select the profile each time before you load the game but it beats having to switch SLI on and off.

Basically we are using the SLI AA to fix the problem and make the game look way better. You wont see a big FPS improvement but you wont have any jaggies in the game and the clouds and MFD will now render correctly with SLI on. I get about 22-30 FPS in the game with all settings on High, the highest water setting and All planar shadows.

  • Like 1

[sIGPIC][/sIGPIC]

 

System Specs

 

Intel I7-3930K, Asrock EXTREME9, EVGA TITAN, Mushkin Chronos SSD, 16GB G.SKILL Ripjaws Z series 2133, TM Warthog and MFD's, Saitek Proflight Combat pedals, TrackIR 5 + TrackClip PRO, Windows 7 x64, 3-Asus VS2248H-P monitors, Thermaltake Level 10 GT, Obutto cockpit

 

Link to comment
Share on other sites

Well I have "Split Frame Rendering" Forced ( a must ) Vista Ultimate 32bit I get well above 120 fps ( 174.85 Beta ) 174.74 had an SLI trouble for me....

It's easy to do this by the Nvidia profiler no need of this troubled Nhancer this can cause troubles for many so use it with caution..

To see if you are using SLI i mean Really use it.. check the Show SLI Visual Indicator in your Nvidia controls.. I've seen many loosing SLI faculty due to nhancer.

Link to comment
Share on other sites

SLI hasnt worked for me in this game at any point or driver version. I tried it under Vista x86-no go, and I've since switched to Vista Ultimate x64 SP1 All I ever got is flashing clouds and MFD with zero FPS improvement with SLI enabled. Turning it off fixes the problem but I play different games other than LOMAC and it's a real hassle to enable and disable Sli all the time. The point of using nHancer is so that you can use SLI antialiasing(no it's not the same AA as what you can access in the nvidia control panel) and not have flickering clouds. The SLI works perfect in all other games except this one.

I checked on Nvidia's site....didnt see any 174.85 on there and I'm not taking a chance on some hacked up virus ladden driver off guru3d.....been there done that.

 

SLI Anti-Aliasing modes are using the two graphic cards to offer a near-Supersampling quality. They are especially usefull for games which are not directly compatible with SLI, i.e. which don't run faster with an SLI setup. Using SLI Anti-Aliasing, the SLI power can be used in those cases to gain some image quality at least. - quoted from nHancer

[sIGPIC][/sIGPIC]

 

System Specs

 

Intel I7-3930K, Asrock EXTREME9, EVGA TITAN, Mushkin Chronos SSD, 16GB G.SKILL Ripjaws Z series 2133, TM Warthog and MFD's, Saitek Proflight Combat pedals, TrackIR 5 + TrackClip PRO, Windows 7 x64, 3-Asus VS2248H-P monitors, Thermaltake Level 10 GT, Obutto cockpit

 

Link to comment
Share on other sites

never had a virus issue from guru3d but i certainly do get the flickering clouds, never thought to just turn the sli off, but as you said why should you, there has to be a better way.

 

still on xp pro sp2, so your solution or fix may be irrelavent here but i appreciate the question being raised.

 

for reference sake i am currently runnning 169.44 xp 32.

these seem to be very stable on my system.

Link to comment
Share on other sites

an intersting subject, SLI

 

Hi Guys.

I'm trying to make a decision on whether or not to build a system where I can go SLI in the future, but I've read where the results are not worth the investment. Yet in this thread Slayer gets 22-30 fps while Gozr gets 120+fps (both while flying LOMAC, I assume). I don't get it.:huh: I intend to add Black Shark, KOTS, and SoW_BoB to my title shelf but I don't know if I should invest in SLi or even Crossfire if the results don't warrant the investment. Somebody spread some knowledge, please.:helpsmilie:

thanks!

Flyby out

ps here's an intersting tech article on SLi v Crossifire

http://www.hardwaresecrets.com/article/391/1

The U.S. Congress is the best governing body that BIG money can buy. :cry:

Link to comment
Share on other sites

I too have never had issues with LockOn and SLI except with one of the drivers nvidia issued, but the next one fixed it again. The flashing clouds only happened with that one driver version, before and after it, all the drivers worked great in LockON with SLI.

No need to use other programs.

:thumbup:

 

99th flyby, LockOn and Flaming Cliffs do not take advantage of SLI very much at all due to their age, so basically it only helps very little in the FPS. As for BlackShark, it is a new sim coming out so I imagine/assume that it will take advantage of SLI should you choose to invest in that direction.

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

I use nHancer, I really like it, I had the problem with flashing textures when I first loaded up Lock On after a very long hiatus. I no longer have that problem. Here are my settings in nHancer for Lock On

 

nHancer settings for Lock On

 

Enhancements

AA......................SLI @ SLI 8x with no jaggies or flashing textures

Gamma Correction ........... On

Multisampling ...................On

AF....................................16x

Verticle Sync.....................On

Force Triple Buffer...............On

Color Scheme.....................Unchecked

 

Optimizations

Texture Filtering ................Quality

Trilinear Opt.......................Off

Aniso. Filter Opt.................Off

Aniso. Sample Opt.............Off

Negitive Lod Bias................Clamp

Adjust LOD Bias.................Unchecked

Force DXT3 (Open GL)........Unchecked

Prerender Limit...................3

 

Compatibility

Force Mip Maps.................Trilenear

High Dymanic Range..........Disabled

Conformannt Text clamp.....Off.........Open GL..... not needed

Driver Extention Limit.........0............Open GL.....not needed

Reported Open GL vers......Unchecked

OpenGL Control................Unchecked

Dymanic Tiling..................1

CPU Multi Core Support......Multi core

 

SLI

SLI Load Bal Graph.........Off, used to check how well SLI works in application

SLI Stereo Mode ............0

 

SLI Mode

Alternate Frame Rendering w/no compatibility flags set

Open GL Flags..............Default

 

I'm using nvidia driver 169.13, tweak guides (http://www.tweakguides.com/) has proven that when you set AA in the game profile it will stick, and you don't have to use the Global setting to make AA work in game

And this one is very stable for me

I'm running EVGA 680i, Intel e6700, 2 gig Corsair RAM, 2x EVGA 8800GTX in SLI. Lock On works great, IL-2 on the other hand sucks because I can't get Vertical sync to work for very long

and I just won't fly without TIR.......................

 

Hope this helps.....

[sIGPIC]VFA-151_zpsc7bcfa86.png[/sIGPIC]

Link to comment
Share on other sites

thanks Talon

 

I too have never had issues with LockOn and SLI except with one of the drivers nvidia issued, but the next one fixed it again. The flashing clouds only happened with that one driver version, before and after it, all the drivers worked great in LockON with SLI.

No need to use other programs.

:thumbup:

 

99th flyby, LockOn and Flaming Cliffs do not take advantage of SLI very much at all due to their age, so basically it only helps very little in the FPS. As for BlackShark, it is a new sim coming out so I imagine/assume that it will take advantage of SLI should you choose to invest in that direction.

But isn't Black Shark using basically the same grahic engine, exept updated to DX9? I'll need to do a bit more checking on that point.

thanks for chiming in.;)

Flyby out

update: I just checked and it was recently posted that BS will not support SLI.

The U.S. Congress is the best governing body that BIG money can buy. :cry:

Link to comment
Share on other sites

I'm in the camp that SLI has never made any difference for me in Lock On either...

 

It says it's enabled and I've tried all types, but there is absolutely no fps change.

 

(1GB 7950GX2)

Intel i9-9900KF @5.2GHz

MSI Z390 Gaming Pro Carbon

32GB G.Skill Trident Z DDR3200 RAM

MSI RTX 2080 Ti Gaming X Trio

40" Panasonic TH-40DX600U @ 4K

Pimax Vision 8K Plus / Oculus Rift CV1 / HTC Vive

Gametrix JetSeat with SimShaker

Windows 10 64 Bit Home Edition

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Well I was interested in the "STRAPLINE HEADING " fix flashing clouds... but all I get is more nonsense abreveations, what is SLi? and why is this so called "fix" seemingly complex and delicate to do?

  • Like 1

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

i ve got hudge improve with my SLI on , but i still have got cloud flash problem. so i m flying SLI off .

btw ntune soft manage badly the af AND aa, i have to set it correctly in general, coz it does not work properly when i put my setting in profile page lol

 

XPS 720, XP 32b, q6600,mobo nF680Sli, 1To,4GB ddr2 800mhz, SLI 2x8800 GTX 169.21, creative Xfi xtreM Music

Link to comment
Share on other sites

=RvE=Paploo, i would like to know your settings in the general, i am experimenting and must say i find it slightly confusing.

coould you please list your general settings, thanks.

 

Ogreman, SLi is two videocards working together, the problem is flashing clouds, the fix i guess is 'delicate' as you need to mess with nhancer, which looks powerful and some seem to have issues with it.

 

if you hang around long enough you will begin to love abbreviations, this genre is full of them.

Link to comment
Share on other sites

  • 2 months later...

-=Phoenix=- (anyone) how does LOMAC performace scale in SLi mode? Do two cards get you double the frame rates of one card? I don't really believe that SLI would do that well, but I'd like to know the performance improvement %.

Flyby out

The U.S. Congress is the best governing body that BIG money can buy. :cry:

Link to comment
Share on other sites

@ _-Phoenix_-

 

Thanks a lot, you just made me solve my problem.

I just got recently that amazing nvidia geforce 9800 GX2 black edition from XFX and it is just fantastic. My only problem was the flicker (clouds, canopy and MFD). I just put force alternate frame rendering1 in the nVidia control pannel for LOCKON specifically and the problem just vanished!

 

Thanks!

 

JEFX

[sIGPIC][/sIGPIC]

In DCS I fly jets with thousands of pounds of thrust...

In real life I fly a humble Cessna Hawx XP II with 210 HP :D

Link to comment
Share on other sites

I was looking at the 9800GX2 too, but what card did you replace with and what were the improvements?

[sigpic]http://forums.eagle.ru/signaturepics/sigpic4448_29.gif[/sigpic]

My PC specs below:

Case: Corsair 400C

PSU: SEASONIC SS-760XP2 760W Platinum

CPU: AMD RYZEN 3900X (12C/24T)

RAM: 32 GB 4266Mhz (two 2x8 kits) of trident Z RGB @3600Mhz CL 14 CR=1T

MOBO: ASUS CROSSHAIR HERO VI AM4

GFX: GTX 1080Ti MSI Gaming X

Cooler: NXZT Kraken X62 280mm AIO

Storage: Samsung 960 EVO 1TB M.2+6GB WD 6Gb red

HOTAS: Thrustmaster Warthog + CH pro pedals

Monitor: Gigabyte AORUS AD27QD Freesync HDR400 1440P

 

Link to comment
Share on other sites

Pilotasso,

 

It is difficult to tell exactly the improvement because at the same time that I changed my card (from a 7950X2), I also went from a 21'' CRT in 1600X1200 to a TH2Go setup with 3840X1024, which my old card could not handle very well...

 

All I can say is that it did an amazing improvement with the new setup. (like going from as low as 7 FPS on takeoff at AirBases to 30ish FPS).

 

Be warned though that you might have to change your PSU. I had a 600 Watts and it was definitely not enough. I dont know about the 800 that you have. You need a PSU with both a 6 pin plug AND a more recent 8 pin PCI plug.

 

It really works great (it makes quite some noise though, but I still love it because I can really enjoy seemless motion, even through dark smoke and explosions.)

 

Here is a really deep review of the card on Widescreengamingforum :

http://www.widescreengamingforum.com/wiki/index.php/NVIDIA_GeForce_9800GX2_Review

 

hope this helps, keep us posted!

 

You can see my post about my new setup here :

http://forums.eagle.ru/showthread.php?p=513139#post513139

 

dsc03546rm4.jpg

 

:D:D:D

 

 

JEFX

[sIGPIC][/sIGPIC]

In DCS I fly jets with thousands of pounds of thrust...

In real life I fly a humble Cessna Hawx XP II with 210 HP :D

Link to comment
Share on other sites

My PSu is 850W not 800, and I have the 8 pin connector and several 6 pin avaiable. It draws that much power? :huh:


Edited by Pilotasso

[sigpic]http://forums.eagle.ru/signaturepics/sigpic4448_29.gif[/sigpic]

My PC specs below:

Case: Corsair 400C

PSU: SEASONIC SS-760XP2 760W Platinum

CPU: AMD RYZEN 3900X (12C/24T)

RAM: 32 GB 4266Mhz (two 2x8 kits) of trident Z RGB @3600Mhz CL 14 CR=1T

MOBO: ASUS CROSSHAIR HERO VI AM4

GFX: GTX 1080Ti MSI Gaming X

Cooler: NXZT Kraken X62 280mm AIO

Storage: Samsung 960 EVO 1TB M.2+6GB WD 6Gb red

HOTAS: Thrustmaster Warthog + CH pro pedals

Monitor: Gigabyte AORUS AD27QD Freesync HDR400 1440P

 

Link to comment
Share on other sites

You might be good with 850W since you have the right connectors.

I am no tech here. I am sure that you can find the exact energy consumption of the card somewhere on the net (Tom's hardware maybe?).

 

JEFX

[sIGPIC][/sIGPIC]

In DCS I fly jets with thousands of pounds of thrust...

In real life I fly a humble Cessna Hawx XP II with 210 HP :D

Link to comment
Share on other sites

@ _-Phoenix_-

 

Thanks a lot, you just made me solve my problem.

I just got recently that amazing nvidia geforce 9800 GX2 black edition from XFX and it is just fantastic. My only problem was the flicker (clouds, canopy and MFD). I just put force alternate frame rendering1 in the nVidia control pannel for LOCKON specifically and the problem just vanished!

 

Thanks!

 

JEFX

 

what is your Nvidia driver number ?

Thanks

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...