Jump to content

Open Beta Download "Couldn't Connect to Server"


Recommended Posts

Just deleted my "stable" install to free up space for the Open Beta, in order to be able to use my "brand new" A-10 C II module.

 

Downloaded the Open Beta installer without issues, but when the download actual download of the game starts, after selecting the installation directory, the thing is first "Checking for Updates" and then a pop-up message comes up:

 

COULDN'T CONNECT TO SERVER

 

Are there any server issues?

Link to post
Share on other sites

Hi

 

I have made the team aware.

 

Please follow this link and download the latest dcs_updater.exe and replace it with the one in your install location

 

http://updates.digitalcombatsimulator.com/

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites

I getting the same error message. I had to reinstall a clean version of Windows 10 due to a corrupted M.2 SSD and now I can't install either the stable or beta version of using the web installer. I get the same COULDN'T CONNECT TO SERVER message. I tried disabling my Anti-virus, and connecting directly to the internet and I get the same error. I had no issues with any of the 20 other games that I installed. I put in a ticket, but it looks like even that got lost, so I'll have to but in another ticket.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...