Jump to content

External View Axis Invert not working for mouse


Rhayvn
 Share

Recommended Posts

I concur.

 

I have had settings for mouse look to invert all axis with a modifier (because DCS has these settings backwards in external views, compared to every other game I play). This does not work anymore, and furthermore the settings for the mouse axis seems to make no difference whatsoever. No matter what I put in there, the game uses default settings. I tried resetting the settings for "General" and "UI Layer" as well, but to no avail.

 

edit: Just to be clear, this is for the Open Beta 200923 update. Release version is unaffected.


Edited by DrGonzo94
Link to comment
Share on other sites

I am seeing the same problem as described above. No matter if I unassign the mouse Y-axis or invert it, the response is always opposite of what it was before this latest open beta update.

Windows 10 Pro 64-bit

i9-9900k 3.6 GHz

ASUS ROG Strix Z390-E Gaming

64 GB 3200 MHz ram

RTX 2080 Ti

Samsung 970 pro NVMe (boot & DCS)

Link to comment
Share on other sites

Wait, it works for you? I have no change after last patch. Are you using general settings or individual plane settings?

 

Yup, the method I described above works again in openbeta 200930 update, and also 201002 update.

 

edit: Sorry, didn't properly read your question. It works for all modules I'm using (AJS37, F-16, Mi-8, FC3, Ka-50, among others). If I remove mouse look settings, mouse look is disabled. Default mouse look settings are the same as they were before 200930 update.


Edited by DrGonzo94
Link to comment
Share on other sites

Yup, the method I described above works again in openbeta 200930 update, and also 201002 update.

 

edit: Sorry, didn't properly read your question. It works for all modules I'm using (AJS37, F-16, Mi-8, FC3, Ka-50, among others). If I remove mouse look settings, mouse look is disabled. Default mouse look settings are the same as they were before 200930 update.

 

Is that camera view via Mouse in the Axis menu? I tried removing both the general and aircraft specific assignments and it made no difference (still was active). Invert doesn't work either.


Edited by medway
Link to comment
Share on other sites

Yup, the method I described above works again in openbeta 200930 update, and also 201002 update.

 

edit: Sorry, didn't properly read your question. It works for all modules I'm using (AJS37, F-16, Mi-8, FC3, Ka-50, among others). If I remove mouse look settings, mouse look is disabled. Default mouse look settings are the same as they were before 200930 update.

 

 

Can you explain step by step how did you make external mouse look inverted after last update? I don't understand.

Link to comment
Share on other sites

Here is what I observe from the last three patches - I'm currently running the Oct 7th patch (open beta 2.5.6.55960)

 

 

I've been using the A-10C and A-10C-II and see the same behavior in both modules.

 

 

Start DCS and chose either a quick mission takeoff, or join an MP server and select role->fly to go into the cockpit.

 

Select F2 for external view. Move the mouse around and note the direction the camera moves in response to mouse movement.

Mouse X-axis (left/right) -> camera pans left/right

Mouse Y-axis (up/down) -> camera pans up/down

Mouse Z-axis (scroll forward/backward) -> a/c moves farther/closer

 

Whatever I change in the axis tune dialog, for any mouse axis, I see no change in camera behavior in F2 external view. I can change deadzone, X saturation, Y saturation, curvature, or select slider, invert, user input. Nothing changes the response of the mouse to the camera view.

 

I can completely clear my mouse from the camera view assignment, and there is still no change in F2 external camera view when I move my mouse.

 

This behavior started with the Sept 23rd patch 2 weeks ago (2.5.6.55363), and has not changed with the last 2 patches.

 

 

I'm flummoxed, but I'd not be surprised if there is a simple fix or workaround.


Edited by peachpossum
add a/c modules, correct mouse Z axis behavior

Windows 10 Pro 64-bit

i9-9900k 3.6 GHz

ASUS ROG Strix Z390-E Gaming

64 GB 3200 MHz ram

RTX 2080 Ti

Samsung 970 pro NVMe (boot & DCS)

Link to comment
Share on other sites

The closest thing to workaround I found was this autohotkeys script https://autohotkey.com/board/topic/38656-using-the-left-mouse-button-to-invert-cursor/?p=242190

 

You can invert axes with LMB but it sort of jumps in big increments when in F2 view. I tried to edit some numbers in the script but it's still doing that.

If someone can make it work, let us know please.

Link to comment
Share on other sites

Can you explain step by step how did you make external mouse look inverted after last update? I don't understand.

 

I followed this guide, it worked before, and it works now.

 

 

Clear mouse axises

Set a modifier

Set each axis with modifier and then use axis tune to invert each one.

Then set mouse axis without modifier for each axis for regular in-cockpit use.

Link to comment
Share on other sites

Here is what I observe from the last three patches - I'm currently running the Oct 7th patch (open beta 2.5.6.55960)

 

 

I've been using the A-10C and A-10C-II and see the same behavior in both modules.

 

 

Start DCS and chose either a quick mission takeoff, or join an MP server and select role->fly to go into the cockpit.

 

Select F2 for external view. Move the mouse around and note the direction the camera moves in response to mouse movement.

Mouse X-axis (left/right) -> camera pans left/right

Mouse Y-axis (up/down) -> camera pans up/down

Mouse Z-axis (scroll forward/backward) -> a/c moves farther/closer

 

Whatever I change in the axis tune dialog, for any mouse axis, I see no change in camera behavior in F2 external view. I can change deadzone, X saturation, Y saturation, curvature, or select slider, invert, user input. Nothing changes the response of the mouse to the camera view.

 

I can completely clear my mouse from the camera view assignment, and there is still no change in F2 external camera view when I move my mouse.

 

This behavior started with the Sept 23rd patch 2 weeks ago (2.5.6.55363), and has not changed with the last 2 patches.

 

 

I'm flummoxed, but I'd not be surprised if there is a simple fix or workaround.

 

Same situation here.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

This issue appears to be fixed for me too using the the F-86F and the P-47-D40, though I haven't tested the A-10C-II yet where I first noticed the problem.

 

It did require me to clear the category and re-assign my camera movements before any axis tuning settings would work.

Windows 10 Pro 64-bit

i9-9900k 3.6 GHz

ASUS ROG Strix Z390-E Gaming

64 GB 3200 MHz ram

RTX 2080 Ti

Samsung 970 pro NVMe (boot & DCS)

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...