Jump to content

Performance plummets after some time


Recommended Posts

Hi

 

Can you attach a track replay showing a fps drop, just so we can replay and see what performance we get.

 

thank you

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites
I have only read the first post but if your GPU is at %100 then the card will throttle back : stutter

 

No, that’s not how it works. A GPU will throttle back once it reaches one of it’s limits: temperature, power consumption, etc. Just being used at 100% is not going to make it throttle. My GPU temp is fine, around 70C under max load. My case is well ventilated and the card is a MSI Gaming X, one of the best models of 2070S. My GPU is at 100% all the time simply because it is the performance bottleneck, which is understandable in VR.

 

@Flappie: will do.

 

@BigNewy: I will try and do that, thanks.

AMD R5 5600X | 32GB DDR4 3000MHz | RTX 2070 SUPER | HP Reverb G2 | VKB Gunfighter Pro Mk3 | Thrustmaster TCWS

Link to post
Share on other sites
No, that’s not how it works. A GPU will throttle back once it reaches one of it’s limits: temperature, power consumption, etc. Just being used at 100% is not going to make it throttle. My GPU temp is fine, around 70C under max load. My case is well ventilated and the card is a MSI Gaming X, one of the best models of 2070S. My GPU is at 100% all the time simply because it is the performance bottleneck, which is understandable in VR.

 

@Flappie: will do.

 

@BigNewy: I will try and do that, thanks.

 

Of course you are correct what I should of said if your @ 100 gpu usage check your temps but as there good my comment was irrelevant.


Edited by freehand
Link to post
Share on other sites
I agree 100% with Panzertard. Adobe Software is the next suspect on the list. Qiou, you should give it a go: you can disable all Adobe services at startup using msconfig. Don't worry, you'll still be able to enable them whenever you want.

 

 

Then reboot the PC, and try a long play.

 

I did that, at this point I only have Microsoft services running. Same problem happened after a long play. I first switched planes after 15min, and it was fine. But I played another 40min in a different server, then switched and the stutter was back.

 

How do I create a track file in multiplayer? My understanding is that it only works in SP, where I am not able to replicate this so easily (happened only once in many hours).

 

Today I will revert to the previous video driver, as it is the last solution on the list.

AMD R5 5600X | 32GB DDR4 3000MHz | RTX 2070 SUPER | HP Reverb G2 | VKB Gunfighter Pro Mk3 | Thrustmaster TCWS

Link to post
Share on other sites

When i get my RTX 3090 i will be able to get to the core of this. If DCS has a problem with it's garbage collector routine or doesn't have a routine to clean up unused assets, then it will show up as ridiculous VRAM usage with a 24GB card. Right now it's easy to fill up 11GB of a 2080ti, just happened to me again yesterday an a MP server, when i switched from a A-10 to the Ka-50. In my case i was lucky and after 5-6 minutes the normal FPS came back. I think ED has to test these scenarios more, because the problem is present for years.

i9 10920X @4.8GHz, 3090 OC, 64 GB RAM @3600, Valve Index, HOTAS & Rudder: all Virpil with FFB base mod (G940), DCS: all modules

Link to post
Share on other sites
Maybe your game can't forget the previous plane you were flying in, keeping all the data into memory... That is weird. Maybe the service is bothering you is from Windows... I'm thinkin it may be tied to memory compression in some way (app preloading/prefetching). Please take a look at this.

 

I think I found a way to replicate it in Single Player, but sending a track file is not necessarily the best solution since a track file would only correspond to the first loading.

 

I loaded the same mission (SP) multiple times. Just take off, crash, click "Fly again" (the idea is to spend 1-2min each time so the game is really loading everything around you). After the third time, the framerate is again very bad for me and I had to restart the game entirely. This is replicable for anyone, just take a heavy SP mission with lots of assets and load it multiple times. I was getting 40fps stable on the ground the first time, by the third time the FPS was dropping below 20fps and had horrible stutter. I flew it despite the stutter and it was still bad after 10min of flying, it did not solve itself over time. I had to quit that mission as it was barely playable.

 

@Alec: I would gladly join you to make this investigation, any chance you could offer me a RTX3090 as well? My b'day is coming up, so... :music_whistling::lol:

AMD R5 5600X | 32GB DDR4 3000MHz | RTX 2070 SUPER | HP Reverb G2 | VKB Gunfighter Pro Mk3 | Thrustmaster TCWS

Link to post
Share on other sites
I think I found a way to replicate it in Single Player, but sending a track file is not necessarily the best solution since a track file would only correspond to the first loading.

 

I loaded the same mission (SP) multiple times. Just take off, crash, click "Fly again" (the idea is to spend 1-2min each time so the game is really loading everything around you). After the third time, the framerate is again very bad for me and I had to restart the game entirely. This is replicable for anyone, just take a heavy SP mission with lots of assets and load it multiple times. I was getting 40fps stable on the ground the first time, by the third time the FPS was dropping below 20fps and had horrible stutter. I flew it despite the stutter and it was still bad after 10min of flying, it did not solve itself over time. I had to quit that mission as it was barely playable.

 

@Alec: I would gladly join you to make this investigation, any chance you could offer me a RTX3090 as well? My b'day is coming up, so... :music_whistling::lol:

 

It has been like that for years on and off I always restart a game for new mission or plane swap due to the same reason just restart.

Link to post
Share on other sites

Still need to make another few tests but the pagefile issue could have been the culprit. Mine was set automatically at 5GB by the system. I manually set it to 16-32GB and have seen improvements in MP. However I will make another couple of flights to check and make sure, and come back here to close the issue if it is.

AMD R5 5600X | 32GB DDR4 3000MHz | RTX 2070 SUPER | HP Reverb G2 | VKB Gunfighter Pro Mk3 | Thrustmaster TCWS

Link to post
Share on other sites

+1

Same Problem since the syria map relase update in VR...

 

switching from Module to Module is killing my performance...

 

I noticed the same after useing the spyglass zoom in VR...

 

In single player it is better but after a while i have the same problem like in MP but it takes much longer...

 

wired thing... seems to be a memory leak maybe

i7-8700K / 32GB RAM @3000 / 1TB M.2 SSD / Asus RTX 2080 Ti OC

VR- Gamer: Valve Index

Flight Gear: Thrustmaster HOTAS Warthog / Thrustmaster TPR / 3x Thrustmaster MFD / Jetseat

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
+1

Same Problem since the syria map relase update in VR...

 

switching from Module to Module is killing my performance...

 

I noticed the same after useing the spyglass zoom in VR...

 

In single player it is better but after a while i have the same problem like in MP but it takes much longer...

 

wired thing... seems to be a memory leak maybe

Qiou has just said his issue was probably linked to his small memory page file. Why are you talking about a "memory leak"?

 

 

Please create your own thread and I'll be happy to help you.

Link to post
Share on other sites
Qiou has just said his issue was probably linked to his small memory page file. Why are you talking about a "memory leak"?

 

 

Please create your own thread and I'll be happy to help you.

 

Okay, I will check if my problem is maybe also related to the memory page file.

If not I will come back with an own thread.

i7-8700K / 32GB RAM @3000 / 1TB M.2 SSD / Asus RTX 2080 Ti OC

VR- Gamer: Valve Index

Flight Gear: Thrustmaster HOTAS Warthog / Thrustmaster TPR / 3x Thrustmaster MFD / Jetseat

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

I can at least confirm that the problem does not appear in SP anymore, thanks probably to the higher page file size. I played 1:30 hours on Through the inferno in Syria, switched aircraft twice, l tried to load as many ground units as possible by cycling through them with F7, and still no stutter. I did not have time to check if it is also gone in MP but at least it looks like a great step forward.

 

I am wondering if the small size of page file didn’t appear on my pc with update 2004. Since it was done recently, it could explain why this issue appeared in August for me.

AMD R5 5600X | 32GB DDR4 3000MHz | RTX 2070 SUPER | HP Reverb G2 | VKB Gunfighter Pro Mk3 | Thrustmaster TCWS

Link to post
Share on other sites

Some other user is having the same 5GB page file when starting DCS. I'm wondering if there's any way for DCS to tell Windows something like: "Hi, I'm the most ravenous program you'll ever see. Gimme all that you got. Regards."

 

 

I've just updated to v2004. I'll see if I need to force page file size or not.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...