Jump to content
Attention! Content rebuild and reindex process is in progress. Estimated completion date - 4th December 2020. Forum content may look broken during this process.

[INVESTIGATING] CoPilot refuses to fire


Recommended Posts

As said, the UH-1 copilot IA do not fire. I believe this happens after the last DCS update, because some days ago I was flying the UH-1 and the copilot IA work as intended. I have attached a track with one example. As you can see the copilot doesn't fire a single bullet in all the fight.
Link to post
Share on other sites
[QUOTE=daemon1808;4462572]As said, the UH-1 copilot IA do not fire. I believe this happens after the last DCS update, because some days ago I was flying the UH-1 and the copilot IA work as intended. I have attached a track with one example. As you can see the copilot doesn't fire a single bullet in all the fight.[/QUOTE] The same thing happens to me. After update.
[B]MB Asus Z270 / Intel i7 7700K / Corsair 32gb RAM / Asus Strix 1080Ti / 1TB SSD dedicated to DCS / 1TB HD[/B]
Link to post
Share on other sites
We can't fire from that position anymore either. We've totally lost the ability to steer the miniguns. (Neither the AI or us seem to be able to put the left side gunsight down.)
Link to post
Share on other sites
Damn, that drove me crazy in an online mission. I thought it was me forgetting to map something. He wouldn't even put his sight down.
Now Shipping 1 thru 425 for current production version 1 PointCTRL General Information Post [URL="https://forums.eagle.ru/showpost.php?p=3607054&postcount=1"]https://forums.eagle.ru/showpost.php...54&postcount=1[/URL] [B]PreOrder Wait List Submission[/B] [URL]https://pointctrl.com/elementor-8258/[/URL] PointCTRL Support Discord [URL]https://discord.gg/jH5FktJ[/URL] PintCTRL Website [URL]https://pointctrl.com/[/URL]
Link to post
Share on other sites
I have had this problem too. Online and offline.
[URL="https://forums.eagle.ru/showthread.php?t=242416"]Check out my DCS VoiceAttack Profiles[/URL] [URL="https://www.digitalcombatsimulator.com/en/files/?PER_PAGE=100&CREATED_BY=asherao"]Check out my Mods and Utilities on ED User Files[/URL]
Link to post
Share on other sites
[QUOTE=MilesD;4465299]Damn, that drove me crazy in an online mission. I thought it was me forgetting to map something. He wouldn't even put his sight down.[/QUOTE] yes, even if you take control of the copilot and put the sight down, when you return to the pilot the copilot doesn't open fire. :(
Link to post
Share on other sites
[QUOTE=daemon1808;4466186]yes, even if you take control of the copilot and put the sight down, when you return to the pilot the copilot doesn't open fire. :([/QUOTE] And here I thought the Company CO "Conscientious Objector" was my co-pilot.
Now Shipping 1 thru 425 for current production version 1 PointCTRL General Information Post [URL="https://forums.eagle.ru/showpost.php?p=3607054&postcount=1"]https://forums.eagle.ru/showpost.php...54&postcount=1[/URL] [B]PreOrder Wait List Submission[/B] [URL]https://pointctrl.com/elementor-8258/[/URL] PointCTRL Support Discord [URL]https://discord.gg/jH5FktJ[/URL] PintCTRL Website [URL]https://pointctrl.com/[/URL]
Link to post
Share on other sites
I would be nice if they would at least acknowledge one of these bug reports. Correction to my post above: You can fire manually and aim the guns from the co-pilot position, I just either forgot how to lower his sight with my mouse, or the mouse hotspot for it is gone. Key worked once I looked up the mapping. So it's just the AI that's got problems. Also finding a lot of the controls have changed the direction they rotate when clicked with the mouse buttons. And the radio/intercom selector switch pops up the annoying radio menu when set to intercom, which I keep accidentally doing as that's one of the controls that's reversed mouse click directions.
Link to post
Share on other sites
It seems that the problem is related with the miniguns. I have found that the left and right gunners refuse to fire too, if they are equiped with miniguns. But they fire as usual, if they are armed with machineguns. What really amaze me is that there not much people complaining about this. This bug is nearly a game stopper for the Huey O_O
Link to post
Share on other sites
Funnily enough this has been a major problem a while back (plus the player couldn't quite use them either), but it got fixed after quite a lot of complaining, at least for a while. Apparently it's back. P.S.: Last time around the issue was that the AI would only 'tap' the trigger and never hold it for some reason. Doesn't matter for the M60s, but since the M134D have to spin up a short moment, they never got any lead on target from them.
Link to post
Share on other sites
Yes it's annoying. Hope this gets fixed soon!
[SIZE=1][SIZE=1]- Raven - [/SIZE][/SIZE] [SIZE=1][SIGPIC][/SIGPIC][/SIZE] [SIZE=1]System specs:[SPOILER] [SIZE=1]i7 6700k @4.5Ghz[/SIZE] [SIZE=1] 32 GB Corsair DDR4 2400MHz ASUS Strix RTX 2070 Super Advanced ASUS Maximus VIII Ranger 1TB Samsung 960 Pro M.2 NVMe SSD Pro Flight Trainer Puma TM Warthog HOTAS w/ 10cm extension by Sahaj (mounted on Wheelstand Pro for Warthog) Thrustmaster TPR rudder pedals Oculus Rift CV1[/SIZE][/SPOILER][/SIZE]
Link to post
Share on other sites
I'm also having issues with the AI co-pilot not firing the M134, even when set to free fire ROE. I've tried a new mission with the me as the pilot never lowering the pilot sight. I've even tried in a new mission moving to the co-pilot seat, lowering his sight and then moving back to the pilot seat, and he still won't fire. Interestingly in this scenario when you lower the co-pilot sight then migrate back to the pilot seat, the AI co-pilot seems to track targets with his sight, but just won't fire. === Could this be an issue with incomplete implementation of the new "show crew indicator" (picture of helo and crew in lower left of screen)? In the Mi8 this new "show crew indicator" has taken over the old "AI panel show/hide" (coloured text in lower right of screen), for setting crew ROE. In the Huey, the old "AI panel show/hide" still exists in conjunction with the "show crew indicator". In addition, the Huey "show crew indicator" does not show co-pilot ROE, nor the door gunners ROE or even presence at all. ==== I've had no issues with the Huey AI door gunners firing with either the M134 or M60. EDIT: I take it back. side gunners are not firing in MP, with either the M60 or M134. No problems so far in SP though. Edited by mad rabbit
Link to post
Share on other sites
[QUOTE=Catweedle;4475342]- Door gunners do not engage in MP (tested with miniguns)[/QUOTE] Quite weird that, since miniguns for doorgunners work just fine in SP. At least this thread is labelled "fixed internally", so hopefully we'll see that implemented soon into the Live build :)
[SIZE=1][SIZE=1]- Raven - [/SIZE][/SIZE] [SIZE=1][SIGPIC][/SIGPIC][/SIZE] [SIZE=1]System specs:[SPOILER] [SIZE=1]i7 6700k @4.5Ghz[/SIZE] [SIZE=1] 32 GB Corsair DDR4 2400MHz ASUS Strix RTX 2070 Super Advanced ASUS Maximus VIII Ranger 1TB Samsung 960 Pro M.2 NVMe SSD Pro Flight Trainer Puma TM Warthog HOTAS w/ 10cm extension by Sahaj (mounted on Wheelstand Pro for Warthog) Thrustmaster TPR rudder pedals Oculus Rift CV1[/SIZE][/SPOILER][/SIZE]
Link to post
Share on other sites
[QUOTE=Elysian Angel;4476114]Quite weird that, since miniguns for doorgunners work just fine in SP. At least this thread is labelled "fixed internally", so hopefully we'll see that implemented soon into the Live build :)[/QUOTE] Weird, annoying, frustrating ... there's a couple of attributes that go well with DCS-MP. :music_whistling:
Link to post
Share on other sites
  • 2 weeks later...
Patched, servers patched, co-pilot now lowers reticle, still refuses to fire at infantry, light vehicle, heavy vehicle, and AAA emplacements. I've test on two servers, two different missions. I managed to get the side-gunners to engage on second server, but the front co-pilot enjoys his 100% Ammo. Should we wait for the Huey "II" to come out, or?
Link to post
Share on other sites
  • Super Moderators
[QUOTE=VFA103 Whisper;4497945]Patched, servers patched, co-pilot now lowers reticle, still refuses to fire at infantry, light vehicle, heavy vehicle, and AAA emplacements. I've test on two servers, two different missions. I managed to get the side-gunners to engage on second server, but the front co-pilot enjoys his 100% Ammo. Should we wait for the Huey "II" to come out, or?[/QUOTE] No need for the sarcasm, happy to take another look, please note if the 7.62 can not penetrate the target the AI co-pilot will not engage it. If you have a short track replay showing a scenario please attach it. thanks
Link to post
Share on other sites
  • Super Moderators
Tested in a open beta server it seems ok to me try a cleanup and repair or verify for steam. Please add a track showing the issue and I will take a closer look thanks Edited by BIGNEWY
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...