Jump to content

Help with FPS locked at 50


XAiracobraX
 Share

Recommended Posts

I upgraded from a intel 4790k to a intel i7-10700k, with that I also bought CL14 3200Mhz 32Gb RAM, and intalled with fresh windows 10 home OS on a samsung 970 evo 1Tb. Still running on MSI GTX 1080 Gaming 8 Gb. Running with track ir 5 on a 2560 x 1440 gsync monitor. Running latest Open Beta, freshly installed after installing.

 

 

 

On my old computer I regularly got 110-120 fps on the instant action missions. On this new computer it seems my fps are locked at 50 fps. If I run on high preset i get 50 fps, if I run on low preset I get 50 fps, if I run on low and have the resolution set to 1920 x 1080 I still get 50 fps. All using the in game fps counter. In task manager the cpu is at 20 %, the gpu is at 30%. I have vsync unchecked in game, in the nvidia control panel I have vsync at its default of "use application setting". I have tried doing the dcs repair.

 

 

 

For reference, performance in the other combat flight sim uses ~100% of gpu and has 130-200+ fps depending on if clouds are present.

 

 

 

Please help! If you need files please let me know what files and where I can find them.

Intel i7-10700k, 32GB DDR4, GTX 1080 8GB, 1TB NVMe SSD, LG32GK850G 2560x1440 Monitor, Noctua u12a cooler

Link to comment
Share on other sites

Hi. Do you own the Winwing HOTAS? One of its script is known to cause FPS capping for some users (see here). Sometimes, HELIOS is the culprit. Is it installed on your PC?

Can you please attach your dcs.log file (in C:\Users\your_name\Saved Games\DCS\Logs) as well as your Export.lua file (in C:\Users\your_name\Saved Games\DCS\Scripts) ?


Edited by Flappie

A track or it didn't happen.

Link to comment
Share on other sites

Looking in C:\Users\your_name\Saved Games\DCS.openbeta I don't see ascripts folder

 

 

I did a crtl + f and searched for export.lua in my saved games folder, it doesn't find anything.

Intel i7-10700k, 32GB DDR4, GTX 1080 8GB, 1TB NVMe SSD, LG32GK850G 2560x1440 Monitor, Noctua u12a cooler

Link to comment
Share on other sites

Are You using Rivatuner SS if yes check you dont have frame limit set in there unknown.png

303 & Friends discord

 

Hangar :

 

JF-17 Thunder, F-16C Viper, I-16, Christen Eagle II, F-14 Tomcat, Supercarrier, WWII Assets Pack, F/A-18C Hornet, AJS-37 Viggen, Spitfire LF Mk. IX, F-5E Tiger II, M-2000C, MiG-15bis, Bf 109 K-4 Kurfürst, Fw 190 D-9 Dora, F-86F Sabre, Flaming Cliffs 3, P-51D Mustang, A-10C Warthog,SA342 Gazelle, UH-1H Huey, Mi-8MTV2 Magnificent Eight, Black Shark II, Persian Gulf Map, Normandy 1944 Map,

 

 

Link to comment
Share on other sites

Alt + enter made no difference, I have also tried doing the repair several times. So as my last hope I have decided to uninstall the open beta and try a fresh install of stable.

Intel i7-10700k, 32GB DDR4, GTX 1080 8GB, 1TB NVMe SSD, LG32GK850G 2560x1440 Monitor, Noctua u12a cooler

Link to comment
Share on other sites

What is your Windows refresh rate?

 

 

Display>Display adapter settings>monitor>refresh rate

 

 

Also check your settings in nVidia Control panel, I'm sure there as a Gsync tab in there.

i9-9900K @ 5.1 - delided, Gigabyte Aorus Elite MB, Corsair H150i Pro water cooler

64gig G-Skill DDR4@3600, MSI 2080Ti

Winwing Super Taurus, Super Libra, TO and Combat panels

MFG Crosswind pedals, Tek Creations panels

Trackir

Link to comment
Share on other sites

It's not vsync or refresh rate issue if it's doing 50fps and your monitor's lowest refresh rate is 60. Check your Nvidia setting and make sure you didn't set max fps to 50.

 

Also in graphics.lua or autoexec.cfg file of DCS, make sure maxfps is not set to 50.

Link to comment
Share on other sites

Well I uninstalled OB and installed Stable, unfortunately that didn't change anything. So playing with it more, things are behaving in a way that I don't understand. If gsync is enabled, then when I look at the sky, like straight up my fps goes to 50, and then stays at 50 no matter where I look. And its a solid 50. If gsync is off, running a fixed refresh rate then looking straight up at the sky or to the sides/wings yields 144 fps, but looking straight ahead yields 72 fps. But with a fixed refresh rate the fps switches back and forth between 144 and 72, and they too are solid with no wavering between any other numbers. Its like a light switch flipping between 72 and 144. I have vsync off in both the game and nvidia control panel. My monitors refresh rate is set to 144 hz, I have checked both the nvidia control panel as well as the windows display settings.

 

Edit: If I use refresh rate set to application setting the fps is erratically jumping all over the place between 144 and 50.

Edit: the max frame rate in nvidia control panel shows off, as it's not set

 

edit: I looked for those two files you list above. I can't find a autoexec.cfg, used the search function for a file of that name in both the game's main directory as well as in the user/saved games/dcs directory. I did find a graphics.lua, only in the games main directory, in which the maxfps is set to 180.

 

 

I am hoping that someone can understand what is going on as I don't.

 

Thanks in advance!


Edited by XAiracobraX

Intel i7-10700k, 32GB DDR4, GTX 1080 8GB, 1TB NVMe SSD, LG32GK850G 2560x1440 Monitor, Noctua u12a cooler

Link to comment
Share on other sites

I think I figured out a fix at least, I don't understand it but I went into the Nvidia control panel, added dcs for program specific settings. Inside that I changed the prefered refresh rate option from "application-controlled" to "highest available". Now I at the same graphics settings, with gsync enabled I have a solid 130-160 fps instead of the locked 50 fps it was.

I then changed that setting back to "application-controlled" and re-ran the same missions, it seems to be running fine after restarting the game. I had tried setting all the values as suggested in a post by either WAGS or BIGNEWY but what I had to do it appears was change it to a different setting, then run the game, and then change it back, then run the game again for it to take effect.

 

 

 

I pray this holds now and I don't have anymore problems.

  • Thanks 1

Intel i7-10700k, 32GB DDR4, GTX 1080 8GB, 1TB NVMe SSD, LG32GK850G 2560x1440 Monitor, Noctua u12a cooler

Link to comment
Share on other sites

  • 7 months later...

Hi, I ran into the same issue.

Everything worked fine and when I tried out something I was stuck with 50 FPS sharp.

The only „solution“ (more like a workaround) was to set the „max FPS“ in NCP to a fixed number > than my monitors refresh rate (e.g. 120 or 1000)

It‘s still annoying though, that I wasn’t able to find the culprit...

  • Thanks 1
Link to comment
Share on other sites

On 8/18/2020 at 1:43 AM, XAiracobraX said:

I think I figured out a fix at least, I don't understand it but I went into the Nvidia control panel, added dcs for program specific settings. Inside that I changed the prefered refresh rate option from "application-controlled" to "highest available". Now I at the same graphics settings, with gsync enabled I have a solid 130-160 fps instead of the locked 50 fps it was.

I then changed that setting back to "application-controlled" and re-ran the same missions, it seems to be running fine after restarting the game. I had tried setting all the values as suggested in a post by either WAGS or BIGNEWY but what I had to do it appears was change it to a different setting, then run the game, and then change it back, then run the game again for it to take effect.

 

 

 

I pray this holds now and I don't have anymore problems.

Thank you for this, as I dont have gsync it didn't work exactly for me, but pointed me to the right direction. I set the max FPS in nvidia cp to 250 and that unlocked the fps. Now I get around 180 (= dcs maxfps) in the menus (was 50), and whatever I can get in game (gpu @ 100% now). But disabling the nvidia cp fps cap un-solves the problem again ...

  • Thanks 1

R5 5600x @ 4.6Ghz | B550 Gigabyte Aorus Pro | beQuiet! Dark Rock Pro 4 | 32GB Team @3600Mhz |  Samsung nmve 1TB | GTX 1080 FE Zotac | Oculus Quest 2

 

Get my skins >>   Check my DCS Awesome List >>

Link to comment
Share on other sites

Il 17/4/2021 at 00:52, Casablanca ha scritto:

Thank you for this, as I dont have gsync it didn't work exactly for me, but pointed me to the right direction. I set the max FPS in nvidia cp to 250 and that unlocked the fps. Now I get around 180 (= dcs maxfps) in the menus (was 50), and whatever I can get in game (gpu @ 100% now). But disabling the nvidia cp fps cap un-solves the problem again ...

Hi what Driver version are you currently using? Could I please ask you for a screeshot of the value you changed in the Nvidia panel?

“Quando camminerete sulla terra dopo aver volato, guarderete il cielo perché là siete stati e là vorrete tornare.”

 

Link to comment
Share on other sites

@JAKAL sorry but my nvidia cp is in french, it might be something like "maximum number of images per second"

@Hiob I wouldn't advise commenting maxfps as when I did so, the fps climbed to 5500fps (yes: five five zero zero) in the menus, and my gpu started roaring like an f14 on afterburner 🚀 😂

R5 5600x @ 4.6Ghz | B550 Gigabyte Aorus Pro | beQuiet! Dark Rock Pro 4 | 32GB Team @3600Mhz |  Samsung nmve 1TB | GTX 1080 FE Zotac | Oculus Quest 2

 

Get my skins >>   Check my DCS Awesome List >>

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...