Jump to content

Airboss / MOOSE - frustrating problem


Recommended Posts

Hello everyone,

 

So, a little background first. Im not interested in the DCS Supercarrier, mostly due to performance concerns, so I was using Alerax's LSO AI Script for quite some time, but the most recent 2.5.6 update broke it. Seems the author of that has disappeared (tried contacting via PM, then noticed he hasnt been online in quite some time). No idea whats wrong with it, it just throws error messages. So, I thought I'd dive in and learn MOOSE and the Airboss scripting.

 

I've been reading all I can and watching tutorial videos, including https://flightcontrol-master.github.io/MOOSE_DOCS_DEVELOP/Documentation/Ops.Airboss.html. I've probably put in around 3-4 hours a day for a week now, and sadly I feel like I've hit a brick wall.

 

Here's what's going on.

 

I downloaded and installed the BOS-100 - Stennis Hornet and Tomcat.miz from https://github.com/FlightControl-Master. Ran though it a few times, looked at the code, and thought I could give it a go installing it in a few other missions. I had copied two of the DCS Default quick Case 1 landing missions (Caucuses and Persian Gulf) and one mission I made myself, along with one more Black Sea training mission I downloaded. Started with the easy default ones.

 

Here's what I've done:

- Copied the Airboss Soundfiles folder into the .miz file

- Made sure the Stennis "carriername" matches the Airboss LUA callout

- Made sure the TACAN and ICLS is set up correctly

- Made sure the Case 1 window overlaps the mission time (I just set it from 9am - 10pm for testing)

- Added both the MOOSE LUA and the Airboss LUA as "Mission Start" commands inside the ME.

- Made sure the flyable aircraft (DCS F/A-18C) is set as "Client"

 

When I try to play the mission, I get the normal Airboss welcome message, indicating the script is loaded. I do hear some of the marshal callouts, as well as read the subtitles. But, here's where it falls apart.

 

Once I pass initial, I no longer get consistent audio messages, only the subtitles. I get a few audio messages on downwind, but once I see "paddles contact," everything from there till touchdown is subtitle only, no audio messages. This makes landing extremely hard trying to constantly divert my attention to the corner of my screen to see what the LSO is telling me.

 

I've tried various versions of the Airboss LUA script, including one by Habu, one from Github, and the one from the sample BOS-100 mission, and they all result in the same behavior, in every missions I've tried adding it to. EDIT: Last night I also tried the very latest MOOSE, 2020-07-11, and get the same results with that one too.

 

The callout audio works perfectly fine in the sample BOS-100 mission. All messages are audible as well as subtitled.

 

I tried posting the question to the MOOSE Discord, and havent had any real feedback yet (maybe I dont know how to use Discord). Seems there's very little activity over there.

 

Does anyone have any ideas? For such a complex and full featured scripting package, I'm quite shocked there isnt more information/discussion on MOOSE.

 

Any help is much appreciated.


Edited by mtpiperpilot
Link to comment
Share on other sites

Here's what I'm using for my LUA contents:

----------------------------------------------------------------------------------------

 

-- No MOOSE settings menu. Comment out this line if required.

_SETTINGS:SetPlayerMenuOff()

 

-- Create AIRBOSS object.

local AirbossStennis=AIRBOSS:New("Stennis")

 

-- Add recovery windows:

-- Case I from 6 to 10 pm.

local window1=AirbossStennis:AddRecoveryWindow( "6:00", "22:00", 1, nil, true, 25)

 

-- Set folder of airboss sound files within miz file.

AirbossStennis:SetSoundfilesFolder("Airboss Soundfiles Loud/")

 

-- Single carrier menu optimization.

AirbossStennis:SetMenuSingleCarrier()

 

-- Skipper menu.

AirbossStennis:SetMenuRecovery(30, 20, false)

 

-- Enable trap sheet.

AirbossStennis:SetTrapSheet()

 

-- Start airboss class.

AirbossStennis:Start()

Link to comment
Share on other sites

Your script looks good. There is no reason I can see why there is a difference between what you do and the demo mission.

 

Do you see the subtitles on the right or left side?

 

If you see them on the right side, you have no radio relay (which you script suggests). The subtitles are then messages you see independent if you have the sound files in the right place or not.

 

So two things could be:

1. You don't have all sound files in the right place.

2. You did not change your frequency to 264 MHz to hear the LSO calls.

 

Hope this helps :)

A warrior's mission is to foster the success of others.

i7-8700K | Asus RTX 2080Ti Strix OC | 32 GB Ram 3200 MHz DDR-4 | Asus Maximus Hero X | Samung EVO 960 Pro SSD | VKB Gunfighter Pro | MFG Crosswind | Rift S

RAT - On the Range - Rescue Helo - Recovery Tanker - Warehouse - Airboss

Link to comment
Share on other sites

Thank you Frank! Got it working.

 

I'm a little embarrassed. I didnt realize I had to manually tune the radio to 264.000Mhz. I guess I assumed it was automatically tuning because I heard the Marshall calls. Also, coming from the Alerax LSO script, which does simulate this. Oops.

 

I also added the same relay aircraft as in the demo mission to all of mine.

 

The only thing I'm still a bit confused about is oftentimes, when in the pattern (downwind, base turns) I get an audio only call saying "you're high" or "you're low", but it almost never matches up with reality. For example, on the last quick test around the pattern, I was 80 feet high when at my 90 deg mark on base (580 ft) and I got a "you're low" call. There's no accompanying subtitle for these calls that I can see.

 

Also, sometimes when I'm right at 1.2 nm abeam the LSO platform, I get a "you're too close to the boat!" message.

 

Is this normal/bugs? Or is something misconfigured?

 

Thanks again! Truly appreciate the help! This is one awesome script! :thumbup:

Screen_200803_220350.thumb.jpg.41431230d951c08205419c5e883980d0.jpg


Edited by mtpiperpilot
Link to comment
Share on other sites

  • 8 months later...

Hey guys, I hope you dont mind me jumping in here. I just setup my own mission from scratch on the syria map using airboss. Its basic Carrier Quals for me and my buddy.

Now here comes the dumb question. From where do I get the sound files? I found Moose.lua and also the Airboss Script but ill be damned if I can find the voice files. Any help is much welcomed.

 

cheers


Rampart

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...