Jump to content

[CANNOT REPRODUCE] problems with the radar - elevation.


Recommended Posts

Encountered an issue after engaging a pair of MiGs in multiplayer where my radar was not working correctly.

 

My elevation scan acted as if it was the azimuth, while the azimuth sweep acted like the bar scan.

This was to the point that altering the degree of azimuth sweep would actually adjust the distance the elevation caret would travel, and adjusting the bar scan setting changed how far the vertical line representing the antenna position would sweep across.

 

The track is very large, as it was a long flight and can be downloaded here:

https://1drv.ms/u/s!Au6nuN4_FUp2grUuRcZmVBfkTj6eUw?e=5FR5vB

 

Since I figure it may be difficult to work with such a large track, I recorded a section of it occurring while I changed the bar and azimuth settings - which has been uploaded to youtube (to appear below).

 

I am not sure as to the condition to reproduce, as I did not notice it immediately.

 

DCS 2.5.6.50979 Open Beta

 

 


Edited by Tiburtius

My Rig:

 

 

CPU: i9-9900k - Corsair H150 Cooler. RAM: 32GB, 3200Mhz.

Mobo: Asus MAXIMUS Formula XI - Main Drive: 512GB NvME SSD

DCS Drive: 512GB NvME SSD - Graphics: GTX 1070 Ti. Display: 23" 1080p LG LCD.

Input: Razer Naga & Blackwidow Ultimate, TrackIR 5, HOTAS Warthog & MFDs (x4), Saitek Rudder Pedals, TurtleBeach PX22 Headset.

 

 

Link to post
Share on other sites

Thanks, fixed!

My Rig:

 

 

CPU: i9-9900k - Corsair H150 Cooler. RAM: 32GB, 3200Mhz.

Mobo: Asus MAXIMUS Formula XI - Main Drive: 512GB NvME SSD

DCS Drive: 512GB NvME SSD - Graphics: GTX 1070 Ti. Display: 23" 1080p LG LCD.

Input: Razer Naga & Blackwidow Ultimate, TrackIR 5, HOTAS Warthog & MFDs (x4), Saitek Rudder Pedals, TurtleBeach PX22 Headset.

 

 

Link to post
Share on other sites

The AA radar is mixing commands and stuff with AG radar, sometimes when I want to lock a target I get a ground point designated... hope I can catch it on a trk file thats smaller, usually happens on a long mission when I switch often between AA modes and AG modes.

Link to post
Share on other sites

Nice find. I encountered the same problem maybe a week ago during a mission, but I didn't realize that the azimuth and elevation were swapped, I just figured the radar bugged out and since I was RTB, didn't try to mess with it too much. ACM modes still worked correctly though.

 

If it helps, it occurred after an A2A engagement against multiple aircraft that started in BVR and ended in a furball, where I used the AIM-120B, the AIM-7H, AIM-9M and guns. I used pretty much all radar modes. Two TWS launches with L&S and DT2 (swapped between them for midcourse guidance, because it currently doesn't work for DT2), FastACQ with SCS Right with L&S, AACQ with SCS Right without L&S or TUC and then a mix of ACM modes and GACQ. At the end of it all, I noticed this bug. It probably occurred earlier at some point, but I didn't notice exactly when, since I was using ACM modes after a point. It definitely started after I was WVR though, so the it worked correctly during the BVR part and then it probably got bugged as I was using the ACM modes.

 

FWIW, I haven't been able to reproduce.

The vCVW-17 is looking for Hornet and Tomcat pilots and RIOs. Join the vCVW-17 Discord.

1197644828_Screen_200911_044202-Copy.png.74d8c09ee9060cffd7408a75ab2c13ef.png

Z370 Aorus Gaming 7, i7-8700K, 2080Ti FTW3 Ultra, 32GB DDR4, 960 Pro, 970 Evo Plus, WD Gold 6TB, Seasonic Prime Platinum

F/A-18C, AV-8B, JF-17, A-10C (C II), M-2000C, F-16C, F-14, BS2, UH-1H, P-51D, Sptifire, FC3

Link to post
Share on other sites

My flight included HARM launches, followed by engaging Havoc’s with AIM-7. On initial RTB, the MiGs came in so I turned back to engage WVR using AIM-9 and Gun, so I know it was after the second engagement.

 

The only other thing I can think of was after clearing the lock on the final shootdown, the radar did try to re-acquire the wreck as it fell to the earth. I did not pay attention at that point as I had to head for the tanker due to low fuel but it was as I climbed to the tanker’s altitude that I found the radar was dysfunctional.

 

Behind the tanker I tried using boresight mode to lock him and then break lock hoping to reset the radar, as well as going between AIR and SURFACE modes, and powering the radar on and off, using the SILent option, RESET and ERASE with no luck.

My Rig:

 

 

CPU: i9-9900k - Corsair H150 Cooler. RAM: 32GB, 3200Mhz.

Mobo: Asus MAXIMUS Formula XI - Main Drive: 512GB NvME SSD

DCS Drive: 512GB NvME SSD - Graphics: GTX 1070 Ti. Display: 23" 1080p LG LCD.

Input: Razer Naga & Blackwidow Ultimate, TrackIR 5, HOTAS Warthog & MFDs (x4), Saitek Rudder Pedals, TurtleBeach PX22 Headset.

 

 

Link to post
Share on other sites
  • 1 month later...

[CANNOT REPRODUCE] problems with the radar - elevation.

 

There are still problems with the radar. This time the elevation seems to change with bars. It moves up and down by itself, and the scan only slightly moves.

 

 

This plane will probably be a big trouble for a long time ...


Edited by padonis
Link to post
Share on other sites

Going into ACM will swap the radar axis and also if your radar elevation isn't centered in the middle the VACQ mode will be biased and won't work either. Interesting to see that coming back to BVR doesn't reswap the axis. Try going back to ACS, undesignate and then for BVR. That would confirm axis are always swapped when going ACM but not swapped when going BVR

Link to post
Share on other sites

This happens always with ACM using guns, just push radar elevation to one end before going to ACM and you'll notice your VACQ doesn't work because it flips the axis and doesn't reset the radar azimuth.

 

I'm surprised this keeps coming back as Cannot Reproduce on reported bugs

Link to post
Share on other sites

Merged threads,

 

we have been unabel to reproduce so far, but will continue to try.

 

thank you

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites

Yes and followed your points, I was still unable to reproduce.

 

I will ask other testers to try.

 

Thanks

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites
Yes and followed your points, I was still unable to reproduce.

 

I will ask other testers to try.

 

Thanks

 

Thanks. Are you using the same OB? For me this works everytime. If I return to MRM mode and then press pinkie then there's no prob.

[sIGPIC][/sIGPIC]

Win10 64, Asus Maximus VIII Formula, i5 6600K, Geforce 980 GTX Ti, 32 GB Ram, Samsung EVO SSD.

Link to post
Share on other sites

Same bug here, after change radar mode to guns, when back to BVR the radar stuck......

System:

Asus TUF Z390-Pro Gaming/ Intel i5-9600k@ Coffeelake 9a Gen/ Water Cooler Corsair Hydro H45/ Corsair Vengeance Lpx 32Gb 3200Mhz/ EVGA GeForce RX 2070 Super 8Gb Gddr6 256Bits/ 1 SSd M2 3gen 1Tb Xpg/ Headset Corsair + SoundCloud BlasterX Pro Gaming AE-5 / Corsair HX1000i W Plus Platinum/ Case Corsair Gamer Series Obsidiam 500D/ LG 32" 4k Monitor Dp/ Track Ir5 w/Clip Pro/ Saitek Hino X56

Link to post
Share on other sites

AA radar swapping horizontal and vertical axes

 

Hello,

 

i wanted to ask if anyone else has been seeing this problem. Sometimes, quite rarely, the AA radar gets stuck in, for example, "6 bar" horizontal angle range and 80 degree vertical range. Changing bars changes horizontal range, changing azimuth range changes vertical range. Like the radar axes are precisely flipped.

 

I suspect its caused by a specific order of switching between ACM modes, GACQ and JHMCS. I was never able to find the combination. When it happens, it appears there is no way to recover from it other than respawn.

 

Does anyone know what combination causes it? How to prevent it? Do i have to sacrifice JHMCS to ensure this stops happening? I just lost 60 minutes of mission gameplay (in Raven One, great campaign btw) because of this, again... :doh: Maybe there was a bugreport on it, but i cant find anything.

 

Any helping information is welcome.


Edited by dorianR666

:joystick:

CPU: AMD Ryzen 5 1600X

GPU: AMD RX 580

Link to post
Share on other sites

dont seem exactly what happened to me (4 times at today date), but similar.

in my case, after using vertical scan in a dogfight, changing weapons to guns, aim9, aim120 ecc, i dont know the exact procedure to reproduce the bug, it gets stuck in vertical scan.

i can do nothing to use BVR again, it gets the BVR data layout (i can select range, degrees ecc), but radar keeps scanning 2 degrees left& right and all the vertical .

i tried everything, change to AG mode, shut radar off, reset, everything, i cannot take back control of my radar when it happens.

 

this add to another bug… if i use vertical scan, lock a target, then lose it (like if it goes outside my radar limits), then it stays in vertical apparently, but in reality radar is scanning a sort of big boresight, not vertical. to make it work again as intended i have to set boresight, then vertical again, and it works again as intended.

Link to post
Share on other sites
Hello,

 

i wanted to ask if anyone else has been seeing this problem. Sometimes, quite rarely, the AA radar gets stuck in, for example, "6 bar" horizontal angle range and 80 degree vertical range. Changing bars changes horizontal range, changing azimuth range changes vertical range. Like the radar axes are precisely flipped.

 

I suspect its caused by a specific order of switching between ACM modes, GACQ and JHMCS. I was never able to find the combination. When it happens, it appears there is no way to recover from it other than respawn.

 

Does anyone know what combination causes it? How to prevent it? Do i have to sacrifice JHMCS to ensure this stops happening? I just lost 60 minutes of mission gameplay (in Raven One, great campaign btw) because of this, again... :doh: Maybe there was a bugreport on it, but i cant find anything.

 

Any helping information is welcome.

 

 

I’ve had exactly the same, but alas I cannot remember the preceding state or switchology, as I was flying in a “JD & coke” induced state, and just buried the nose into trump tower when I couldn’t fix it! :lol:

But yes, this has certainly happened.

Vertical scan is aligned along the bottom, and sweep is shown up and down on the left.

 

When I am near my PC in a few days I will try to induce it again.

Alien desktop PC, Intel i7-8700 CPU@3.20GHz 6 Core, Nvidia GTX 1070, 16GB RAM. TM Warthog stick and Throttles. Saitek ProFlight pedals.

Link to post
Share on other sites
  • 3 weeks later...

I was testing into this again and found that Svend_Dellepude's method can reliably recreate this issue both in SP via the ME, and in MP with a client-hosted server.

 

Additional track attached plus the associated mission file.

server-20200910-205926.trk

Hornet_Radar_ScanBug.miz

My Rig:

 

 

CPU: i9-9900k - Corsair H150 Cooler. RAM: 32GB, 3200Mhz.

Mobo: Asus MAXIMUS Formula XI - Main Drive: 512GB NvME SSD

DCS Drive: 512GB NvME SSD - Graphics: GTX 1070 Ti. Display: 23" 1080p LG LCD.

Input: Razer Naga & Blackwidow Ultimate, TrackIR 5, HOTAS Warthog & MFDs (x4), Saitek Rudder Pedals, TurtleBeach PX22 Headset.

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...