Jump to content

[CAN NOT REPRODUCE]TGP slew heavy stutters


Oldfox
 Share

Recommended Posts

Hi,

 

Not sure if this has always been like this as before I was slewing TGP with hat buttons.

Now I have a Warthog throttle with upgraded slew, using analog slew axis X and Y, the TGP moves really really harsh, it's not smooth at all even when using small inputs and makes it hard to aim at anything if using some zoom.

 

Cursor is working perfectly if slewing on the TAD screen for example so don't think it's an input issue on my side.

 

Thanks for the help!

Link to comment
Share on other sites

Standard the TGP slew is a bit snappy. Way better with the upgraded slew stick.

Below are my axis settings (same for Y axis).

If required, the smoothness still can be tuned on the stats page in the cockpit.

 

FQiHzX.png

dUJOta.jpg

 

 

Windows 10 | i7 7700K @4800 | 32GB DDR3 | GTX 1070 | TM Warthog HOTAS | Saitek Combat Rudder Pedals | TM MFDs + Lilliput 8" | TIR5 Pro

Link to comment
Share on other sites

Well it actually is pretty difficult to point exactly on a tank in full zoom.... I think it would be easier using a digital hat, which is non sense.

Feels like it could be some numerical rounding issues regarding coordinates....

 

Will try to make a video to show you how bad it actually is.

Link to comment
Share on other sites

Ok here's a quick view of what happens using analog axis slew on the A10 for me.

 

Am I the only one in this case?

 

Happens when zoomed, in wide angle or when using other sensors the slew axis is perfectly smooth.


Edited by Oldfox
Link to comment
Share on other sites

Maybe reset your bindings ? See if that helps.

Definitely not seeing that behavior here, or heard from others they have it.

dUJOta.jpg

 

 

Windows 10 | i7 7700K @4800 | 32GB DDR3 | GTX 1070 | TM Warthog HOTAS | Saitek Combat Rudder Pedals | TM MFDs + Lilliput 8" | TIR5 Pro

Link to comment
Share on other sites

Well I have nothing special in my bindings, slew axis is cleared from all other controllers, and working perfectly for any other function appart from TGP slew when zoomed. TAD cursor is moving smoothly as well as HUD cursor.

 

I can still map it to a different analog joystick to compare the behavior but for now looks like a real bug to me.

 

I am using triple screens for information if it ever has any link with the issue.


Edited by Oldfox
Link to comment
Share on other sites

Just tried cleaning everything in bindings. Using a saitek joystick as slew control. If I zoom in full, the closest I am under the plane, the more it stutters. It's like it's trying to constantly area lock.

 

Tried using just digital slew and it's actually same behaviour.

 

I can't be the only one having this !!??

 

Tried to render in 1 screen instead of 3 and no luck.

Link to comment
Share on other sites

Oldfox: I have the same issue, when zoomed in the movement is jerky as in your video. I am also using Warthog HOTAS, TGP slew works ok when zoomed out, when zoomed in it is very jumpy. I always thought that it is a feature :)

Link to comment
Share on other sites

  • 3 weeks later...
  • 4 weeks later...

I have the same issue, it's not hardware related. Or if it is, it has to be a problem with how the TGP reacts to slew curve changes.

All other slewing operations work perfectly fine and smooth, using the same slew joystick.

 

I think it lies in the TGP tracking logic, as all TGPs across the game suffers from the same issue. (F-16, F-18.)

 

The issue is when the TGP is zoomed in and off angle from the plane. Trying to slew it makes it jerky, as if it's "sticking" to the prior location. The same effect can be observed when using any pod in the A/A tracking mode. (Even F-14's TCS has this issue.)


Edited by Torri98
Link to comment
Share on other sites

I have the same issue, it's not hardware related. Or if it is, it has to be a problem with how the TGP reacts to slew curve changes.

All other slewing operations work perfectly fine and smooth, using the same slew joystick.

 

I think it lies in the TGP tracking logic, as all TGPs across the game suffers from the same issue. (F-16, F-18.)

 

The issue is when the TGP is zoomed in and off angle from the plane. Trying to slew it makes it jerky, as if it's "sticking" to the prior location. The same effect can be observed when using any pod in the A/A tracking mode. (Even F-14's TCS has this issue.)

 

So I'm not dreaming :) Not sure about the slew curves as I think I had the same behavior using slew button instead of an axis. Could you double check?

 

Thanks!

Link to comment
Share on other sites

So I'm not dreaming :) Not sure about the slew curves as I think I had the same behavior using slew button instead of an axis. Could you double check?

 

Thanks!

 

I could probably double check with buttons instead of axis, but I am 99% certain that the issue lies with the area/point track logic.

Link to comment
Share on other sites

I could probably double check with buttons instead of axis, but I am 99% certain that the issue lies with the area/point track logic.

 

That or numerical imprecision when computing TGP angles resulting in jerky movements at high zoom values.

Link to comment
Share on other sites

  • 1 month later...
  • 4 months later...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...