Jump to content

[REPORTED]Autopilot broken


cptmoose
 Share

Recommended Posts

Just downloaded the latest patch 2.5.6.52196

 

Jumped into A-10C in multiplayer, Attempted to engage Autopilot and it will only engage while the button is actively being pressed. It will not remain activated while holding a steady level heading.

Attempted to use button bind on the joystick as well as the one in the cockpit and had the same issue. I then placed down a new A-10c in the editor and flew it just to make sure and same issue Occured.

 

Its broken.

Link to comment
Share on other sites

Was about to report this annoying bug as well, but seems like someone was faster, there is also one more thing I have noticed, that is inverter switch located on electrical panel (right side), switches now to TEST when pressed with left mouse button when previously it was the opposite, nothing major but should be fixed regardless ;).

Link to comment
Share on other sites

Was about to report this annoying bug as well, but seems like someone was faster, there is also one more thing I have noticed, that is inverter switch located on electrical panel (right side), switches now to TEST when pressed with left mouse button when previously it was the opposite, nothing major but should be fixed regardless ;).

 

Theres a few switches that have reversed- Canopy Open/Close is another.. same IFFCC switch.


Edited by Sunscreen
Link to comment
Share on other sites

bind this instead while waiting for the patch with the fix

unknown.png

 

or if you feel handy with lua, you can probably spot and fix the issue by digging into the keybind files for the A-10c...

 

"Hotas Left Throttle Button" works.

Thanks for pointing this out

Link to comment
Share on other sites

It would appear that the last update revised the .dll files within the A-10C Mods\aircraft\A-10C\bin directory, and a lot of the same files for other ac. I don't think that wading through the keybind files will do any good. We will have to wait for DCS to fix it.

 

I use a bespoke cockpit with a large number of hardwired controls, as well as Helios. I have found a number of my controls have changed their behaviour as a result of this latest update.

 

I am resigned to wait and see.

Link to comment
Share on other sites

Following on from my last post - and assuming that my assumption is true - it would be nice for someone at DCS to just put up a post saying. "Sorry, it is broken - a fix is in hand" before everyone starts wading through their control bindings.

 

I cannot believe that the adage "Never apologise - never explain", is a good one for any business.

Link to comment
Share on other sites

Following on from my last post - and assuming that my assumption is true - it would be nice for someone at DCS to just put up a post saying. "Sorry, it is broken - a fix is in hand" before everyone starts wading through their control bindings.

 

I cannot believe that the adage "Never apologise - never explain", is a good one for any business.

 

 

Good point...

Link to comment
Share on other sites

what surprises me is...It was so easy to all of us to pinpoint these bugs that seems to me that there are no beta testers for A10 anymore...

 

auto pilot, left clicks changed to right clicks without announcement and so on...

Link to comment
Share on other sites

In my opinion they should say

" Hey guys we are releasing this patch with some glitches we couldn't solve it:

 

1...

2...

3..

Appreciate if you can point more bugs, thanks!

 

So no surprises, apply the patch at will.

Link to comment
Share on other sites

Was about to report this annoying bug as well, but seems like someone was faster, there is also one more thing I have noticed, that is inverter switch located on electrical panel (right side), switches now to TEST when pressed with left mouse button when previously it was the opposite, nothing major but should be fixed regardless ;).

+1

Link to comment
Share on other sites

what surprises me is...It was so easy to all of us to pinpoint these bugs that seems to me that there are no beta testers for A10 anymore...

 

auto pilot, left clicks changed to right clicks without announcement and so on...

 

There are beta testers, us. That's why its called DCS 2.5.6 Beta. I have 2.5.5 "Stable" installed as well, so I just go back to that when there's a show-stopping bug. In these threads, we can report bugs, ED changes the subject line by adding [REPORTED], and hopefully they fix it. I think they made Betas available to all of us because with so many of us, we find bugs faster than a small, exclusive group. Looks like that concept is working. :smilewink:

ASRock Z370 Professional Gaming i7, Intel i7 8700K Coffee Lake processor @4.7GHz, Corsair H105 Liquid Cooler, G.SKILL Ripjaws V Series 64GB DDR4 3400 memory, EVGA RTX3090 FTW3 Ultra 24GB video card, Samsung 840PRO 256MB SSD for Windows 10 64-bit OS, Samsung 850PRO 2TB SSD for program files, LG WH14NS40 Blu-Ray burner. HOTAS Warthog, Saitek Pedals, HP Reverb G2. Partridge and pear tree pending. pilotfly.gif

Link to comment
Share on other sites

This thread is not for blaming the testers, the bug was missed by us at ED, it is the reason we have an open beta to test in a much wider environment before sending a patch to the stable version

 

The team are working on a fix.

 

thank you

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...