Jump to content

Help Safer Pay keeps shooting down my payment


Recommended Posts

So I'm trying to capitalize on this sale, and for some reason Safer Pay keeps rejecting my cards. My first Card which goes through Bank A is a Mastercard and I had some problems purchasing last night, but it eventually went through. Last night I tried purchasing some more things and Card A was getting shot down and wouldn't go through at all. Today I tried using Card B which is a Visa and goes through a different bank. For some reason this card is also getting flagged. Is there a reason that Safer Pay might be rejecting cards right now? Every-time I try to purchase no matter what card I use I get greeted with this:

 

Processing of the transaction failed. Please try again later or contact your provider.

 

Is anyone having this problem, or have you ever had this problem? How did you fix it if you did? There is enough money on both cards to make the purchase and no outstanding debts and I've never experienced this before. As much help as I can get would be appreciated.

Link to comment
Share on other sites

I also called the company and told them that it was me, and they de-flagged SaferPay. They said wait at least 30mins for the card info to be updated through the database and it should work. Tried it and hour later, and just minutes before posting this, and it is still shooting me back. Something to do with Saferpay.

Link to comment
Share on other sites

Please contact support they will assist you

 

https://www.digitalcombatsimulator.com/en/support/

 

thank you

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

  • 4 months later...
On 7/7/2020 at 7:42 AM, DeltaXrayBravo said:

Something to do with Saferpay.

Hey man. Your problem solved?

Now I've the same problem.

 

Thx.


Edited by Devrim

i7-2600 @3.4GHz | Corsair 16GB @1600MHz. | MSI GTX1660Ti Gaming X | Samsung 256GB SSD (Win7HPx64)
Samsung 32" | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars & 2 x 8"TFTs | Logitech G13, G230, G510, PZ55 SwitchPanel & Farming Sim Panel | TIR5
>>MY MODS<< | Discord: Devrim#1068

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...