Jump to content

SAITEK X52 andX532Pro problems


Recommended Posts

I have both Saitek X52 and X52Pro, and have same problems with both of them in LockOn 1.1 and 1.12.

 

Issue is that LockON is always reading the sticks as having buttons pressed, so defining inputs is nearly impossible. LockON always reads buttons 33, 34, 35, and 36 as always on.

 

I can't seem to get it working.

 

Also I run LockOn both XPPro and XP pro64. 1.12 refuses to run on XP64 becouse Starforce says it can't run on that system. However 1.1 runs great on XP64, better then on 32 bit XP.

 

My XP machine is a Intel Dual-Core laptop with Radeon X1400

My XPPro64 box is AMD Opteron QuadCore with 4gb of ram and QuaddroFX 4600 (512mb).

 

DaveR

Link to comment
Share on other sites

Hello,

 

to circumvent your first problem you have to use the Saitek Profile Software. Unfortunately this is a known problem and thats the only way get this buttons going.

 

As for your StarForce problem, you should update their drivers:

 

http://www.star-force.com/support/drivers/

 

Hope this helps

Link to comment
Share on other sites

Check both sticks in the control panel as well to be on the safe side. I had exactly the same problem with my X-52 when I first got it and there was a fault in the throttle assembly.

 

Unlikely that both sticks will have the same physical problem, but worth checking none the less...... Especially if either stick is brand new. Otherwise you could end up chasing ghosts in LOMAC when the problem lies elsewhere (like I did for an entire day!!)

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...