Jump to content

VAICOMM/AIRIO - problems with recognizing some functions


Recommended Posts

Hello,

this is not a VAICOM Problem (i think) but more about my bad english pronounce.

 

I have done a lot of training and custom words recording (preventing some other words..for example i say ball and bullet is recognized...as i prefer to use guns I prevented bullet from being dictated) but still I have some issues with some important words.

 

In particular....crew is almost always recognized as two

 

in AIRIO

 

radio tune is recognized as radio check (with lower confidence) or sometimes as radio two (and then ignored)

link tune is recognized as link mode or sometimes as link two (ignored as above)

tacan tune is the only one that 10% of the times works (but almost always recognized as tacan mode)

 

Now i tried everything

 

- Recording every single word (so radio, tune, link, check) - recording all the phrase (radio tune, link tune, radio check, tacan tune).

But always these are recognized different to what is say.

 

As already written i did a lot of training both in Vaicomm and windows speech recognition training and a lot of recordings...in the Windows settings I enabled the "recognize non native accent" option.

Don't know what to do anymore....I would like at least to also have the Jester Wheel as it is unusable for me this way :(

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites

VAICOMM/AIRIO - problems with recognizing some functions

 

Edit...it seems that some way restarting VAICOMM made things better as 50% of the time now it recognize me,

but still it does not work.

 

As you can see Radio Tune and Link Tune are recognized (more often then before but not always) by the speech recognition engine but not by the VAICOMM profile, while TACAN Tune is recognized by both...

 

1ec9362d82bb3a5292aa2dc4a9723487.jpg

 

I followed the instructions in the VAICOMM manual, and I imported the three commands from AIRIO profile (see the second screen)...So why it is not recognized correctly?

 

f73c21f1c26bc473171b9ca75a1c39aa.png

 

e6ace8f7f9db4c56185d6f4a14d24819.jpg

 

Anyway also when using Tacan Tune also if recognized the command is not executed (only when i use tacan tune texaco is recognized and executed).

So what i am doing wrong (as probably I forgot to see something in the options)


Edited by VirusAM

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites

No one can give some help with this?

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites

Instead of "crew, maybe try "chief"

 

As for the others, if you have added words to the speech recognition dictionary, along with your own pronunciation, the only other thought that occurred to me was that there is an issue with the setup of your mic or your mic itself. For example, do you have the volume level set right, to optimise recognition?

Link to post
Share on other sites
Instead of "crew, maybe try "chief"

 

As for the others, if you have added words to the speech recognition dictionary, along with your own pronunciation, the only other thought that occurred to me was that there is an issue with the setup of your mic or your mic itself. For example, do you have the volume level set right, to optimise recognition?

 

Thanks Greyman...

for chief/crew is ok..is a minor thing and i can live with it.

But if you see carefully my screenshots you will see that the issue is not (only) in the recognition of words and phrases, but that with 3 specific AIRIO commands (radio tune, link tune, tacan tune)

also if they are recognized by the speech engine (as you can see in the screenshots it recognizes...) they are not recognized by the VAICOMM profile (yellow 'unrecognized' in the screenshots).

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
Thanks Greyman...

for chief/crew is ok..is a minor thing and i can live with it.

But if you see carefully my screenshots you will see that the issue is not (only) in the recognition of words and phrases, but that with 3 specific AIRIO commands (radio tune, link tune, tacan tune)

also if they are recognized by the speech engine (as you can see in the screenshots it recognizes...) they are not recognized by the VAICOMM profile (yellow 'unrecognized' in the screenshots).

Several of us have changed the commands phrases for these (for instance I had real problems with TACAN TUNE and have changed it to Tack Freak).

 

To change these, go into the VA edit of the profile rather than the VAICOM one and then edit each phrase in turn (they are in a separate group from the command words) to words that work for you

 

Sent from my SM-T835 using Tapatalk

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

VAICOMM/AIRIO - problems with recognizing some functions

 

Several of us have changed the commands phrases for these (for instance I had real problems with TACAN TUNE and have changed it to Tack Freak).

 

To change these, go into the VA edit of the profile rather than the VAICOM one and then edit each phrase in turn (they are in a separate group from the command words) to words that work for you

 

Sent from my SM-T835 using Tapatalk

 

 

 

Ok i’ll try that also

but please watch my screenshots.

The speech is recognized, is the vaicomm profile that act as if the commands was not in the profile.

 

Here is another example from today

Command is recognized but doesn’t do anything in DCS.

 

My phrase was as instructed in the manual “radio tune two five one decimal zero zero zero”

 

155f6f062a0f4f2752492a81ddc53f65.plist

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites

The problem is I don't think it is recognising the whole command - it is just recognising 0 (the contains '0' messages in brackets).

 

Attached is the screenshot from my log (I wasn't in DCS hence the AIRIO commands not being available) - the recognition messages look different

487745739_Radiofreak.jpg.49cc7f2b3ccf154f121626e5d55b2470.jpg

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

Could well be Greyman's suggestion

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

VAICOMM/AIRIO - problems with recognizing some functions

 

The problem is I don't think it is recognising the whole command - it is just recognising 0 (the contains '0' messages in brackets).

 

Attached is the screenshot from my log (I wasn't in DCS hence the AIRIO commands not being available) - the recognition messages look different

 

 

 

From you screenshots i see that it should read 251 decimal 000

I say decimal but as you can see from my screenshots it recognizes “radio tune 251.000”

(In your screenshot i saw that it happened to you once also)

So maybe that is the reason that it doesn’t trigger the commands.


Edited by VirusAM

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
It was the "awaiting additional input" messages that prompted my earlier, linked, suggestion.

 

Did that not work @VirusAM?

 

 

 

Sorry greyman...i didn’t read your post...

Thanks i will look tomorrow. I think I already enabled that option, but i need to check.

Anyway i am skeptical as it is not the “awaiting additional input “ my issue, but it is that these three AIRIO commands also if recognized don’t have any effect in SIM.

Anyway thanks for trying to help, i will report back tomorrow

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
It was the "awaiting additional input" messages that prompted my earlier, linked, suggestion.

 

Did that not work @VirusAM?

 

I did a check right now.

I had the extended command set already enabled.

Thanks anyway for trying to help, really appreciated

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites

I still think you need to change the command phrases to something that can be recognised when you say it (Freak seems to work quite well for a lot of people rather than Tune)

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites
I did a check right now.

I had the extended command set already enabled.

Thanks anyway for trying to help, really appreciated

 

I had similar problems. Using the RESET function solved the problems for me.

Link to post
Share on other sites
I still think you need to change the command phrases to something that can be recognised when you say it (Freak seems to work quite well for a lot of people rather than Tune)

 

 

 

I changed

 

I used radio change instead of radio tune....

The issue is not that it doesn’t recognize me.

It is that recognizes radio change 225.00 instead of radio change 225 decimal 00.

Tacan change yankee 047 is often recognized...x-ray is never recognized (i mean the speech engine does, the profile does not)

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites

I did also a reset of everything but doesn't change anything

The worst case is with radio tune, tacan tune, marker from map etc.

I changed radio tune to "radio change" to make it recognize me better, but that's not the issue as the speech engine recognize my phrases (as is possible to see in the above screenshots).

 

For example if i speak radio change 225 decimal 000 I can see that it writes radio change 225.000 'unrecognized'

Sometimes Tacan Change works, some time it does not work. Radio Change never worked for me.

 

Would be possible to have some form of official support please?

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
Would be possible to have some form of official support please?

 

While Hollywood does support on these forums, it migyt be best in this case to use the official support e-mail (support@vaicompro.com)

 

Sent from my SM-T835 using Tapatalk

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

First of all do a hard reset of your database by deleting the Config and Database subfolders (you seem to have somehow imported an ATC called '0' which won't help here).

Then try using the correct syntax as in the manual i.e. ' Two Five Zero Decimal Zero' and not e.g. 'Zero Zero Zero' as seen in the log.

Hope that helps grtz

There is no spoon.

 

Avatar_old_80x80.gif.0c105925ce4b9f5b87697ea37cbde317.gif

VAICOM PRO plugin for DCS World

www.vaicompro.com

Link to post
Share on other sites
While Hollywood does support on these forums, it migyt be best in this case to use the official support e-mail (support@vaicompro.com)

 

Sent from my SM-T835 using Tapatalk

 

 

 

I sent an email at that address at the same time I opened this thread.

Thanks anyway

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
First of all do a hard reset of your database by deleting the Config and Database subfolders (you seem to have somehow imported an ATC called '0' which won't help here).

Then try using the correct syntax as in the manual i.e. ' Two Five Zero Decimal Zero' and not e.g. 'Zero Zero Zero' as seen in the log.

Hope that helps grtz

 

 

 

Thanks Hollywood, about the 0 ATC I figured out something was wrong and did a complete reset of all the profile already. That didn’t solve the issue with radio tune command.

So I need only to try your second suggestion.

That’s seems promising. Will do tomorrow.

Thanks, and sorry for my previous post, but i took a lot of effort into voice training, and with AIRIO you don’t have a backup (the jester wheel)...so I really would like to have all working as intended.

Will keep this post updated as i try.

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites

VirusAM

 

I had a similar problem with Radio Tune,

 

The solution was to change the Windows Spech, I had the one from English US, I changed it to English UK, and everything started working without problems.

 

:thumbup:

Link to post
Share on other sites

VAICOMM/AIRIO - problems with recognizing some functions

 

First of all do a hard reset of your database by deleting the Config and Database subfolders (you seem to have somehow imported an ATC called '0' which won't help here).

Then try using the correct syntax as in the manual i.e. ' Two Five Zero Decimal Zero' and not e.g. 'Zero Zero Zero' as seen in the log.

Hope that helps grtz

 

 

 

Hollywood I tried your suggestion but as you can see from the screenshots 250 decimal 0 is still recognized as 250.0.

In the same shot, you can see also tacan tune (which i also changed to tacan change) working with yankee but not with x-ray (also if the recognition of the words seems ok)

 

ccb7f02b4924b143e979748c885a976a.jpg

 

d2a31b52e9816ec897aa1d611a00b3aa.jpg


Edited by VirusAM

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
VirusAM

 

 

 

I had a similar problem with Radio Tune,

 

 

 

The solution was to change the Windows Spech, I had the one from English US, I changed it to English UK, and everything started working without problems.

 

 

 

:thumbup:

 

 

 

I will try also your suggestion, but my issue seems not releated to speak recognition (as the sentences are indeed recognized), but more to something related to vaicomm not interpreting correctly some parts

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Oculus Quest 2

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...