Jump to content

Recommended Posts

Hi guys. I'm having a bit of a problem with generator failure. I have followed the guide from Grim Reaper, but as soon as I say starrt pulling the collective more than about 30% I'm getting generator failure. I know it's normal to have generator failure when applying excessive force, but I am unable to fly.. If I do the auto start, it flies perfectly normal.. What can the issue be?

Link to post
Share on other sites

Throttle full right?

A Co, 229th AHB, 1st Cav Div

ASUS Prime Z370-A MB, Intel Core i7 8700K 4.9GHz OC'd, GeForce GTX 1080 Ti 11GB OC'd, 32GB DDR4, 1TB SSD, Windows 10 (64-bit)

Samsung 65" 4K Curved Display (Oculus Rift occaisionally), Track IR5, VoiceAttack, Baur's BRD-N Cyclic base/Virpil T-50CM Grip, UH-1h Collective by Microhelis & OE-XAM Pedals. JetSeat & SimShaker for Aviators.

JUST CHOPPERS

Link to post
Share on other sites
Did you cold start or does it happen after a hot start? I've noticed that when starting the mission with everything up and running you have to wait a few seconds before takeoff. Your engine rpm will increase, then settle at idle and you are good to go. But better perform a cold start, it's a great way to get to know her better.

 

 

Btw, you should get another guide. I'd recommend Chuck's

 

Hi, thanks for the tips, had the same issue, have tried, works. :thumbup:

Link to post
Share on other sites

Throttle is full yes, and I waited a while before takeoff, because I'm new to the aircraft so I spent some time on ground before takeoff. It happens everytime.. If I start it hot, it flies just fine. What other things can it be?

Link to post
Share on other sites
Throttle is full yes, and I waited a while before takeoff, because I'm new to the aircraft so I spent some time on ground before takeoff. It happens everytime.. If I start it hot, it flies just fine. What other things can it be?

 

Do you move the engine condition levers ( Number 2 of the image ) after start the engines ?

 

https://www.digitalcombatsimulator.com/images/products/magnificent_eight/26.jpg

 

 

Do you turn off your APU after start?

 

The APU AFAIK only affects to the fuel consumption.

Link to post
Share on other sites

If hot start is working then it is not your controllers.

 

Are you using external ground power to hasten your manual start up?

and further, have you enabled the on board generators once the engines are at full rev?

 

Do you know what was meant when the previous dudes questioned asked about full throttle?

Once the engines are initially spooled up and the needles on the dual engine tachometers hover around the 70 - 80 % mark..... Did you rotate the throttle grip on the collective so that the engines tachometer climbs above 90% for both engines?

 

Is your chopper carrying a heavy weapon load?


Edited by Rogue Trooper

HP pro Reverb.

Current settings:

Windows VR setting: IPD is 64.5mm, High image quality, 90Hz refresh rate.

Steam: VR SS set to 100%, motionReprojectionMode set to "motionreproduction" and Locked in at 45 Hz display,

DCS: Pixel Density 1.0, Forced IPD at 55 (perceived world size), 2 X MSAA, 0 X SSAA.

My real IPD is 64.5mm. Prescription VROptition lenses installed.

VR Driver system:

I9-9900KS 5Ghz CPU. XI Hero motherboard and 2080ti graphics card, 32 gigs Ram 3

[code][code][code][code]

[/code][/code][/code][/code]200 Hz. No OC at the mo.

Link to post
Share on other sites

And to add a small thing to Rouge Trooper's comment. Full throttle is full TO THE RIGHT, opposite to the Huey and most western helicopters.

Edit:

Never mind, saw now Chic already mentioned that in the first answer.


Edited by Holton181

Helicopters and Viggen

DCS 1.5.7 and OpenBeta

Win7 Pro 64bit

i7-3820 3.60GHz

P9X79 Pro

32GB

GTX 670 2GB

VG278H + a Dell

PFT Lynx

TrackIR 5

Link to post
Share on other sites

Check your weight in the re-arm screen, is easy to overload the chopper with a full load of fuel and weapons.

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

i highly recommend NOT using Grim Reaper tutorials as they are of very low standard, best info sources to use are Chucks Guides ( https://www.mudspike.com/chucks-guides-dcs-mi-8mtv2/ ), the ED manual by Belsimtek ( https://www.digitalcombatsimulator.com/en/downloads/documentation/magnificent_eight_flight_manual/ ) or if you prefer you tube videos there are vsTerminus ( https://www.youtube.com/channel/UCcsJYdaffnVHiituz7dnogw) and Matt Wagner (

)

vsTerminus will probs help you most as its very up to date

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...