Jump to content

Lockon Crash - Bug Report


Recommended Posts

System Specs:

 

Gigabite DS4 Motherboard

Intel Q6600 - G0 Stepping 2.4Ghz running @ 3.2 WaterCooled

3Gb ram

Nvidia 8800 GTS 640 Mb

2x Raptor X 150 GB in raid 0

 

Win Vista x64 - updated to the latest windows updates

Video Drivers - Tried the 3 latest versions fron NVIDIA + MS Win Update Version - Same Result

 

 

Here s the details of the application crash:

 

From the "after crash" pop up window:

 

Problem signature:

Problem Event Name: APPCRASH

Application Name: lockon.exe

Application Version: 1.1.2.0

Application Timestamp: 3676782f

Fault Module Name: StackHash_c22a

Fault Module Version: 6.0.6000.16386

Fault Module Timestamp: 4549bdf8

Exception Code: c0000374

Exception Offset: 000aa0fb

OS Version: 6.0.6000.2.0.0.256.1

Locale ID: 1033

Additional Information 1: c22a

Additional Information 2: 3b1976f88d1427b37eda74c5f142de31

Additional Information 3: 2fc5

Additional Information 4: ed50e6a4084667c29742302ce23a0ee1

Read our privacy statement:

http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409

 

From the reboot MS pop up window:

 

Problem signature:

Problem Event Name: BlueScreen

OS Version: 6.0.6000.2.0.0.256.1

Locale ID: 1033

Additional information about the problem:

BCCode: 76

BCP1: 0000000000000000

BCP2: FFFFFA8003230430

BCP3: 0000000000000020

BCP4: 0000000000000000

OS Version: 6_0_6000

Service Pack: 0_0

Product: 256_1

Files that help describe the problem:

C:\Windows\Minidump\Mini011908-02.dmp

C:\Windows\Temp\WER-17097-0.sysdata.xml

C:\Windows\Temp\WER4E5D.tmp.version.txt

Read our privacy statement:

http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409

 

Minidump file attached

 

 

Help appreciated !

 

Thank you

 

Mini011908-02.rar

Link to post
Share on other sites

don t start...

 

Its vista go buy XP

 

Honestly if you don't realize that Vista is better than XP that s fine, people used to say that of XP when they swore they d never switch from Win 98. You like to live int he past.. fine, that s your problem, just remember that some day you are going to HAVE to switch, cause Microsoft will find a way to make XP disappear so.. get ready.

At least spare me these comments! I m here cause i have a real problem and i hope that someone from ED could tell me how to work around it. 'Buying' XP is not a solution. I am already aggravated by the fact that I can't play for more than 30 min a game that i bought and that i like despite the glitches and the issues it has. Giving in to the corus of those who think they know which OS is best based on the fact that a game coded in the middle ages would run fine on it or not doesnt make you look smart.

Link to post
Share on other sites

I am just wondering if anyone from ED has taken a look at this post (or to similar ones for that matters), and if there s someone that could venture into possible solutions that dont include drivers update.

 

I am, as well as any other i imagine, willing to give any info that could help to find a fix..

 

It would also be nice to know if there is anyone working on getting lockon 'more' playable on vista, since that s where we re heading in the future..

 

Thanks

Link to post
Share on other sites

Rant-time

 

Well it s been almost a week now and noone has posted a reply with any relevance to the problem...:music_whistling:

 

At this point i am a little disappointed with the support :( and I am wondering if the posts here are usefull at all. I mean if i cant get a reply to a problem i am having why am i reporting the issue in the first place ?:wallbash: So that i can share my "bad experience" with other forum users ? So we can all cry together ? :sad_2::ranting::sad_2::drunk::ranting::sad_2:

 

Yes sure some people have experience with pc's and can point u in the right direction with some simple issues, but what about a more complex issue, unexpected behaviour, or uncommon problems related specifically to the game ? Nobody is gona be able to help you with those unless they have some knowledge of the game's code and programming..

 

I am sure someone is now thinking "well this attitude wont really get you anywhere.." :doh: well "before" the "attitude display" i wasnt getting much either so .. not a real change there.. but at least i am voicing my concerns, and if they are misplaced concern please tell me so, so i might be reassured myself that something will actually come out of these bug reports. As of now, however, nothing to report so maybe it should rightfully be me -the customer- being upset, not the support group or whoever it is that would be upset reading this..

 

Thats a bit beyond my point but com on... I was at least expecting an aknowledgement.. "yes, thank you for posting about this issue but we have no clue how to fix it or what it depends on :dunno:" which at least is better than "go buy xp :thumbdown:" especially after a patch that was supposed to keep things within the compatibility range with Vista.

 

Frustrated Pilot - Over and Out. :pilotfly:

Link to post
Share on other sites

Read my sig...

 

Seriously, accept the fact that vista is a new OS and thus it's going to have issues. If you want to play the game, go get XP. Dual boot the thing if you want, but XP is the way to go if you want to play lockon. I have no doubt that vista, or the next Microsoft OS is the future, but it's not the best thing NOW. If you want to play this game NOW then get XP.

DCS Wishlist: 1) FIX THE DAMN RIVERS!!! 2) Spherical or cylindrical panorama view projection. 3) Enhanced input options (action upon button release, etc). 4) Aircraft flight parameter dump upon exit (stick posn, attitude, rates, accel, control volume, control-surface positions, SAS bias, etc). 5) ADS-33 maneuver courses as static objects. 6) Exposed API or exports of trim position and stick force for custom controllers. 7) Select auto multiple audio devices

Link to post
Share on other sites
Read my sig...

 

Seriously, accept the fact that vista is a new OS and thus it's going to have issues. If you want to play the game, go get XP. Dual boot the thing if you want, but XP is the way to go if you want to play lockon. I have no doubt that vista, or the next Microsoft OS is the future, but it's not the best thing NOW. If you want to play this game NOW then get XP.

 

Your car breaks down and u buy a new one right ?

 

Would you at least have the curtesy of reading the post before saying "go get xp" .. that s not even acceptable after the release of a patch that was supposed to fix compatibility with vista.

 

I swear people are just so used to the way things are that just about noone is willing to step up and make an effort to actually DO something to even attempt to make things better. What is that ?

Your attitude is just like "heh you know this is how it is, take it or leave it..", a classic coming from an American, definitely not impressive.

Link to post
Share on other sites

Lock-On: Flaming Cliffs is "incompatible" with Windows Vista and it's not fault of microsoft. There is graphical also sound problems and BSOD issues if you run LO on Vista platform. Btw we shouldn't forget about the memory leak problem which is really not nice. ED knows everything already.

 

If ED will publish a patch and make LO compatible with windows vista, that's good news. If not you can't run it on windows vista platform without problems.

[sIGPIC][/sIGPIC]

Intel Core i7-6700K, @5GHz | Asus Maximus Hero VIII | 2 x eVGA GTX 970 SLI | Kingston Predator 16GB DDR4-3000Mhz | 2 x Samsung 850 PRO 240GB RAID-0 | AOC G2460PG G-SYNC LCD | OCULUS RIFT CV1 VR | THRUSTMASTER HOTAS WARTHOG | CH PRO PEDALS

Link to post
Share on other sites

Graphical Issues were present in XP as well and they still are. I remember my own issues there when i used to run XP myself.

 

The fact that the Vista Os and Lockon are not compatible is not entirely true. There s a handful of people blessed by god knows what that can run the two just fine. The problem is that Lockon wasnt coded FOR Vista, or with it in mind.. not even close.

 

The audio issues reflect this since in Vista the audio stack is completely different than what is under XP. Issued solved for most players that use creative hardware with Alchemy. I have it myself and works just fine after some time of struggling to find a solution.

 

The phantomatic memory leak is something i still have to read up on but i am not sure what the issue is there since some argue there is one and others seem to disagree..

 

I have no disillusion of a patch at this point though it would be much more professional on ED's side to release one since they didnt do a great job the first time around. They re all up in BS, DCS and whatever that LOMAC is on a different priority list alltogether.

 

What I would like to know is what does this memory dump say ?

What is the error ? What is happening ? Why is it crashing ? What does it depend on ? Is it another application in the background causing this ?

But most of all .. i would like to know that there is someone looking into it ! From a customer point of view... that isnt really too much to ask for.

Link to post
Share on other sites
  • 2 weeks later...
Give us:

 

CPU, Vidcard, Memory and Soundcard info.

 

 

That info is actually in the first 5 lines of the original post

 

 

And do you use the latest BIOS and device drivers ?

 

Yes and Yes

 

My guess:

 

You are using a creative labs sound card. If its so, uninstall the drivers, reboot and try flanker WITHOUT any music/sounds. Report afterwards.

 

The price is right, creative hardware it is, also mentioned in the post but i m pretty sure you just guessed it.

 

I ll try that out but i think it was happening with the Realtek Onboard audio as well.. we ll see

Link to post
Share on other sites

Reporting back to say that even with the onboard audio, no creative drivers installed the problem still exists.

Tried no audio at all in game and also disabling the audio card, those also did not work.

 

On a positive note the avi recorder works (which never did for me on xp)

Link to post
Share on other sites

Hi Tropikal,

 

you have no idea how I understand your frustration!!!!

 

I've been fighting on so many issues on Lockon that i lost the count.. but I stll love this Sim, so... i continue to have a "tough" relationship with up and downs... hehhe this remind me of my girlfriend!!! hehehe

 

However, i m not using Vista yet, so I am sorry if I cannot really help u on that, but i had an idea which may apply.

 

Sometimes, to solve compatibility issues on XP, u have a chance to run the application "emulating" an older OS. Does Vista have this option?

 

I solved problems with other application on XP (older programs) simply emulating Win 2000 or Win 98 for that application.

 

If Vista has this option, u may try that, and keep ure fingers crossed.

 

Although realli it can sound unfair, if many other users are reporting major compatibility issues with Vista, there is not that much u can really do.

On the other side, remember that PC are like ppl, they can have a sort of unique personality, due to the enormous diversity of components u can plug together to build a machine. Compatibility issues among several different devices are not a news. That is the reason why on some few blessed ppl using Vista, the game maybe is running smooth and on ure system is not. Troubleshooting this issue, require that u catch a Vista system that is known to work completely fine and have a full comparison with ure system, to see what hardware is different and most importantly if Vista is 32 or 64 bit.

 

I wish u the best luck on this my friend.. and also.. don t expect any support from Eagle, because (I may be wrong on this, in that case I apologize for) I was reading many posts, but I never saw any Eagle Rep. to step in and help. Whatever this community is sharing, the help is coming from the "community".

 

Have a great day.

Link to post
Share on other sites

Vista has that same option and it has been checked since install to make sure the program would run.

 

However, the issue is that the compatibility option does help when a program has trouble starting, in this case the program starts, but crashes after some time.

 

I tried running with compatibility eabled and disabled and i cant see any difference, it runs and crashes in both instances.

Link to post
Share on other sites
Another smart post.. it s amazing the amount of useless people on the planet.

 

Thanks, You are very quick to judge

 

and well, it is believed that only 1 out of 64 is a "creator" all the remaining 63 are "users"or "consumers" for the whole life... Do You believe You are the "one", or the one of the remaining 63?

P.S.try to keep the sense of humor ON at all times or You twice more likely to die while young :thumbup:

‎"Eagle Dynamics" - simulating human madness since 1991

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

Have you installed hotfixes recommended by Nvidia?

http://www.nvidia.com/object/windows_vista_hotfixes.html

 

I have a similar system, running Vista64, but with SLI. Initially it was running without crashes, but had recently started crashing in LOMAC. I traced my problem (perhaps not yours), to a little too much juice to the CPU to attempt a stable overclock. No, I didn't have to tone down the clock, but had to decrease the voltage to the CPU. This almost eliminates crashes from LOMAC. It still crashes at the most inopportune times, but after this fix, seems to occur in a ratio of 1 in 5-7 LOMAC starts.

 

Recently I've installed Vista Service Pack 1, and I haven't had a crash lately, so there's possible hope around the corner.

 

Do you have any other crashes that occur without LOMAC running? What other things are happening? Are you also getting CTDs in LOMAC or other apps? Is LOMAC the only culprit when you get a BSOD (are there any other file/hardware errors associated with your crashes)?

Link to post
Share on other sites
Have you installed hotfixes recommended by Nvidia?

http://www.nvidia.com/object/windows_vista_hotfixes.html

 

I have a similar system, running Vista64, but with SLI. Initially it was running without crashes, but had recently started crashing in LOMAC. I traced my problem (perhaps not yours), to a little too much juice to the CPU to attempt a stable overclock. No, I didn't have to tone down the clock, but had to decrease the voltage to the CPU. This almost eliminates crashes from LOMAC. It still crashes at the most inopportune times, but after this fix, seems to occur in a ratio of 1 in 5-7 LOMAC starts.

 

Recently I've installed Vista Service Pack 1, and I haven't had a crash lately, so there's possible hope around the corner.

 

Do you have any other crashes that occur without LOMAC running? What other things are happening? Are you also getting CTDs in LOMAC or other apps? Is LOMAC the only culprit when you get a BSOD (are there any other file/hardware errors associated with your crashes)?

 

First off thanx for the reply and thanx for the suggestions.

 

I hope my problem is not due to the overvoltage on the cpu on the overclock since i think i still had this issue when i was not overclocking.

 

To get to your questions, yes i did apply the nvidia recommended patches; i keep the OS uptodate with the Windows Updates and i m not sure if that would be the same as installing SP1 i believe it is.

 

No other program crashes except for explorer which stalls sometimes while streaming, however no blue screens or anything like that. No other program makes the pc reboot like LockOn.

 

All the times i checked the error referred to a file that had to do with lockon when it was not lockon.exe itself.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...