Jump to content

New StreamDeck Plugin


Recommended Posts

  • Replies 330
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi I wanted to share a new StreamDeck plugin I've created for DCS   https://github.com/charlestytler/streamdeck-dcs-interface       DCS Interface is a plugin that allows you to create buttons and

F16 PROFILE FOR STREAM DECK AND CTYTLER PLUG IN   MY F16 PROFILE:                                 DCS F-16C.zip

 

I have not been able to get it to work.

 

I've tried copying F-14B.lua to:

F14.lua

F-14.lua

F-14A.lua

 

with no success.

 

maybe try "F-14A-135-GR". That's the name of the kneeboard folder.

Link to post
Share on other sites
  • 4 weeks later...
  • 2 weeks later...

Just wanted to drop a note and say THANK YOU for this plugin!! Just started using it and it is fantastic.  Well designed, written and documented.  You sir are an asset to this community!  Thanks again!

Windows 10 x64 | i5-9600K | ASUS RTX 2080 8GB | 32GB DDR4 3200 | 256GB & 1TB SSD | GIGABYTE Z390 | TM Warthog HOTAS | Virpil WarBRD | Slaw RX Viper v2 | TrackIR 5 | Buddy-Fox A-10C UFC

Link to post
Share on other sites
  • 2 weeks later...

Hi, I have two DCS installations, the Stable and the Open Beta, both of which install on an additional disk with the folders in both savegames in the user folder.
I performed exactly the same procedure for both release by installing the DCS-Bios v0.10.0 on the PC, modifying in both installation the "script \ Export.lua" with the command for enabling BIOS and "script \ bin \ Config.lua" with the port modifyed to 1725 in the same way, copied to both installation savedgame in "script" the "DCS-ExportScript" folder of version 1.2.1, if launching the two versions alternately if I open DCS-BIOS Hub from web browser in DCS Connection I see both installations green with all three ticks for each activated, runnung the two release alternatively with a mission started in Lua Console i see the DCS Connection green as in the Dashboard I see green both Virtual Cockpit and Lua Console, but from the Stable installation if I test the connection from the StramDeck with the DCS Interface v1.0.3 plug-in installed and port changed to 1725 everything works correctly and I see the commands sent and the values of been read, if instead I launch the Open Beta it does not connect or write anything.
I also tried renaming the Open Beta installation and re-launching an installation in the same path then remove the new installation and restore the original but nothing changes.
Some idea?

Link to post
Share on other sites

Super-awesome-plugin! Thanks a lot! 🙂

Few issues/questions below.

 

SABRE

In case someone is using this with the Sabre and wants to have the toggle switch for bomb release auto/manual.
There's a mistake in "F-86F Sabre.lua", line 284 or somewhere around:
[639] = "",     -- Demolition Bomb Release Selector Switch, AUTO RELEASE/MANUAL RELEASE {2,-2}
Change this to:
[639] = "%1d",     -- Demolition Bomb Release Selector Switch, AUTO RELEASE/MANUAL RELEASE {2,-2}

Values are -1 for manual release and 1 for auto release.

 

MORE-WAY TOGGLES?

Do you know if it's possible in this plugin to assign more than 2 "icons" to a specific SD button? For example, in F-86 you have the 4-way toggle switch for bomb selection - "DEMO BOMBS", it goes like this: ALL (up), OFF (center), LEFT (down left), RIGHT (down right). I'd like to have 4 icons which simply depict the switch position. Can this be done somehow?

 

RECALCULATE NDB FREQ INTO kHz?

I have no idea how to deal with it. For example, in F-86 the "frequency" in ADF receiver is shown as, say, a float from 0.0000 to 1.0000 or something of this sort (we're talking DCS Stream Deck plugin). Basically it's a RANGE o values between two extrema which work something like percentage of "full frequency sweep" in a particular band, but it's not a frequency in kHz/MHz/etc.

How can I recalculate it into proper kHz, so I can then display value in kHz on a Stream Decks button? I mean, I'm not asking for a mathematical formula (can figure one out myself), but where should I put this formula? Do I need to write something additional in e.g. "F-86F Sabre.lua" or... I don't know.

 

EDIT:

Another mistake (or a change introduced in the module by ED) in "F-86F Sabre.lua", line 239 or so:

[807] = "%.1f",     -- AN/ARC-27 UHF Preset Channel Selector {0.0, 0.1, 0.2, 0.3, 0.4, 0.5, 0.6, 0.7, 0.8, 0.9, 1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7, 1.8}

Change to:

[807] = "%.2f",     -- AN/ARC-27 UHF Preset Channel Selector {0.00, 0.01, 0.02, 0.03, 0.04, 0.05, 0.06, 0.07, 0.08, 0.09, 0.10, 0.11, 0.12, 0.13, 0.14, 0.15, 0.16, 0.17, 0.18}

 


Edited by scoobie

i7-8700K GTX1060(6GB) 16GB 27"@1080p TM Hawg HOTAS TPR TIR3 SD-XL button/pot box
UH1 Mi8 Ka50 10CII 18 5 86 MiG15 109 Spit 51 47 A8 superc. PG NTTR Norm. Channel

Link to post
Share on other sites
On 1/10/2021 at 10:35 AM, scoobie said:

MORE-WAY TOGGLES?

Do you know if it's possible in this plugin to assign more than 2 "icons" to a specific SD button? For example, in F-86 you have the 4-way toggle switch for bomb selection - "DEMO BOMBS", it goes like this: ALL (up), OFF (center), LEFT (down left), RIGHT (down right). I'd like to have 4 icons which simply depict the switch position. Can this be done somehow?

 

Unfortunately it is not possible to assign more than 2 icons per button. This is a limitation of the Stream Deck software.
But there are magicians like nosaMtrevoC who did something fabulous for the TOMCAT here

But nothing prevents you to ask Elgato for this option.

 

On my side it is already done but more we are numerous to do it and the more chance we will have this option.

 

Edit: I've just requested it again.


Edited by Chacal_IX
Link to post
Share on other sites

Thanks for the clarification!
I have just submitted my kind request to Elgato 🙂

 

For now, I'm using those... "text alterations" (can't remember the term) for more than 2-way toggles, like:

 

| BOMBS |       | BOMBS |

|    OFF    |       |   LEFT   |   and so on.

A bit clumsy, but works.

i7-8700K GTX1060(6GB) 16GB 27"@1080p TM Hawg HOTAS TPR TIR3 SD-XL button/pot box
UH1 Mi8 Ka50 10CII 18 5 86 MiG15 109 Spit 51 47 A8 superc. PG NTTR Norm. Channel

Link to post
Share on other sites
  • 4 weeks later...

Has anybody managed to get the F-14 RIO weapon wheel working, the minute I press it the plugin appears to lock up causing me to have to restart streamdeck (DCS carries on working)

 

F-14B lua entry:

    [59] = "%.4f",   -- Weapon type wheel, (-0.023255813953488, 0, 1)

Have tried it in sections:

ExportScript.ConfigEveryFrameArguments = 
ExportScript.ConfigArguments = 

 

Both have the same result

VCVW-11 - VF-213 - 205R - Reaper

 

3800X | Asus 2070 Strix | 64gb Ram

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...