Jump to content

[W.I.P]stereo_mode_use_shared_parser helps a lot with balancing CPU/GPU usage


Recommended Posts

I was wondering if this could have anything to do with the fact trees are rendering in at different distances in each eye in my G2, and some distant terrain also looks 'odd'? I dont have the "options.graphics.stereo_mode_use_shared_parser = true/false" line in my autoexec.cfg file at all.

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

I was wondering if this could have anything to do with the fact trees are rendering in at different distances in each eye in my G2, and some distant terrain also looks 'odd'? I dont have the "options.graphics.stereo_mode_use_shared_parser = true/false" line in my autoexec.cfg file at all.


Check your graphics lua in the main dcs folder

Vincent "Virus" 

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2 + T-50CM2 Grip

Throttles: Logitech x56

Rudder: Saitek Rudders

Hardware: Razer Tartarus

Monitor: Samsung Odyssey G9, TrackIr v5

Link to comment
Share on other sites

6 hours ago, VirusAM said:

 


Check your graphics lua in the main dcs folder

 

 

--in stereo and hmd mode you can try to use single parser for both eyes , by default is false , comment to enable it or set to true
stereo_mode_use_shared_parser = false

 

 

5 hours ago, captainHelmet said:

If you would like to test the feature I believe you can paste that line into your autoexec.cfg if it isn't already there.

I have tested this feature before, thanks thou.


Edited by VampireNZ

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites



--in stereo and hmd mode you can try to use single parser for both eyes , by default is false , comment to enable it or set to true
stereo_mode_use_shared_parser = false



Yeah...I know, I discovered this feature quite a long time ago.
I was just pointing out that in autoexec.cfg you need to put there yourself.
But in graphics.lua in the main dcs world install is there and should be false by default.

Vincent "Virus" 

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2 + T-50CM2 Grip

Throttles: Logitech x56

Rudder: Saitek Rudders

Hardware: Razer Tartarus

Monitor: Samsung Odyssey G9, TrackIr v5

Link to comment
Share on other sites

1 hour ago, VirusAM said:

 


Yeah...I know, I discovered this feature quite a long time ago.
I was just pointing out that in autoexec.cfg you need to put there yourself.
But in graphics.lua in the main dcs world install is there and should be false by default.

 

NO.......I was quoting what you asked me to check, out of the graphics.lua. Figured since you were telling me to check it, you might recognise it...

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

10 ore fa, VampireNZ ha scritto:

NO.......I was quoting what you asked me to check, out of the graphics.lua. Figured since you were telling me to check it, you might recognise it...

 

Oh yes...that is the option I mentioned...sorry didn' get you were quoting the comment in the file.

Vincent "Virus" 

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2 + T-50CM2 Grip

Throttles: Logitech x56

Rudder: Saitek Rudders

Hardware: Razer Tartarus

Monitor: Samsung Odyssey G9, TrackIr v5

Link to comment
Share on other sites

Be careful with this option, it causes of it:

 

and this on water (white artefacts):

 

EI7gWCb.jpg

Webmaster of http://www.yoyosims.pl

Yoyosimsbanner.gif

Win 10 64, i9 9900k, RTX  3090 24Gb OC, RAM 32Gb Corsair Vengeance LED OC@3200MHz,, 3xSSD+2xSSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5, [MSFS, P3Dv5, DCS, RoF, Condor2, IL-2 CoD/BoX] VR fly only: HP Reverb G2

Link to comment
Share on other sites

  • 1 month later...
On 1/13/2021 at 1:00 PM, VampireNZ said:

I was wondering if this could have anything to do with the fact trees are rendering in at different distances in each eye in my G2, and some distant terrain also looks 'odd'? I dont have the "options.graphics.stereo_mode_use_shared_parser = true/false" line in my autoexec.cfg file at all.

 

I'm having the same issue. Default VR settings trees and terrain different in either eye causing shimmering and eye strain. Turn on the parser and terrain renders fine, but cockpit lights etc render in one eye only, also smoke not rendering properly. 

 

Frustrating that neither mode works. 

"It takes a big man to admit he is wrong...I'm not a big man" Chevy Chase, Fletch Lives

 

3700x - 32gb ram - RTX3080 - Windows 10

Link to comment
Share on other sites

19 hours ago, DayGlow said:

 

I'm having the same issue. Default VR settings trees and terrain different in either eye causing shimmering and eye strain. Turn on the parser and terrain renders fine, but cockpit lights etc render in one eye only, also smoke not rendering properly. 

 

Frustrating that neither mode works. 

 

Yeah I have to have 'options.graphics.stereo_mode_use_shared_parser = true' for trees to render at the same distance in each eye etc. Kinda strange you haver to have a hack line in your autoexec.cfg for the game to work properly in VR....but then again this is DCS. 9 time out of 10 the only way to fix a problem is with a patch/do it yourself.

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

On 3/4/2021 at 12:36 PM, VampireNZ said:

 

Yeah I have to have 'options.graphics.stereo_mode_use_shared_parser = true' for trees to render at the same distance in each eye etc. Kinda strange you haver to have a hack line in your autoexec.cfg for the game to work properly in VR....but then again this is DCS. 9 time out of 10 the only way to fix a problem is with a patch/do it yourself.

 

I find the source of the issue

 

 

"It takes a big man to admit he is wrong...I'm not a big man" Chevy Chase, Fletch Lives

 

3700x - 32gb ram - RTX3080 - Windows 10

Link to comment
Share on other sites

  • 2 months later...

Is there anything new with this trick and the 2.7 open beta version?  Has ED implemented it with 2.7? I see the Big Newy mentioned that they were working on something but it's not for public use yet. 

Link to comment
Share on other sites

i think its now inside 2.7 ... @BIGNEWY?

SYSTEM SPECS: Hardware Intel Corei7-12700KF @ 5.1/5.3p & 3.8e GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

29 minutes ago, speed-of-heat said:

i think its now inside 2.7 ... @BIGNEWY?

 

not as far as I am aware. I will ask the team when they get back from May holiday. 

  • Like 2

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

thanks have a great week!

SYSTEM SPECS: Hardware Intel Corei7-12700KF @ 5.1/5.3p & 3.8e GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

Posted (edited)

I thought it was included in 2.7 too, but not yet. I still see perf gains with it on, but smoke, heat blur and some cockpit lights still rendered in one eye. I also do see some graphical glitches in 2.7, particularly around the Caucasus coastlines where grey lines and polygons appear in the sea. I'm not sure if that's to do with this option or not as I haven't tried it as false - I like the performance I get with true so just accepting any negatives.


Edited by Hoirtel
Link to comment
Share on other sites

  • 2 weeks later...
On 5/10/2021 at 12:56 AM, Hoirtel said:

I thought it was included in 2.7 too, but not yet. I still see perf gains with it on, but smoke, heat blur and some cockpit lights still rendered in one eye. I also do see some graphical glitches in 2.7, particularly around the Caucasus coastlines where grey lines and polygons appear in the sea. I'm not sure if that's to do with this option or not as I haven't tried it as false - I like the performance I get with true so just accepting any negatives.

 

I am seeing the same thing. Only appears on left lens of my G2. While I like the little performance boost, my OCD can't abide the white blobs and what appear to be reflections of rivers and/or roads on the ocean surface.

Ryzen 5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium | Win 11

"Any sufficiently advanced technology is indistinguishable from magic."

--Arthur C Clark

Link to comment
Share on other sites

  • 3 weeks later...

Does definitely help performance on high polygon areas and generally lowers power usage so potentially great feature. But smoke sometimes flickers white in my left eye, renders normally in right. I don't really see the wrong reflections/artefacts over water though.

 

edit: this is on 2.7, the flickering smoke seem to be somewhat related to cloud settings/proximity.


Edited by Avalanche
Link to comment
Share on other sites

  • 5 weeks later...

I am still using 'stereo_mode_use_shared_parser' as it makes the difference in VR to lurk around 40 fps (the min my HMD can handle in half-refreshrate) and suffering the stutter pain when it goes below. 
Just curious if this is still being worked on or abandoned? the discrepancies between the left and right eye are sometimes severe.. especially when you use lights inside the cockpit. 
One eye is lit, the other isn't. but then.. not using it, suffers in performance.
 

 

Link to comment
Share on other sites

1 hour ago, durp said:

I am still using 'stereo_mode_use_shared_parser' as it makes the difference in VR to lurk around 40 fps (the min my HMD can handle in half-refreshrate) and suffering the stutter pain when it goes below. 
Just curious if this is still being worked on or abandoned? the discrepancies between the left and right eye are sometimes severe.. especially when you use lights inside the cockpit. 
One eye is lit, the other isn't. but then.. not using it, suffers in performance.
 

 

I hope it's still being worked on, I'm sure it will come out when it's ready. If I'm doing a night flight I disable it so the lights work properly. Night is better on fps anyway! - bit of a faff but hopefully temporary. 


Edited by Hoirtel
  • Like 1
Link to comment
Share on other sites

Had to stop using it. Getting weird artifacts of small pods and other lengths of rivers or streams being superimposed onto the sea, in the form of a greyish, static image.

Ryzen 5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium | Win 11

"Any sufficiently advanced technology is indistinguishable from magic."

--Arthur C Clark

Link to comment
Share on other sites

14 hours ago, Sr. said:

Had to stop using it. Getting weird artifacts of small pods and other lengths of rivers or streams being superimposed onto the sea, in the form of a greyish, static image.

Yeah I get this. I try to look the other way! 🤣

Link to comment
Share on other sites

  • 1 month later...
22 minutes ago, AndyPeacock said:

Did you ever manage to get an update on this? 

 

 

I have just asked the team again, it is still not where it needs to be for open use. I can not give any ETA on this feature at the moment sorry. 

  • Like 1
  • Thanks 1

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...