Jump to content

[W.I.P]stereo_mode_use_shared_parser helps a lot with balancing CPU/GPU usage


Recommended Posts

I was wondering if this could have anything to do with the fact trees are rendering in at different distances in each eye in my G2, and some distant terrain also looks 'odd'? I dont have the "options.graphics.stereo_mode_use_shared_parser = true/false" line in my autoexec.cfg file at all.

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
I was wondering if this could have anything to do with the fact trees are rendering in at different distances in each eye in my G2, and some distant terrain also looks 'odd'? I dont have the "options.graphics.stereo_mode_use_shared_parser = true/false" line in my autoexec.cfg file at all.


Check your graphics lua in the main dcs folder

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Valve Index 

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
6 hours ago, VirusAM said:

 


Check your graphics lua in the main dcs folder

 

 

--in stereo and hmd mode you can try to use single parser for both eyes , by default is false , comment to enable it or set to true
stereo_mode_use_shared_parser = false

 

 

5 hours ago, captainHelmet said:

If you would like to test the feature I believe you can paste that line into your autoexec.cfg if it isn't already there.

I have tested this feature before, thanks thou.


Edited by VampireNZ

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites


--in stereo and hmd mode you can try to use single parser for both eyes , by default is false , comment to enable it or set to true
stereo_mode_use_shared_parser = false



Yeah...I know, I discovered this feature quite a long time ago.
I was just pointing out that in autoexec.cfg you need to put there yourself.
But in graphics.lua in the main dcs world install is there and should be false by default.

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Valve Index 

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
1 hour ago, VirusAM said:

 


Yeah...I know, I discovered this feature quite a long time ago.
I was just pointing out that in autoexec.cfg you need to put there yourself.
But in graphics.lua in the main dcs world install is there and should be false by default.

 

NO.......I was quoting what you asked me to check, out of the graphics.lua. Figured since you were telling me to check it, you might recognise it...

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
10 ore fa, VampireNZ ha scritto:

NO.......I was quoting what you asked me to check, out of the graphics.lua. Figured since you were telling me to check it, you might recognise it...

 

Oh yes...that is the option I mentioned...sorry didn' get you were quoting the comment in the file.

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2

Joystick grips: Virpil T-50CM2

Throttles: Virpil T-50-CM3 Throttle

Hardware: VKB T-Rudder, Razer Tartarus, Winwing Take Off and Combat Ready Panels

VR: Valve Index 

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites

Be careful with this option, it causes of it:

 

and this on water (white artefacts):

 

EI7gWCb.jpg

Webmaster of http://www.yoyosims.pl

Yoyosimsbanner.gif

Win 10 64, i9 9900k, RTX  3090 24Gb OC, RAM 32Gb Corsair Vengeance LED OC@3200MHz,, 3xSSD+2xSSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5, [MSFS, P3Dv5, DCS, RoF, Condor2, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Link to post
Share on other sites
  • 1 month later...
On 1/13/2021 at 1:00 PM, VampireNZ said:

I was wondering if this could have anything to do with the fact trees are rendering in at different distances in each eye in my G2, and some distant terrain also looks 'odd'? I dont have the "options.graphics.stereo_mode_use_shared_parser = true/false" line in my autoexec.cfg file at all.

 

I'm having the same issue. Default VR settings trees and terrain different in either eye causing shimmering and eye strain. Turn on the parser and terrain renders fine, but cockpit lights etc render in one eye only, also smoke not rendering properly. 

 

Frustrating that neither mode works. 

"It takes a big man to admit he is wrong...I'm not a big man" Chevy Chase, Fletch Lives

 

3700x - 32gb ram - RTX3080 - Windows 10

Link to post
Share on other sites
19 hours ago, DayGlow said:

 

I'm having the same issue. Default VR settings trees and terrain different in either eye causing shimmering and eye strain. Turn on the parser and terrain renders fine, but cockpit lights etc render in one eye only, also smoke not rendering properly. 

 

Frustrating that neither mode works. 

 

Yeah I have to have 'options.graphics.stereo_mode_use_shared_parser = true' for trees to render at the same distance in each eye etc. Kinda strange you haver to have a hack line in your autoexec.cfg for the game to work properly in VR....but then again this is DCS. 9 time out of 10 the only way to fix a problem is with a patch/do it yourself.

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
On 3/4/2021 at 12:36 PM, VampireNZ said:

 

Yeah I have to have 'options.graphics.stereo_mode_use_shared_parser = true' for trees to render at the same distance in each eye etc. Kinda strange you haver to have a hack line in your autoexec.cfg for the game to work properly in VR....but then again this is DCS. 9 time out of 10 the only way to fix a problem is with a patch/do it yourself.

 

I find the source of the issue

 

 

"It takes a big man to admit he is wrong...I'm not a big man" Chevy Chase, Fletch Lives

 

3700x - 32gb ram - RTX3080 - Windows 10

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...