Jump to content

Axis values at start


Lange_666
 Share

Recommended Posts

Is there a way to prevent of DCS seeing axis input at startup while there is none?

If i enter a plane, often it starts to move after i touch the toe brakes, i have to either move the throttle a bit forward and back again. The reason why the airplane doesn't move is because of toe brake input because they are always set to on. The moment i touch them you see them quickly move down a bit and then back up to no input.

I wonder why DCS sees input on these axis on first start even if there is no real input at that moment.

And, is there a way around this?

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

Not sure it will solve your problem, but have you tried ticking the option to "sync HOTAS" (not exactly named that but something like that)? Depending what HOTAS you're using it should set your throttle (for example) to idle if your physical HOTAS is at idle.

Beyond that not sure how to solve it. I'm not sure if DCS uses the last setting it had or what value at startup but what you're seeing is "normal" (at least what happens always, not just to you)

Link to comment
Share on other sites

The sync was already applied, so that doesn't help.

It might be normal but it leads to some strange things like when using the F-18, starting mid-air to make a trap. If you trap with the toebrakes at anything else then zero and you catch a wire, the wire stays attached to the hook. Normally with some extra power and touching the brakes quickly the hook will eventually release the wire but i already had the chance of being pulled all the way back by the wire, not possible anymore to unhook.

Where's the deckcrew when you need them...?

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

That behavior is really not normal.

With settings sync'd the axis should be exactly in the correct position per the controllers on starting.

I know mine are. No idea though why yours may not be.

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | Valve Index| Vive Pro 2 |

Link to comment
Share on other sites

That's why i asked around.I was looking into the reason why the the F-18's hook would not release the cable until i found proof on Youtube. There were people dealing with the same thing and on one of the video's you could see that the toe brakes were active upon landing although he said he didn't brake on landing.

So i checked mine and the same thing happened. If i don't "activate" them when i'm going in game, the're about a 50% chance they are active, just as the throttle is (i already had the same with my previous Cougar setup and it happens both in stable en open beta).

 

 

+ look what rob10 said in the post #3.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

That's why i asked around.I was looking into the reason why the the F-18's hook would not release the cable until i found proof on Youtube. There were people dealing with the same thing and on one of the video's you could see that the toe brakes were active upon landing although he said he didn't brake on landing.

So i checked mine and the same thing happened. If i don't "activate" them when i'm going in game, the're about a 50% chance they are active, just as the throttle is (i already had the same with my previous Cougar setup and it happens both in stable en open beta).

 

 

+ look what rob10 said in the post #3.

 

 

Well if the toe brakes are active on landing you might need to invert the axis.. I just landed the other day in a F18 and this did not happen I unhooked and moved over to Cat 1..

ASRock Z590 Phantom Gaming 4/AC / Intel i7 10700K @ 5.0Ghz / Noctua DHS-14 / Samsung 980 Pro M.2 1TB /  Samsung 980 m.2 500GB OS Drive / Asus 1080GTX OC 2025mhz /  G. Skill Trident Z CAS 16 - 32GB RAM @4200  / HP Reverb G2 VR / HOTAS Cougar & MFD's / Buttkicker simulation

Link to comment
Share on other sites

No, they move in the right direction, they are active on startup and reset once touched. If i touch them and push slightly forward, you see the toebrakes briefly move forward "more then my input" and then come back to the actual position. Same goes for the throttle.

If i "enter" the sim (let's say in flight), my airplanes always accelerate up to the point where i move the throttle slightly forward and only then are the values of the axis taken into account. Since the throttle sits all the way back at that point, only then the airplanes start to slow down.

 

On enter... the throttle and toebrakes sit visualy in the correct position but the input for both is not zero. They only become zero when touched slightly the first time and then resemble the actual input. Just a little touch is enough. This is not a new behaviour, i have this since the beginning of DCS (years and years back) and over that time, i've re-installed it various times.

 

It does not happen all the time, roughly 50/50 and at first startup of the game, if i quit a mission and go back in, (mostly) the problem is gone.

 

Also, check robs10 post above number #3 .

I'm not sure if DCS uses the last setting it had or what value at startup but what you're seeing is "normal" (at least what happens always, not just to you)

 

 

I've also added a few input pictures:

Upon start-up of a fresh DCS, fresh mission A-10C:

CpMnUYn.png

Notice the +/- 30% input of the toe brakes at that point

 

 

After touching the rudder (putting my feet on the toe brakes was enough)

A7u4CKv.png

Notice the axis values for the toe brakes returned to the correct position = 0

 

 

Next is with the toe brakes fully pressed forward by me.

jxKdIji.png

Notice the direction of the axis is correct so no need to invert.

 

 

Same "can" happen with the throttle...

It's not a deal breaking issue, i general i touch my controls upon entering the planes but sometimes i forget like it happened with the F-18, starting mid-air for landing trials and i didn't touch brakes until after landing.

Then there was the impossibility to unhook.

 

 

Another one dealing with the same problem:

https://forums.eagle.ru/showpost.php?p=3596902&postcount=14

Look at the toe brakes position and then look at mine and compare them to fully applied toe brakes in my picture above.


Edited by Lange_666

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

I had a similar problem with my rudder pedals . Cycling them at the briefing screen resolved .

9700k , Aorus Pro wifi , 32gb 3200 mhz CL16 , 1tb EVO 970 , MSI RX 6800XT Gaming X TRIO , Seasonic Prime 850w Gold , Coolermaster H500m , Noctua NH-D15S , CH Hotas on Foxxmounts , CH pedals , Reverb G2

 

"Hold my beer"

Link to comment
Share on other sites

I see the same thing with the F-14. Toe brakes are at 50% when air starting. (enter mission and press rctrl+ent to see control inputs with hands and feet off controls). A small tap and they go back to zero.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

@Svsmonkey & SVgamer72: Those actions are a not a permanent cure, it's just a manual reset at the beginning of the game. Those inputs should not be there to start with.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

@Svsmonkey & SVgamer72: Those actions are a not a permanent cure, it's just a manual reset at the beginning of the game. Those inputs should not be there to start with.

 

When reporting a bug, it is best to offer a way or reproducing it for ED to look into.

 

I am just presenting a repeatable way of seeing the bug observed on my system.

Link to comment
Share on other sites

I didn't exactly reported a bug (for that this is the wrong section anyway), just asked a question if there was a way to bypass without touching those axis at startup. I haven't found one yet... ;). BTW, the bug has been around since the dawn of DCS World.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

Similiar issue. I set a deadzone of 90% for each rudder pedal so they would not be active until I pressed them all the way down.

Trackir4 using the latest Trackir 5 software, Win10 Pro [Creator Update] updated from Win7Pro Pro 64Bit, Intel® Core™ i5-2500 3.30 GHz 6M Intel Smart Cache LGA115 , GigaByte GA-Z68XP-UD4 Intel Z68 Chipset DDR3 16GB Ram, GTX MSI Gaming 1060 [6 GB] Video Card, Main Monitor 1 on left 1920x1080 Touchscreen Monitor 2 on right 1920x1080 .

Link to comment
Share on other sites

I checked my controls on each entry now, the toe brakes always (and not irregulary as i first thought because i never really checked the controls input each time) sit around 30% when entering the planes.

Could it be that this is to prevent accidental rolling should there be any throttle input?

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...