Jump to content

Need some Help with Settings - HP reverb


Recommended Posts

Hi All, so based on various threads and advice - I've been trying to get my rig running as smoothly as possible. However, I'm running into some issues that I'm not able to solve.

 

My system setting are in my sig line below. I'm running an HP reverb v2 and flying DCS through Steam. OB 2.5.6. The screenshots of settings to follow. But in short, no matter what settings I run - when I fly over any sort of city (Vegas in this case), my settings go from a stable 45 FPS down to 30 and occasionally less. I've tried the DCS settings with all shadows off and MSAA off as well as shadows on/flat and MSAA x2. There seems to be no difference in frame rate but obviously the pic with MSAA x2 is much less shimmery.

 

I've also been experimenting with Motion smoothing and SS in Steam VR. I've tried both setting SS to 100% 150% in both global and DCS application settings in Steam VR. Again, the frame rates are about identical between the two settings - with obviously the 150% being clearer and better resolution.

 

Can you VR gurus please take a look at the settings and see if I've got something set wrong? The ting that jumped out at me from running several back to back experiments with different setting in the F-16 / NTTR / instant action / Free flight scenario was that both the GPU and the CPU memory seemed maxed out. Often 10+ of 11 GB GPU RAM was being used and about 50% or more of the CPU RAM was being used. Lots of Red in FpsVR.

 

Thank in advance for any help or advice.

 

Edit: I can't seem to add more than 3 attachments per post - so I'll add the other screenshots in subsequent posts.

447140881_WMRsetup.thumb.PNG.9a68bff03002390628d622d51f66b16b.PNG

1160647926_SteamVRsettings-General.thumb.PNG.266f350e2fc666eb743cac57fa16e52a.PNG

543689380_SteamVRsettings-DCS150.thumb.PNG.95d773a95347c00696be65d83f27f119.PNG

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

batch 2 of my settings

1304314906_SteamVRsettings-DCS.thumb.PNG.1adeb3feaefa52e687b8f1c7688e3282.PNG

1897130288_NVIDIA1.thumb.PNG.58bfb8129806e6c9fe382bf89fa30567.PNG

1641677841_NVIDIA2.thumb.PNG.bc115982fe2fcfa8226feab175817d46.PNG

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

Screenshots of the DCS settings and Steam VR settings

1877534486_MSAAoff.thumb.jpg.f955f3bb35a79f6ad69d665b188625b9.jpg

2137594569_MSAAON.thumb.jpg.bb469e2debc30ac36d8c0f698bc00ac2.jpg

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

Ok, I feel stupid for asking - but how do you get a screenshot with the fpsVR window showing? I have it up in my HMD fov, but when I do a screenshot - its just the cockpit only. No fps VR window. Is there a trick to get it to display?

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

Because of DCS isn´t well optimized for VR yet, I guess there is no hardware existing at the moment which is able to run DCS-VR with constant 45 FPS, shimmer-free at high terrain textures + high textures + ultra visible range + 150% super sampling. In contrast to for e.g. Half Life Alyx which is really amazing and the best example that it is possible to create an absolutely stunning VR experience with an impressive texture quality and constantly high FPS at the same time.

Link to post
Share on other sites
Because of DCS isn´t well optimized for VR yet, I guess there is no hardware existing at the moment which is able to run DCS-VR with constant 45 FPS, shimmer-free at high terrain textures + high textures + ultra visible range + 150% super sampling. In contrast to for e.g. Half Life Alyx which is really amazing and the best example that it is possible to create an absolutely stunning VR experience with an impressive texture quality and constantly high FPS at the same time.

 

Yep, I'm aware of that. But others seem to be running similar HW and are able to get those settings up pretty decently. I'm just trying to figure out if I have any settings off that would be throwing my system into slow FPS?

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites
Ok, I feel stupid for asking - but how do you get a screenshot with the fpsVR window showing? I have it up in my HMD fov, but when I do a screenshot - its just the cockpit only. No fps VR window. Is there a trick to get it to display?

 

Anyone? Bueller?

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

Take super sampling down to 100%, 2.5..6 has serious perf issues.

 

I also turn of mirrors and shadows take the visibility range to high

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

Hi Notso,

 

Have a look at this thread:

 

https://forums.eagle.ru/showthread.php?t=253988&highlight=aurelius

 

I have an imageshack link in there that shows all of the settings I am using. The screenshots of SteamVR settings are a little outdated, but the settings in them are still valid.

 

Also, as far as I know, SteamVRs "Motion Smoothing" setting does nothing with WMR headsets. That may no longer be true, since that incompatibility issue was disclosed by Steam a long time ago, so they may have fixed it since then. But, something I KNOW currently works is to manually edit your defaultvrsettings file for SteamVR for WMR.

 

Here is a good link from Microsoft that shows you how to do that. Again, older version of SteamVR, so the screenshots aren't identical to what you'll see now, but the file editing process to turn on Motion Reprojection is still the same.

 

https://docs.microsoft.com/en-us/windows/mixed-reality/enthusiast-guide/using-steamvr-with-windows-mixed-reality

ASRock Z370 Professional Gaming i7, Intel i7 8700K Coffee Lake processor @4.7GHz, Corsair H105 Liquid Cooler, G.SKILL Ripjaws V Series 64GB DDR4 3400 memory, MSI GTX2080Ti Gaming X Trio 11GB video card, Samsung 840PRO 256MB SSD for Windows 10 64-bit OS, Samsung 850PRO 2TB SSD for program files, LG WH14NS40 Blu-Ray burner. HOTAS Warthog, Saitek Pedals, HP Reverb G2, HP Reverb Pro, and Oculus Rift CV1. Partridge and pear tree pending. pilotfly.gif

Link to post
Share on other sites
S

 

I have similar hardware, slightly overclocked -see my signature- and I use openbeta, latest 2.5.5. Still with 2.5.5 which is supposed to be easier on he hardware I Think your settings are on the high side.

 

Of course, its a matter of personal choise and how you experience the "flow".

I might be a bit on the sensitive to stutter.

 

You need to adapt the settings to your personal choise, and the fastest way is to look for settings from other people with similar hardware, and from that test until you find the highest Graphics that still give you smooth gaming enough so you dont get disturbed from stutter etc.

 

It will be a compromize.

 

Some settings loads/might load the hardware without giving you a noticable difference in VR in DCS.

 

fpsVR print screen; if you do not use full screen in-game(Alt+Enter), and alt-tab so you have the mouse pointer outside the DVS window on the computer screen you can use a print screen of the whole computer screen window. Make fpsVR window seen on the screen and print screen.

[T.M HOTAS Warthog Stick & Throttle + T.Flight pedals, HP Reverb pro, Oculus Rift( Pimax 8KX incoming) ] :)

[DCS Mirage 2K; Huey; Spitfire Mk IX, AJS 37, F-14, F-18, FC3, A-10 Warthog II ]

i9 9900KS@5.2/32Gb@3200/ ASUS ROG STRIX RTX2080ti OC 11Gb @2080Mhz(ASUS ROG STRIX RTX3090 OC incoming) ASUS STRIX Z390-F , 2Tb m2 NVMe

Link to post
Share on other sites
What is your DCS VR pixel density set to?

 

I think you're settings are looking pretty close to mine; I do turn off cockpit global illumination, as well as civ traffic.

 

I have PD set to 1.0 as per previous advice from StuartAston and imacken.

 

I'll try those others as well. I've never completely understood what global cockpit illum does. Does it light the cockpit even if it would be in shadows?

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites
Hi Notso,

 

Have a look at this thread:

 

https://forums.eagle.ru/showthread.php?t=253988&highlight=aurelius

 

I have an imageshack link in there that shows all of the settings I am using. The screenshots of SteamVR settings are a little outdated, but the settings in them are still valid.

 

Also, as far as I know, SteamVRs "Motion Smoothing" setting does nothing with WMR headsets. That may no longer be true, since that incompatibility issue was disclosed by Steam a long time ago, so they may have fixed it since then. But, something I KNOW currently works is to manually edit your defaultvrsettings file for SteamVR for WMR.

 

Here is a good link from Microsoft that shows you how to do that. Again, older version of SteamVR, so the screenshots aren't identical to what you'll see now, but the file editing process to turn on Motion Reprojection is still the same.

 

https://docs.microsoft.com/en-us/windows/mixed-reality/enthusiast-guide/using-steamvr-with-windows-mixed-reality

 

Thanks, that's very helpful. Are you running 2.5.6 or previous versions? I'm coming more to the conclusion I need to roll back to 2.5.5 OB until the .6 gets sorted out by ED.

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites
I have similar hardware, slightly overclocked -see my signature- and I use openbeta, latest 2.5.5. Still with 2.5.5 which is supposed to be easier on he hardware I Think your settings are on the high side.

 

Of course, its a matter of personal choise and how you experience the "flow".

I might be a bit on the sensitive to stutter.

 

You need to adapt the settings to your personal choise, and the fastest way is to look for settings from other people with similar hardware, and from that test until you find the highest Graphics that still give you smooth gaming enough so you dont get disturbed from stutter etc.

 

It will be a compromize.

 

Some settings loads/might load the hardware without giving you a noticable difference in VR in DCS.

 

fpsVR print screen; if you do not use full screen in-game(Alt+Enter), and alt-tab so you have the mouse pointer outside the DVS window on the computer screen you can use a print screen of the whole computer screen window. Make fpsVR window seen on the screen and print screen.

 

Ok cool, I think I'm going to roll back to 2.5.5 now and re-attack the settings. They were running well on the stable version back in early Jan (whatever that load was) before I switched to 2.5.6OB.

 

As for the screenshots, I think my issue is I'm using F12 to take the screen captures because that's taking them through Steam. I'll try the print screen button with full screen to see it that works. Thanks.

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

I

m in the middle of updating (or rolling back) to 2.5.5. But before I did, I took a series of screenshots that were interesting and at the same time baffling.

 

So here is the fpsVR running with the Sim on 2.5.6 / everything set to high as before, MSAA x2, Shadows flat, global cockpiut illum on, AF @ 8x / PD 1.0 and Steam VR SS @ 150%:

 

Poor frame rates as I approach the outskirts of Vegas on the Instant action Free flight scenario.. Poor frame rates as you would expect with those settings. However, see the next series of posts......

2120551078_FPSVR1.PNG.2a1fee9d51988e97a7bf5b6823a20682.PNG

140456323_FPSVR2.thumb.PNG.7956e321e65180689c11894e70ca8fde.PNG

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

This time I turned Steam VR SS down to 100% and left everything else the same. It actually got worse.

1855083603_FPSVR3.thumb.PNG.766c33aff19c85ae8bfe2369316e76ee.PNG

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

Next I turned Grass/clutter, tree vis, etc way down (preload radius still max) and cockpit illumination off.

 

No improvement

975611140_FPSVR5-clutteroff.thumb.PNG.28d21c75d07de59310e6f3cbaa4afd69.PNG

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

This time I turned MSAA OFF and AF off.

460108603_FPSVR6-MSAAoff.thumb.PNG.ed5a24c67d25badf1c9dbe480bd8c402.PNG

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

Finally, I turned everything off - all shadows off, MSAA and AF off.

 

Still very little to no change.

 

Something seems wrong here. My machine should be able to easily handle this at 45 FPS with everything on low or off. The one thing that jumps out at me is it seems like my CPU is maxing out. Could there be something running in the background that is eating up resources??? I took a look at task manager and saw there were multiple instances (15) of Steam VR Webhelper open. WTF?? How do I fix this?

509921024_FPSVR7-alloff.thumb.PNG.58470cf9587be4c5bdaff9b9820c5e34.PNG

991700704_Processes2.thumb.PNG.4e34b0cbf3fb25c07609ce3d7f5f8d94.PNG

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

Ok, so I literally spent almost the entire day yesterday (self-isolation is great:music_whistling:) playing with every possible combo of settings. In 2.5.6, I was not seeing any real appreciable change between the usual settings being almost maxed out (ranges high, MSAA x2, shadows flat, SS @150%, etc) to them being turned way down. AS long as I was not anywhere near an urban city such as Vegas or Dubai, I was getting a solid 45 fps even when flying around other AI. AS soon as I got within about 5 miles of a city, the frame rates would plummet and stay around 28-30 regardless if I had the usual performance hog settings turned on or way down.

 

I rolled back to 2.5.5 OB and tried all the same combo of settings (high to low). Yes it was better around the cities - but only slightly and not really enough to make a difference. As soon as I got anywhere near or over a city - the frame rates dropped from 45 to 30 and frame times into the 20+ ms in 2.5.6 while in 2.5.5 I was seeing frame rates drop from 45 to 35-40 and frame times in the high teens to low 20s. The "feel" was not significantly different between the two.

 

So long story short, I went back to 2.5.6 as it had some upgrades I enjoy on the F-16 and most of my "fighting" for now is over the open desert where my performance is fine even with the settings pretty much maxed out. I have SS set to 150% in Steam VR and MSAA x2, AF 8x, terrain object detail at medium, shadows flat and visibility to Ultra. The picture is SOOOO much clearer and enjoyable. And everything is smooth for now. Of course I'm not playing on any MP servers yet, just practicing SP missions for now learning the F-16. So hopefully by the time I want to try some MP stuff, ED will have the VR bugs sorted out. I'm going to stop tweaking for now and just start flying. This rabbit hole could go on forever otherwise.

 

Edit: I still think my CPU is the bottleneck given the fpsVR details. But not sure how to address that. If anyone has any thoughts on that, I'd be very appreciative. Thanks in advance.


Edited by Notso

System HW: i9-9900K @5ghz, MSI 11GB RTX-2080-Ti Trio, G-Skill 32GB RAM, Reverb HMD, Steam VR, TM Warthog Hotas Stick & Throttle, TM F/A-18 Stick grip add-on, TM TFRP pedals. SW: 2.5.6 OB

Link to post
Share on other sites

Maybe you could make a mission with a route to follow, stating a specific altitude to fly and attach that .miz file with your post so others can try it and then compare fps values.

 

I dont really see that I have the same behaviour.

If I set low settings I can keep 90 fps quite often and if I sett high settings and high SS I bog my computer down and have no fun.

 

If I remember it right you hade quite some changes to the nvidia control panel.

I think some of these might set you back.

 

For the other people I have been in touch with we got quite good fps and frame times when backing settings as per thuds guide in the site vr4dcs.com.

Some have problems that occationally raise the CPU frametimes, the cause this isnt really k own to me yet but in between they got good gaming.

 

I do not know for sure but I have a feeling that it is easy to buy the best hardware and then think that you can put most settings to max. Yes, for most other games that true but not for DCS+VR.

You WILL have to compomise a lot even if you use the best H/W.

 

I’ll make some print screens and get back with my settings.

[T.M HOTAS Warthog Stick & Throttle + T.Flight pedals, HP Reverb pro, Oculus Rift( Pimax 8KX incoming) ] :)

[DCS Mirage 2K; Huey; Spitfire Mk IX, AJS 37, F-14, F-18, FC3, A-10 Warthog II ]

i9 9900KS@5.2/32Gb@3200/ ASUS ROG STRIX RTX2080ti OC 11Gb @2080Mhz(ASUS ROG STRIX RTX3090 OC incoming) ASUS STRIX Z390-F , 2Tb m2 NVMe

Link to post
Share on other sites

doing perf tuning in 2.5.6 is ... futile at the moment

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

I rolled back to 2.5.5 OB and tried all the same combo of settings (high to low). Yes it was better around the cities - but only slightly and not really enough to make a difference. As soon as I got anywhere near or over a city - the frame rates dropped from 45 to 30 and frame times into the 20+ ms in 2.5.6 while in 2.5.5 I was seeing frame rates drop from 45 to 35-40 and frame times in the high teens to low 20s. The "feel" was not significantly different between the two.

 

Edit: I still think my CPU is the bottleneck given the fpsVR details. But not sure how to address that. If anyone has any thoughts on that, I'd be very appreciative. Thanks in advance.

 

Something is strange.

 

I have virtually the same hardware and in 99.9% of the cases its the GPU that sets the limit.

 

doing perf tuning in 2.5.6 is ... futile at the moment

 

But not 2.5.5, as he rolled back and didnt get a big improvement.

[T.M HOTAS Warthog Stick & Throttle + T.Flight pedals, HP Reverb pro, Oculus Rift( Pimax 8KX incoming) ] :)

[DCS Mirage 2K; Huey; Spitfire Mk IX, AJS 37, F-14, F-18, FC3, A-10 Warthog II ]

i9 9900KS@5.2/32Gb@3200/ ASUS ROG STRIX RTX2080ti OC 11Gb @2080Mhz(ASUS ROG STRIX RTX3090 OC incoming) ASUS STRIX Z390-F , 2Tb m2 NVMe

Link to post
Share on other sites

I have these settings:

[/img]

I didnt change that much. I'm leaning to think that your settings in nvidia CP can be at least part of the problem.

 

[/img]

 

Supersampling in the two, Video and per application doesnt work individual. It actually supersmaples x [per application] at least for mee when I did my setup. doing 150% in video and 150% in per application/DCS makes total go to 225% or something like.

This is most probably your number one setting killing fps and spiking CPU/GPU.

 

Motionsmoothing - I have it off.

 

[/img]

Make sure Pixel density is set to 1.0.

 

 

When I see your settings I Think theres a lot of high settings that'll bog the CPU/GPU.

 

The biggest problem is using supersampling in steam VR in both video and per application DCS as it both are in action times each other….but there is a lot of other "high settings".

 

My steamVR setting as per thuds guide at vr4dcs.com give me 100% = 2204x2160.

In you settings, some Picture show 100% = 2708x2652 = says 100% but it still is 150% as per pixelcount. I Think there might be quite much to change to be sure it will work perfect.

[T.M HOTAS Warthog Stick & Throttle + T.Flight pedals, HP Reverb pro, Oculus Rift( Pimax 8KX incoming) ] :)

[DCS Mirage 2K; Huey; Spitfire Mk IX, AJS 37, F-14, F-18, FC3, A-10 Warthog II ]

i9 9900KS@5.2/32Gb@3200/ ASUS ROG STRIX RTX2080ti OC 11Gb @2080Mhz(ASUS ROG STRIX RTX3090 OC incoming) ASUS STRIX Z390-F , 2Tb m2 NVMe

Link to post
Share on other sites

So I fired up the F18 and went for a run in Las Vegas area. Instant action, Nevada.

 

[/img]

 

3.png' alt='3.png'>

[T.M HOTAS Warthog Stick & Throttle + T.Flight pedals, HP Reverb pro, Oculus Rift( Pimax 8KX incoming) ] :)

[DCS Mirage 2K; Huey; Spitfire Mk IX, AJS 37, F-14, F-18, FC3, A-10 Warthog II ]

i9 9900KS@5.2/32Gb@3200/ ASUS ROG STRIX RTX2080ti OC 11Gb @2080Mhz(ASUS ROG STRIX RTX3090 OC incoming) ASUS STRIX Z390-F , 2Tb m2 NVMe

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...