Jump to content

Stable version cancelled ? [ NO - it will be updated when we are happy with 2.5.6]


Jokletox
 Share

Recommended Posts

Hi !

 

No update since december 2019, KA-50 and A10C not working in stable version for a friend (new customer)... Stable version is still developping ? Some customers just want to play, not debugging, and those doesn't eem very important to you. It is very frustrating.

 

15/30 days difference between the two versions is ok, 4 months it's too much :(

 

(Sorry for English, it's from Google Trad' :music_whistling: )

Link to comment
Share on other sites

A quote from BIGNEWY.

 

 

 

"Until 2.5.6 is in better shape we wont be updating stable version.

 

Hopefully the coming open beta patches will help and then we can think about updating stable version.

 

Thank you"


Edited by BuzzU

Buzz

Link to comment
Share on other sites

And they keep updating the beta again and again, what's the point ? Get the beta working properly, move it to stable, THEN, keep testing things on beta. There is so much things not working properly on beta that they don't even know where to look at. And they're creating new problems to solve by adding new content again and again. Focus on fixing the beta rather than looking new things to add (that they won't be able to get working before few months) just to keep the 9 years old excited by new trailers !

Link to comment
Share on other sites

ummm......the last update wasn't really about adding stuff but trying to fix some issues. You want them to just throw the update at Stable and try to fix it later????

 

Like BuzzU said:

A quote from BIGNEWY.

 

"Until 2.5.6 is in better shape we wont be updating stable version.

 

not real sure what more needs to be said

Link to comment
Share on other sites

As long as the beta is a mess they shouldn’t update the stable, even if it takes another 6 months. Otherwise it won’t be stable at all.

Too bad about certain modules but that’s the way it goes. You could always go back another version to when the A10 and KA50 both had their old cockpits (unless that’s what you mean by them not working)

Link to comment
Share on other sites

... KA-50 and A10C not working in stable version for a friend (new customer)...

 

 

You need to contact support to get a serial number for Ka-50 if you mean that with "non-working". I've been flying it in stable for 2..3 days now.

Link to comment
Share on other sites

Stable version cancelled ?

 

What you both didn't read in that simple sentence ?

Yeah, the last update on beta was fixes, was it always the case since 4 months ? No it wasn't.

 

 

But there are many more fixes before it is ready for stable. There’s no time limit for how long they can keep working on it to make it ready- just your impatience.

Link to comment
Share on other sites

As long as the beta is a mess they shouldn’t update the stable, even if it takes another 6 months. Otherwise it won’t be stable at all.

Too bad about certain modules but that’s the way it goes. You could always go back another version to when the A10 and KA50 both had their old cockpits (unless that’s what you mean by them not working)

As long as the tiny in number but very vocal on the forum Multiplayer Community is getting updates they shouldn’t update the stable, even if it takes another 6 months.

Too bad about people who have paid hard earned money for certain modules but that’s the way it goes if you're not one of the golden users...You could always p*ss off back to an older unsupported version...who cares...ED certainly don't

 

 

Corrected that for you

Airbag_signatur.png

Link to comment
Share on other sites

Lynnux, I asked him and he told me that he contacted the support and they said "Go play on beta to get the module working" so why they didn't give him a key ??

 

Because there are no keys? If you want use it, just download it. If you want help with problems with a module, you should ask in their respective forums. Stable used to be updated frequently, then people such as yourself were complaining about constant downloads and new bugs, so they recently decided to stop, especially until they get it working better.

 

That is unlikely to change anytime soon. Download beta, or not. Roll back to an earlier version, or not. All up to you, you've got quite a bit of freedom to approach it how you want. And before you ask, there's a search bar up there for a reason ;) Little initiative goes a long way

Spoiler

tumblr_inline_mpv4v0zasI1rg41uj.gif

The troll formerly known as Zhukov

Link to comment
Share on other sites

A quote from BIGNEWY.

 

 

 

"Until 2.5.6 is in better shape we wont be updating stable version.

 

Hopefully the coming open beta patches will help and then we can think about updating stable version.

 

Thank you"

 

Yeah I rode that, than you BuzzU for that

 

(now replying to the other guys) what I'm saying is that they keep adding new things instead of fixing what's already not working on the actual beta. I'm not gonna repeat myself again and again

Link to comment
Share on other sites

Until 2.5.6 is in better shape we wont be updating stable version

 

 

OK, we're into the 4 month since an update to stable...everyone seems pretty cool about that so far...

At what point will the majority consider it an unacceptably long time to have even the simplest and most critical fixes for the stable branch...

5 months?

6 months?

1 year?

Just what do DCS users think is an acceptable update cycle for a game many (most) users will have paid hundreds of $s for across multiple modules?

Airbag_signatur.png

Link to comment
Share on other sites

Because there are no keys?

 

Lynuux said "You need to contact support to get a serial number for Ka-50". That's why I said that they didn't gave him a key for those modules on Stable. Read the whole conversation.

I'm gonna ignore the rest of your answer because that has nothing to relate with what we are all talking about.

 

Are you gonna tell me that if he wants to fly KA50 and A10 he has to update to the beta as he can't get a serial number for stable ? Product is now keyless, ok, but not on stable. That makes it unobtainable for him.


Edited by RyukoSoan
Link to comment
Share on other sites

OK, we're into the 4 month since an update to stable...everyone seems pretty cool about that so far...

At what point will the majority consider it an unacceptably long time to have even the simplest and most critical fixes for the stable branch...

5 months?

6 months?

1 year?

Just what do DCS users think is an acceptable update cycle for a game many (most) users will have paid hundreds of $s for across multiple modules?

 

I'll consider it unacceptable if 2.5.6 gets fixed, so it's ready for a stable update, and stable doesn't get updated within 2 weeks.

 

Seriously Jason, for the millionth time, the open beta is the PUBLIC TESTING BRANCH, land RyukoSoan, like it or not, this is its intended purpose.

 

When ED gets verification that they're features aren't going to cause problems, and are working as intended to an acceptable level, then it'll get shifted over to stable, not before. I would rather wait for working updates, than suffer through broken stuff. I'd be more than willing to test on the OB, but my hardware isn't the best so I prefer not to.

 

Until that happens you can either download the open beta, or have some patience... It'll come when it comes.

 

To quote Mr. Incredible: "We get there, when we get there!"

 

I rank a bit on the low-end as far as hardware goes (of course it could be much worse), so I'd rather have a stable that works, that I can get acceptable performance with the limited missions I do, than have new modules and pay a heavy price with performance.

 

I don't want ED to even think about touching stable until 2.5.6 is sorted out. The problems with 2.5.6 aren't going to go any faster by updating stable.

 

I'm gonna ignore the rest of your answer because that has nothing to relate with what we are all talking about.

 

I beg to differ, and if you'll ignore a workaround to your plight, then I am not sure what your doing here?

 

And yes, I exclusively play stable, it's just I realise the problems 2.5.6 introduced and the features being developed for it. I recognise that ED doesn't have infinite resources, I also understand Brooks' law.

 

Stable will not be updated until 2.5.6 is fixed, it is the priority, and rightfully so.


Edited by Northstar98

Modules I own: F-14A/B, F/A-18C, Supercarrier, F-16CM, AJS-37, F-5E-3, MiG-21bis, Ka-50, A-10C (+ A-10C II), UH-1H, Mi-8MTV2, P-47D, P-51D, FC3, MiG-15bis, Yak-52, CA, C-101, Hawk

Terrains I own: Syria, The Channel, SoH

 

System (RIP my old PC): Dell XPS 15 9570 w/ Intel i7-8750H, NVIDIA GTX 1050Ti Max-Q, 16GB DDR4, 500GB Samsung PM871 SSD (upgraded with 1TB Samsung 970 EVO Plus SSD)

 

VKB Gunfighter Mk.II w. MCG Pro

 

Dreams: https://uk.pcpartpicker.com/list/mBG4dD

Link to comment
Share on other sites

I'll consider it unacceptable if 2.5.6 gets fixed, so it's ready for a stable update, and stable doesn't get updated within 2 weeks.

 

Seriously Jason, for the millionth time, the open beta is the public testing branch, when ED is happy that they're features aren't going to cause big problems, it'll get shifted over to stable.

 

Until that happens you can either download the open beta, or have some patience... It'll come when it comes.

 

To quote Mr. Incredible: "We get there, when we get there!"

 

I rank a bit on the low-end as far as hardware goes (of course it could be much worse), so I'd rather have a stable that works, that I can get acceptable performance with the limited missions I do, than have new modules and pay a heavy price with performance.

 

I don't want ED to even think about touching stable until 2.5.6 is sorted out. The problems with 2.5.6 aren't going to go any faster by updating stable.

 

Again and again and again. Stable means stable. So of course nobody wants to have a beta update on the stable ??? What we're all saying is that they should go little by little, because now, they have ton of sh*t to work out and they're not gonna make it until few months. Test few things, fix it so it's stable, make it live on stable, then try other things OR you're gonna let down every player that is on stable. The game is dead for stable players for now 4 months.

Link to comment
Share on other sites

Anyway, getting of this topic cause the only things you all say is

-If you want beta updates, go on beta

-Beta is made for testing so that's why the updates are not on stable

-They shouldn't update unstable update on stable.

- aaand that's all about you say, and that's has nothing to do with what I'm talking about.

Link to comment
Share on other sites

Again and again and again. Stable means stable. So of course nobody wants to have a beta update on the stable ??? What we're all saying is that they should go little by little, because now, they have ton of sh*t to work out and they're not gonna make it until few months.

 

Development stopped when 2.5.6 was being actively developed, and when it's respective updates came out.

 

ALL the updates present added to the OB are in a beta testing state. I get fix one feature then port it over to stable, the problem is they are 2 different versions, that work in different ways (primarily in graphics). So while at first it makes sense, we're trying to make a feature designed exclusively for one version, then trying to port over to a different one and hope that nothing goes wrong.

 

Instead we can keep updating open beta until the whole thing works and once it's working make a massive update to stable, that way active development only needs to be done once, for one version. We haven't really had such a large disparity between stable and OB, only when we had 1.5 and 2.0.

 

It took years before 1.5 OB/stable (I can't even remember) got updated to 2.0 OA standards + new features, that only came with the introduction for 2.5. Yes, years.

 

you're gonna let down every player that is on stable. The game is dead for stable players for now 4 months.

 

I exclusively play stable, I'll speak for myself thanks...


Edited by Northstar98

Modules I own: F-14A/B, F/A-18C, Supercarrier, F-16CM, AJS-37, F-5E-3, MiG-21bis, Ka-50, A-10C (+ A-10C II), UH-1H, Mi-8MTV2, P-47D, P-51D, FC3, MiG-15bis, Yak-52, CA, C-101, Hawk

Terrains I own: Syria, The Channel, SoH

 

System (RIP my old PC): Dell XPS 15 9570 w/ Intel i7-8750H, NVIDIA GTX 1050Ti Max-Q, 16GB DDR4, 500GB Samsung PM871 SSD (upgraded with 1TB Samsung 970 EVO Plus SSD)

 

VKB Gunfighter Mk.II w. MCG Pro

 

Dreams: https://uk.pcpartpicker.com/list/mBG4dD

Link to comment
Share on other sites

2.5.6 and 2.5.5 stable are different versions of the game, there is a reason why some modules only work on one and not the other, making it work for both = double the workload, of course correct me if I'm wrong.

 

:doh: :doh: :doh:

 

How about letting the module as it is for the stable version so people that bought it still can use what they spent money for ?

 

You're also saying that "ALL updates are in a beta state".

 

How about having LESS updates to fix at once SO they can fix it easier rather than having a ton, not knowing where they're heading to and letting down stable players for months and months ?

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...