Jump to content

[REPORTED]2.5.6 Performance


Recommended Posts

Something else I noticed yesterday, while screwing around in the Tomcat (different from the Hornet I talked about before), once again, in VR.

 

The CPU frame time drops pretty significantly if I switch to a non-cockpit view, (ex: F2 key). I assume this is because it's no longer actually doing any of the work related to the cockpit instruments, and also not drawing the geometry of the cockpit, but while the GPU frame time dropped just a little, the CPU frame time dropped a lot - from 12-13ms down to like 8 or 9. It's enough to go from about fifty percent reprojection to near-zero.

 

Also notably, the reported CPU load is generally never more 15-16%. On my 9900K, that (naively) suggests that what's going on is that the game is either only running two threads, or it's running many, but most of them are just waiting around for another one to finish some task they need. From one software developer to another, suffice it to say I'm glad it's not my problem to debug that. :D

Link to post
Share on other sites
  • Replies 538
  • Created
  • Last Reply

Top Posters In This Topic

I tried to run openbeta today and in multiplayer my frames were getting to low teens in a server with 26 people and it was a slideshow at the airbase with two guys on the ground in hornets and one flying over head. As soon as I flew away from the base and by myself the FPS went back up to 40-45. I had SSLR, SSAA and MSAA off, shadows on low, heat blur low, civ traff off. as well as mustangs registry edit for DVR and the autoexc.cfg with track and hotplug set to disable. I also ran DCS in High priority. I have Nvidia CP all tuned for performance as well. I had to reinstall release version.

System Specs: i9 9900KS, EVGA 2080 TI FTW 3 Ultra OC'd, 32gb Gskill Trident Z Royal ram(for the bling), Samsung 970 PRO M.2 SSD,. Thrustmaster HOTAS Warthog throttle and VKB GF3/MCG PRO stick, MFG Crosswind V2, HP REVERB.

 

DCS modules: F-14, F-18, F-16, A-10, Nevada and PG

Link to post
Share on other sites
They should test it more (which takes more time), they should step up their game (which make the relesae quicker), they should release it without bugs (but wasn't it Open Beta?), the should add a lot more content etc, etc...

You dudes would be perfect CEO's, what are you waiting for?

 

I am sure Lange 666’s car dealer must appreciate him very much. But as everyone knows, we are not CEOs but customers. :clap:

Link to post
Share on other sites

I played museum relic mission 16 today, and as soon as more AI units gathered together storming airfield, my FPS tanked from steady 45 (hp reverb), to low teens. Flew the same mission a few months ago in the Mig instead of Sabre, and haven't experienced any issues then.

 

I also noticed that when I pause the game or press Esc, then the FPS immediately returns to 45. So it's not the visuals, but something that the game is calculating that's causing the issue.

Hardware: Virpil T-50CM, Hotas Warthog, Hotas Cougar, Slaw Rudder, Wheel Stand Pro, GVL224 Trio Throttle, Thrustmaster MFDs, Saitek Trim wheel, Trackir 5, Reverb

Link to post
Share on other sites

For some time I have been back to 2.5.5 and tried the settings which gave better value fps.

When disabling global illumination and switch to flat shadows I have in 2.5.5 advantage +11-15 fps.

The same settings in 2.5.6 the last beta, with the exception of the off SSLR is a gain of 3 fps, probably is the biggest problem with the lighting.

Asus B-85 Pro Gamer, i7 4790K non-oc, Asus GTX 1080 Ti, 16 GB non-oc RAM, Intel SSD 520 - 240 GB, MSFFB2, Win7 64-bit.

Link to post
Share on other sites

I retried 2.5.6 over the weekend and all looks great and performs great in single player with no-low AI planes.. As soon as more than 4 planes are added FPS drops below 60 for vsync. Multiplayer is a complete no go with FPS dropping to 30s/ 40s.

I reverted back to 2.5.5, but fingers crossed this will be resolved going forwards.

Intel Core i3 8350K 4GHz, MSI RTX 2080 Super, AS Rock Z370 Pro4 Motherboard, Samsung SSD, 32G DDR4 RAM, Windows 10 PRO 64 Bit

 

Rift-S, Tripple Samsung 27" C27F Display, Hotas Warthog, Saitek Pro Flight rudder pedals, EDtracker, Track IR.

Link to post
Share on other sites

Hey, NineLine.

 

Here's a mission I created today using the mission generator to highlight the bizarre/painful performance issues that crop up in the latest 2.5.6 OB in the SW region of the Persian Gulf map. My frames dropped to as low as 7 FPS and averaged about 15 FPS. What is odd is, when I then pause the game, frames jump up immediately to 55/60 FPS... even with exterior camera panning, trackIR movement, etc. Could you and the team please test? I do not use any mods.

 

Thanks!

 

 

MG TEST.miz


Edited by wilbur81

i7 8700K @ Stock - Win10 64 - 32 RAM - GTX 1070 SC - 4k Display

"I do not love the bright sword for its sharpness, nor the arrow for its swiftness, nor the warrior for his glory. I love only that which they defend."

- Faramir

Link to post
Share on other sites

***Forgot to mention above: this test mission plays beautifully in the latest 2.5.5 Stable branch, averaging about 50 FPS with all the same graphics settings.

i7 8700K @ Stock - Win10 64 - 32 RAM - GTX 1070 SC - 4k Display

"I do not love the bright sword for its sharpness, nor the arrow for its swiftness, nor the warrior for his glory. I love only that which they defend."

- Faramir

Link to post
Share on other sites
I set up a CAS mission over Iran in the Hornet. Flying the mission by myself- butter smooth.

 

I added 1 wingman- and my performance got around halved (Locked at 40 fps). The difference is severe.

 

Meanwhile I can run 20 Bf 109's vs 40 B-17 and run it butter smooth.

 

Something pointing to AI indeed. I can upload the mission if that is useful.

 

I run a pretty solid rig: Gtx 1080ti, 5gz CPU, 32 gigs ram, SSD.

 

Yeah, it's just not the AI literally, it's the models I think, AI controlled or not, static as well.

Getting back in action!

1st.: PC Specs WIP: Win10P 2004 (20H1), 1440p@75"32 - MB: Asus ROG Strix X-570E - CPU: AMD Ryzen ... - GPU: AMD Radeon ... - RAM: 64 GB - SSD: Samsung 970 EVO Plus 1TB NVMe

2nd.: PC Specs: Win10P 2004 (20H1), 1440p@75"32 - MB: Asus P9X79 - CPU: Intel i7 3820 - RAM: 32GB - GPU: AMD Radeon RX480 8GB - SSD Samsung 860 EVO 250GB (DCS), Input: Saitek Cyborg X/FLY5

Modules: A-10C I/II, F/A-18C, Mig-21Bis, M-2000C, AJS-37, Spitfire LF Mk. IX, P-47, FC3, SC, CA, WW2AP.

Terrains: NTTR, Normandy, Persian Gulf, Syria.

Link to post
Share on other sites

This fps drop made this sim unplayable for me. Lowered AA, lowered settings but still my fps drops to 30s and with low as looks horrible. In fact even with high aa it doesn't look very good.

 

By the way I also installed latest 445 driver. And things become worse

FC3 | UH-1H | Mi-8MTV2 | A-10C II | F/A-18C | Ka-50 | F-14A/B | F-16CAH-64

Persian Gulf | Nevada | Syria | NS-430 | Supercarrier // Wishlist: C-130 | UH-60 | F-4E

 

Youtube

Z390 / i5 9400F / RTX3070 / 32 GB Ram / 500 gb SSD and 1 tb HDD // CH Fighterstick - MS FFB2 - TM Warthog Throttle and Stick - CH Pro Pedals - Trackir 4 and 5

Link to post
Share on other sites
This fps drop made this sim unplayable for me. Lowered AA, lowered settings but still my fps drops to 30s and with low as looks horrible. In fact even with high aa it doesn't look very good.

 

By the way I also installed latest 445 driver. And things become worse

 

I rolled back to 441.87 and they got a bit better. Not as good as DCS 2.5.5 but much better than 2.5.6 with the new nvidia driver.

Link to post
Share on other sites
This fps drop made this sim unplayable for me. Lowered AA, lowered settings but still my fps drops to 30s and with low as looks horrible. In fact even with high aa it doesn't look very good.

 

By the way I also installed latest 445 driver. And things become worse

 

nvidia 445.xx series have a serious problem with DCS World, I observed GPU clock throttling happening for no reason during sessions resulting in huge FPS drops, the earlier 442.xx drivers do not suffer from this.

Link to post
Share on other sites

outside view fairly good but inside the cockpit, especially while looking down is horrible

how come?

FC3 | UH-1H | Mi-8MTV2 | A-10C II | F/A-18C | Ka-50 | F-14A/B | F-16CAH-64

Persian Gulf | Nevada | Syria | NS-430 | Supercarrier // Wishlist: C-130 | UH-60 | F-4E

 

Youtube

Z390 / i5 9400F / RTX3070 / 32 GB Ram / 500 gb SSD and 1 tb HDD // CH Fighterstick - MS FFB2 - TM Warthog Throttle and Stick - CH Pro Pedals - Trackir 4 and 5

Link to post
Share on other sites

Awful performance on Open Beta

 

Hello,

 

The last time I played was back in late 2018. Own most of the modules, never had and performance issues when playing DCS. I have a quite powerful computer so I actually never even expected any sort of performance problems, low FPS.

 

A few days ago I bought the F16 module, hoping that it will give me some motivation to return to DCS.

 

However, my initial hopes were immediately ruined by the awful performance. I have to admit I always played the game with all settings maxed out, the only exception is SSAA which I left on 1.5, MSAA is set to off and there is an option I never saw before, called SSLR, which I set to off as well. All else is set to maximum, but again, I never ever encountered low FPS in this game.

 

This is not the case anymore. At Kutaisi airport, on the runway, daytime, in-cockpit I got 30-35 FPS and outside 15-25 only. Up in the air, at FL250, inside the cockpit only 50-60 FPS and when going to exterior view, only 20-25 FPS.

 

But even without the FPS data, I can clearly feel when panning, both inside and outside of the cockpit that it is not as smooth as it used to be. I am using TrackIR and even when looking around, I can feel the inferior performance.

 

I tested with the Gazelle and the F5 as well and I can confirm that the performance is much worse than I was used to in those modules too.

 

I am not too sure what happened to the game during the past year and a half, it looks beautiful but the performance makes it a no-go for me as it currently stands.

 

I am hoping that the game will receive further optimizations so that in-game FPS will soar once again.

Link to post
Share on other sites

I haven't played since late 2018 with a couple of exceptions back in 2019 but now that I wanted to return to DCS I immediately noticed that the performance is much worse than it used to be. I have a quite powerful PC and never in my entire DCS career had to complain about low FPS but this time it is really bad. SSLR off, MSAA off, SSAA 1.5 and all else maxed out but as I said, I always had these settings (minus the SSLR which I have no clue about, probably a new option) and my FPS were always excellent.

So while the game looks really beautiful these days, unfortunately, the performance seems to suffer. I am hoping it will be addressed.

Link to post
Share on other sites

Optimization should be a priority. After flying another sim a few times I can see that DCS needs a lot of work in optimization and netcode.

1st_CVW_EDsig.png.1f2be0eb45d45098d3777965a273c030.png
 

Alienware New Aurora R9 | Windows® 10  64bit, Intel(R) Core(TM) 9th Gen Intel Core i9-9900K | NVIDIA GeForce RTX 2080Ti OC 11GB | 2 X 1TB SSD | 16GB Dual Channel Hyper X FURY at 2666MHz | 850W EPA Gold Liquid Cooled power supply | Oculus Rift S |

Link to post
Share on other sites
I have a massive FPS drop (30-40 fps) when my SA Page at the F/A-18C Hornet is on. If i switch the page to HSD oder something else, my FPS goes up.

 

Same issue. I go from over 60 overly dense areas and 70-80 normal to about 22-30 on opening the SA page on F18 or data linked F16 as well.

Link to post
Share on other sites

I am hoping that the game will receive further optimizations so that in-game FPS will soar once again.

 

Keep hoping.

ED has had a broken sim for months. They know it and they are just letting it skate. As a long time sim guy, I have never seen anyone treat a game breaking bug like this.

Link to post
Share on other sites

Honestly guys, what is the point in ranting on about this. ED have stated often about the WIP regarding this fps issue.

Roll back to 2.5.5 and you'll be OK. Don't use the OB if you're not prepared to be patient.

Intel i9 10900K 5.1GHz · MSI Gaming X Trio RTX 3090 · ASUS ROG STRIX Z490-F · Acer 4K 32" XB321HK · Samsung 970 500Gb M.2 NVMe · 2 x Samsung 850 Evo 1Tb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 10 · Thrustmaster TPR Pedals · TrackIR5 · Thrustmaster F/A-18 Hornet Grip · Virpil WarBRD Base · Virpil Throttle MT-50 CM2 · Virpil Alpha Grip · HP Reverb G2

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...