Jump to content

[REPORTED]2.5.6 Performance


Recommended Posts

It's not about any improvement. The shaders need to be rebuilt and it is a requirement that the changes take place at all.

 

C:\Users\yourwindowsaccountname\Saved Games\DCS.openbeta

 

Find 2 folders named: fxo & metashaders2 and

delete them every time you change settings. There may be settings which don't need the shaders to be rebuilt, like civilian traffic, but I would always do it just to be safe.

 

Ok mate I will give it a go.

I seriously doubt that it will make any difference as I have not changed any settings. I have been running the same settings since installing OB & for the lat 12 month on stable.

Link to post
Share on other sites
  • Replies 538
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

same here, performance is horrible. From my point of view and personal opinion, I sincerely believe that eagle dynamics should focus on seriously optimizing the graphics engine or the base of the

That shouldn't help you with your original problem either. You've turned off the shadows etc. and the FPS didn't improve. So I pointed out

 

 

Tried your settings small improvement in stable no improvement in OB. :cry:


Edited by Cornelius
Link to post
Share on other sites
  • 2 weeks later...

Hello again, finally found the problem with my system performance, it was only my CPU fan was improperly installed. Now I am again enjoying DCS World in VR.

 

I've got some new questions about the VR options. Does anybody know how does "Bloom Effect" and "MSAA mark size" work. I've search on the documentation but no mention to both options.

 

Thanks in advance

My system: i7 9700K @ 3,6 GHz, 32 Gb RAM 2400 MHz, Gigabyte GTX 1080, 240 Gb SSD, Windows 10 64 bits, HOTAS Cougar, VKB Gladiator Pro, Saitek Combat rudder pedals, Cougar MFDs, TrackIr 5.0, Wheel Stand Pro v2, Gametrix JetSeat KW-908, Oculus Rift S

Link to post
Share on other sites

Ever since the July update i've been getting massive micro stutters. Tried everything in the books to clear it up without luck. At this point need to consider it's either DCS or nvidia drivers since i do see GPU spikes

 

 

Here's some of what i tried to work through:

- Removed all background processes + stoped windows anti-virus/malware

- updated to different nvidia drivers (latest 2 drivers)

- Added the following to autoconfig file

options.graphics.maxfps = 60

disable_write_track = true

no_device_hotplug = true

- validated ram usage is under max (currently @ 75%)

- both CPU and GPU usage (cpu = 25%) I do see spikes in GPU usage

- removed scripts/mods to see if it helped remedy the issue

 

 

 

 

Specs:

TrackIR, i9 9900k, RTX 2070, 32GB ram, SSDs, T16000 + fanatec pedals for rudder input

 

 

Observations:

If i pause the mission the stutters go away and i get smooth trackir movement without stutters. Unpause and stutters resume. I also noticed this occurs in heavier missions. If i load a very basic mission with little to no AI seems to run smooth. AVG FPS is around 50-90 FPS but i've attempted to cap @ 60 recently without benefit

Link to post
Share on other sites

Its a mess at the moment . Not happy . Thats all i have too say .

You can mess with your setting for ever wont change a thing just look at the state of people mucking around with setting just to get clear smooth game play . $60 for a module and maps and hardware . Cant even have a decent online experience .

Sniper G1 - Z87 ~ 4690K @ 4.3 - AMD Vega64 - HyperX 32 :GB @ 1866 - Win10 - 64bit Pro - T-50 Mongoose - CM2 Throttle - VKB T-bar Rudders - Trackir5 . I'm a dot .

Link to post
Share on other sites
Its a mess at the moment . Not happy . Thats all i have too say .

You can mess with your setting for ever wont change a thing just look at the state of people mucking around with setting just to get clear smooth game play . $60 for a module and maps and hardware . Cant even have a decent online experience .

 

I have posted in your other thread, if you can give me your log and dcs settings we may be able to suggest some tweaks for you

 

thanks

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites
Its a mess at the moment . Not happy . Thats all i have too say .

You can mess with your setting for ever wont change a thing just look at the state of people mucking around with setting just to get clear smooth game play . $60 for a module and maps and hardware . Cant even have a decent online experience .

 

 

I feel your pain mate. Yes we are paying customers.

Since the last update thing have been much better for me. So I thank ED for their hard work & getting some of the issues fixed.

But I had a month of unplayable OB DCS & that meant No P-47.

Link to post
Share on other sites
Ever since the July update i've been getting massive micro stutters. Tried everything in the books to clear it up without luck. At this point need to consider it's either DCS or nvidia drivers since i do see GPU spikes ...

 

I have the same issue, but I`m sure that is DCS fault. When micro stutters appear my GPU load decrees to 0% and then GPU load increases to 100 %. This happens only in DCS after July patches, in a stable and open beta version of DCS. I`m willing to believe that is my computer fault BUT, other sims like X-Plane, IL-2 Sturmovik run well. There are no fluctuations GPU and micro stutters. GPU load is 98-100%. Other games also work perfectly.

 

This issue is only in DCS, before July`s patches everything works fine in DCS.

 

So I`m tired of checking any configurations in DCS. Till it would be resolved I won`t buy anything from ED and third party for DCS. I know that my voice is insignificant, especially that this issue is random and most users won`t complain. But this shows that DCS is a mess.

 

I have Ryzen 5 3600, RX590, SSD drives in my computer.

Link to post
Share on other sites

Gotta say that it's been running very well for me in VR . Yesterday i experienced one of my smoothest missions ever-this with two flir displays running .

9700k , Aorus Pro wifi , 32gb 3200 mhz CL16 , 1tb EVO 970 , MSI RX 6800XT Gaming X TRIO , Seasonic Prime 850w Gold , Coolermaster H500m , Noctua NH-D15S , CH Hotas on Foxxmounts , CH pedals , RiftS

 

"Hold my beer"

Link to post
Share on other sites

 

 

 

So I`m tired of checking any configurations in DCS. Till it would be resolved I won`t buy anything from ED and third party for DCS. I know that my voice is insignificant, especially that this issue is random and most users won`t complain. But this shows that DCS is a mess.

 

 

 

I have Ryzen 5 3600, RX590, SSD drives in my computer.

 

You're definitely not alone.

I've been buying and playing DCS modules since the original Blackshark, more than 10 years ago.

But now I stopped playing a few months ago. Just tired of spending more time trying to tweak settings to improve VR performance than really enjoying the sim.

My last purchase was the Viper, and I will definitely not buy anything else until performance gets significantly better.

Intel Core i7 6700K@4.7GHz, Asus Sabertooth Z170 Mark1, 16Gb Kingston DDR4 2800MHz, Asus Geforce GTX1080, SSD Sandisk Extreme Pro 250Gb, Seagate 2Tb, TM Hotas Warthog, Ch Pro Pedals, TrackIr 4, Oculus Rift CV1 & Rift S

Link to post
Share on other sites
You're definitely not alone.

But now I stopped playing a few months ago. Just tired of spending more time trying to tweak settings to improve VR performance than really enjoying the sim.

I think VR performance is how the Sim must be measured from now onto the future.

I had a focus on fall 2021 to do what you wrote above: enjoy without messing with configs.

Let´s expect those much needed improvements on the DCS core will do its job.

I think so.

Link to post
Share on other sites
  • 3 weeks later...

I know in beta the FPS can vary as changes are made but I’m flying along and next thing my frame hitches and drops from say 60 to 30 or whatever and the jumps back to 60, this has never happened before. Please sort this out.

4.8 I7, 1080, TMW&T, SSD, VKB MK.IV.

Link to post
Share on other sites

I really wish that performance wise we would have something somewhat stable. Every now and then i have to rejaust the whole settings on my nvidia card and in DCS. i spend more time tweaking than flying. At some point it becomes really really frustrating.

Link to post
Share on other sites

Hi everyone, I just wanted to let you know that GatorNutz and I have just found an important conflict between DCS and the MSI Dragon Center software on his computer.

 

GatorNutz was experiencing very low FPS (around 20-30) on his high-end PC. It appears he had configured DCS in the MSI Dragon Center "Gaming mode" menu with the "Extreme Gaming" option turned on. As soon as he removed DCS from the MSI Dragon Center list, he got his ~140 FPS back!

 

Bascially, DO NOT ADD DCS as a game to be managed by MSI's Dragon Center!!
Link to post
Share on other sites
I spend more time tweaking than flying. At some point it becomes really really frustrating.
You didn't buy MS FS2020 yet didn't you? That will give you hours and hours of tweaking fun...;)

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to post
Share on other sites
I have the same issue, but I`m sure that is DCS fault. When micro stutters appear my GPU load decrees to 0% and then GPU load increases to 100 %. This happens only in DCS after July patches, in a stable and open beta version of DCS. I`m willing to believe that is my computer fault BUT, other sims like X-Plane, IL-2 Sturmovik run well. There are no fluctuations GPU and micro stutters. GPU load is 98-100%. Other games also work perfectly.

 

 

 

This issue is only in DCS, before July`s patches everything works fine in DCS.

 

 

 

So I`m tired of checking any configurations in DCS. Till it would be resolved I won`t buy anything from ED and third party for DCS. I know that my voice is insignificant, especially that this issue is random and most users won`t complain. But this shows that DCS is a mess.

 

 

 

I have Ryzen 5 3600, RX590, SSD drives in my computer.

Same here.

 

Inviato dal mio SM-G960F utilizzando Tapatalk

Link to post
Share on other sites

@PFT_Orph3us, @paranoid: It looks like an external process is bothering your DCS. You should have a go at launching DCS in Windows Safe Mode to see how DCS is doing.

 

I'd like to rule out any influence from external programs. Can you please launch your game in Windows safe mode?

 

Here's how to do it:

 

  1. Press Windows key, type "msconfig" and press Enter.
  2. In the General tab, tick "Diagnostic startup" and click "Apply" (you will see some other boxes get ticked, it's OK).
  3. Click OK and choose to restart your computer.
  4. Log into Windows as usual, then launch DCS. You will get several error messages since your PC network is disabled. Just click OK until you see DCS main menu.
  5. Fly the Su-25T in an instant action mission and watch your FPS counter.

Once you're done with testing, just open "msconfig", tick "Normal startup", click OK and restart your system, and everything will be back to normal.

 

If you want help, feel free to start your own thread.

Link to post
Share on other sites
You didn't buy MS FS2020 yet didn't you? That will give you hours and hours of tweaking fun...;)

 

But I don't have to exit the game everytime I change a setting (except the things you can change while ingame) and delete the fxo and metashader2 folders. So if fs2020 is hour and hours, DCS is days and days...

Link to post
Share on other sites
and delete the fxo and metashader2 folders.
Doesn't bring you anything, you just delete them because some other dude told that he did delete them. So you can already skip that to gain some playing time.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to post
Share on other sites
Doesn't bring you anything, you just delete them because some other dude told that he did delete them. So you can already skip that to gain some playing time.

 

Did some extended Benchmark testing playing with all the settings and without deleting the shaders and restarting, the results doesn't change. And where do you get your knowledge from?

Link to post
Share on other sites

Own experience...:smartass:

 

Never saw a single benefit from deleting them.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to post
Share on other sites

it used to be useful; and still can be if for some reason your cached shaders become corrupt, and you are seeing graphical anomalies, but in most cases today it adds no benefit other than being a time sink

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

Just repeated my benchmark test with changing textures from high to low (edit: and msaa2x to 4x and shadows flat/default) with and without deleting shaders and must admit I stand corrected. About a year ago this was a complete opposite.

Thank you for pointing this out, guys.


Edited by Cornelius
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...