Jump to content

Can’t save controller profiles?!


Recommended Posts

Hello,

 

Recently I installed DCS World together with the F18 and FC3. I’m a long time flight simmer but been away for quite some time. Have a long history with Falcon, Flanker, Lomac, BMS and now with some more time, and more importantly a decent pc I got to DCS installed. Love the looks and feel of dcs but I’m really getting frustrated. The proces of getting different profiles to work for different aeroplanes doesn’t seem to work.

 

I have a Hotas cougar, mfg crosswind rudders, 2 thrustmasters cougars mfds and track ir. In the controller setup: I select the plane, I select key/axis option and assign it (and tune the axis when needed). I do this for all the options. Then I save it with a appropriated name (F18 v2 for example). Sometimes i loose my mfd setting for no apparent reason, or some rudder imput is lost. When I want to load my file again sometimes(?) it says ‘file doesn’t exist’. Indeed some files seems to magically disappear from the input folder. Some profiles are there but don’t load completely.

 

An axtra weird thing is that my rudders in the cockpit don’t reflect the movement outside. So i invert rudder to work correct, but the cockpit rudder pedals (visuals) don’t match the outside view/actual working condition. Weird.

 

It frustrates me, beacause I thought what I did seemed to me the most logical steps but somehow it messes with me.

 

If I don’t touch the controllers or don’t switch from plane everything is working (except the reversed cockpit visuals of my rudders). It even holds me of flying any other plane at the moment.

 

I looked it up on the forums, even tried to delete or rename folders but no succes. Is this a common problem with a common solution?

 

Anybody help?

 

Regards and thanks in advance!

 

Wiwa

Link to post
Share on other sites

Sounds like you've got something else going on, bad USB port causing your controls to not be recognised (I have experienced the vanishing devices myself). The UI is a pita, but it does indeed work. I'd check your ports, maybe use an external powered hub and see if that helps.

 

About the rudder, which aircraft are you experiencing that with? I would recommend running a repair. To my knowledge none of them do that.

 

Note: the F-18 rudders toe in on the ground. They are supposed to do that.

Spoiler

tumblr_inline_mpv4v0zasI1rg41uj.gif

The troll formerly known as Zhukov

Link to post
Share on other sites

Thank you for the quick reply. The game does recognize all my controllers. I do get them to work and use them. But sometimes the game changes my settings. Apparently when i switch some settings or try to load other profiles. What might cause the costum profile files to disappear?

 

The reversed visual cockpit rudder movement is in all aircraft. I reversed the action, they work as they should be, including toe brake, outside visuals match the actual operation. However the cockpit rudder visuals are reversed. But this problem is a little less annoying than the ‘lost profiles’.

Link to post
Share on other sites

TL;DR Ignore the Save & Load profile buttons, just set your controls and click ok bottom right. The Hornet's rudder works as I would expect

 

 

I am quite new, so may not have all the answers but have spent quite some time setting up controls for a number of aircraft with multiple devices.

 

The profile saving is for each individual device for a particular aircraft. When you set up controls and click ok all the device controls are saved as defaults for whichever aircraft you are using. Make sure you click ok (bottom right)

 

The individual device profiles can be saved and loaded allowing you to experiment with new controls for an aircraft and revert to a previous one or copy device profiles to other aircraft where possible.

 

Each device profile gets save in Saved Games\DCS\Config\Input\Aircraftfname

 

You really don't need to worry too much aboutsaving and loading profiles though as all the controls are stored for an individual aircraft you see in the drop down list top left.

 

I just tried the Hornet and it works as expected - push right pedal forward and right rudder is applied. I have Saitek pedals and non-inverted in axis tuning

Intel i5 8600K 4.8GHz · Palit RTX 2080 Ti Gaming Pro · TUF Z370 Pro · HP Reverb Pro · 500Gb M.2 NVMe · 1Tb SSD · 32Gb G-Skill 3200MHz DDR4 · Windows 10 · Thrustmaster TPR Pedals · Thrustmaster Warthog . JetSeat

Link to post
Share on other sites

Aha..that would be great! Thank you for the reply... I’ll forget the save and load functions. Gonna experiment with it this evening... I consider the incorrect visual rudder movement in the cockpit just to be a minor bug...I’ll live with this.

 

Again, thanks!

Link to post
Share on other sites

I’ve had a profile set up for the F-18 that I’ve used for quite some time, and I just recently purchased the F-16. I jumped back into the F-18 last night and it appears my profile settings are all gone. The file is still there but it appears to be empty. I didn’t have enough time to dig into it last night but at the very least, all my HOTAS settings are gone. So this may be related to your issue.

Link to post
Share on other sites

After checking out I can confirm that this was indeed the right method. Just pressing ok did the trick, instead of saving profiles etc. Switching between planes went ok, each plane ‘remembered’ their own settings. Glad to know it works this way, thanks all for your help!

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...