Jump to content

Activation & Other Difficulties

Recommended Posts

I bought Lock on and downloaded it when it first came out. I subsequently bought Lockon Gold when it came out, so I have two copies; Gold is active on my PC.


I haven't had a chance to fly in many months, but last week I fired up LockOn and enjoyed a bit of quick action. Today I tried, but StarForce Activiation wouldn't let me. I had to enter my serial number and reactivate and I got a message that there were only 9 activations left.


After flying for a few minutes, Lockon quit responding to the button imputs from my Saitek X52. I had to CTL/ALT/DEL out of Lockon. Starting Lockon again cost me another activation. The same thing happened though after flying for a moment: I had to CTL/ALT/DEL out when the X52 quit respsonding. Yet another activation later I was flying again, but again the X52 quit responding.


I've used three activations today and haven't completed a flight yet. Does anyone know why I keep having to 'reactivate' Lockon? Why does the X52 keep stalling on me? I have several music players on my machine, Windowblinds too, a couple other minor utilities. All these I Enditall out of before firing up Lockon.


This is a deal breaker for me. If I can't fire up Lockon, a simulation I've legitamately purchased twice, I'm going to have to move on. Any help would be appreciated.


DrafTech <//><

Link to post
Share on other sites

I would bet 10 shillings that your X52 is to blame for your continued activation problem. Have one of those blighters myself, when I start-up Lockon with the slider on full (Right) then the activation screen comes up.


First hint is to calm down, Lock-on itself is not to blame.


Second hint, stop reactivating Lock-on when this happens and investigate what exactly is wrong. If you haven't done anything drastic to your machine (like changed CPU + RAM etc) then the is something simple messing about with your system config like sliders etc. In fact I was able to change graphics card without getting asked for a reactivation.


Hope this helps, old bean. :)


"It is a well known fact that Mr Cholmondley-Warner was the top Spitfire ace during the Battle of Britain." - Winston Churchill

Link to post
Share on other sites

OK, But...


I can accept that the slider and rotaries of the X52 must be set at neutral before starting up LockOn in order to not activate the StarForce protection. I just tried it and LockOn started up with no problem; thanks.


But, after I'd been flying for five minutes the X52 and keyboard quit responding again; I had to CTL/ALT/DEL to get out of the mission. Why does that keep happening?


Draftech <//><

Link to post
Share on other sites

Concerning poping up StarForce reactivation. Looks like shift or ctrl keys were held down while launching LO. The simplest explanation is your joystick profile of SST. May be you have assigned some modifier keys or key combinations with them to some axis or mode switcher.


And about input devices failure. What keyboard do you have? Is it the Saitek? Does it's profile software installed?

929d768ca6a69127d1f9c61ea94c02e8.gif [sIGPIC][/sIGPIC] =653=Tez
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...