Jump to content

BALT/HSEL strange behaviour


GauSki
 Share

Recommended Posts

I have noticed that BALT and HSEL seem to be behaving very strange for me half the time.

 

My understanding is that normally BALT should hold heading and altitude if activated with less than 5deg bank and should hold bank angle and altitude if there is more than 5 deg of bank angle. HSEL mode can be activated at the same time as BALT to hold/turn to a selected heading.

 

I make sure that I am activating the autopilot modes with zero stick input (verified in axis commands options section) and I always disengage the autopilot using the nosewheel steer disengage/g-limit override button, also with zero stick input.

 

Half the time, this works as intended. However about half the time I get very strange behaviour:

 

- When flying in trimmed level flight and BALT is activated, the aircraft slowly departs into a right or left hand turn. The autopilot maintains altitude but the bank angle slowly and steadily increases until the bank limit causes the autopilot to disengage altogether.

 

- When HSEL is activated, nothing happens. The aircraft wont turn to a heading or hold a heading. If BALT is already active and you try to manually turn towards the HSEL heading, sometimes its as though the autopilot suddenly "wakes up" and initiates a turn towards the selected heading, but does not roll out... just keeps turning and maintaining altitude.

 

These symptoms seemed to be linked and I can't understand what cause is. Sometimes the autopilot system isn't working for the first half of a mission and randomly starts working half way through and vice versa. Sometimes it goes between working and not working several times during a mission. It doesn't appear to need user input to stop or start working..it just... happens..

 

I've noticed in certain missions/campaigns are much more prone to this happening, my inkling is that asymmetrical loadouts/states requiring aileron trim to fly straight and level are a factor.

 

 

Anyone else having these issues? :doh:


Edited by GauSki
Link to comment
Share on other sites

The snippet below would seem to indicate the need to select a lateral mode prior to BALT selection if you want lateral control.

 

BALT.jpg

 

Personally I select HSEL, engage ATC then select BALT with good results

 

 

 

Yup, I've seen this before so I test it nearly every flight. When it works it seems to work in whatever order you choose and when its broke its broke regardless of order also. :(

 

thanks for the idea though!:thumbup:

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...