Jump to content

Thrustmaster TPR Pedal sensitivity !!!


Recommended Posts

Hi All,

Am i the only one having probs in this area. I love these pedals, they feel so smooth but No matter what i do I can't seem to adjust the sensitivity. I only have to move the pedals !/2 an inch either way from centre and i'm at full rudder. Does anyone have any tips or settings for curves on the axis settings. I've looked on line and all I can find is everyone raving about how good they are but nothing about my problem, Firmware is up to date, calibrated using thrustmasters tool, although they do not make sense. According to them once you have calibrated to save the setting you have to unplug the pedals. But when I plug them back in i'm taken back to square one again. Any help would be appreciated before I pull the last of my hair out. LOL :helpsmilie:

Link to post
Share on other sites

Not sure why you’re getting this. Mine were fine right out of the box. Does it show this full deflection problem in dcs and windows? Don’t calibrate through windows but you can check the movement

Link to post
Share on other sites

Hi Chief

seems fine when i check movement in windows, it's the thrustmaster calibration tool that i'm concerned with as there are no actual instruction. They always forget that we're not all wizz kids and boffins. Yes it's bad in DCS even with a massive curve. literally 1/2" or 15mm movement and it's full rudder, In a chopper I can spin like a whirligig toy. I find it strange to have so much movement in the pedals whereas I only need half an inch in either direction. thanks for the reply though.

Link to post
Share on other sites

If TM calibration tool doesn't work, try to work around it in DCS settings. Bring up the Axis visualizer in DCS when you fly and start changing parameters from there. Put a heavy S-curve on it like 30, and reduce Y saturation to very low number like 30%, then go from there.

 

If your brake axis is stuck at 10-15% when in neutral position, then put a negative slider curve (not the S-curve) on it like -50.


Edited by Supmua

PC: 9900K/3090, 32GB RAM.

Joystick bases: TMWx2, VPC WarBRD, MT50CM2, VKB GFII, FSSB R3L

Joystick grips: TM (Warthog, F/A-18C), Realsimulator (F-16SGRH, F-18CGRH), VKB (Kosmosima LH, MCG, MCG Pro), VPC MongoosT50-CM2

Throttles: TMWx2, Winwing Super Taurus, Logitech Throttle Quadrant, Realsimulator RS Linear Throttle (soon)

VR: HTC Vive/Pro/Pro 2, Oculus Rift/Quest 2, Valve Index

Link to post
Share on other sites

Mt TPR works great and I never calibrated it. In the windows driver it was well centered and had full deflection on all three axis right out of the box. Just had to do a firmware update via the windows driver. I don't see any way to calibrate the pedals in the windows driver. I have never opened any TM calibration tool. I don't use any curves etc. in DCS. Just an extension on the warthog joystick. The TPR pedals seem to have a nice built in curve in their action. My experiences with the TM tools has been that they are not worth the trouble to use. My guess is the TM tool has added some gain in your signal and you need to undo it and go back to the out of box state. I would think that just exiting the TM tools would do the trick but be sure it is not running in the background after you close the window. I don't have any experience with the tool your are talking about but they usually need to be running in order to affect the controller.

 

 

good luck

slyfly

Link to post
Share on other sites
Or just say piss on the TM calibration and try doing it through Windows. Afterall is just a rudder axis and brakes. You aren't gonna do anything that can't be undone

 

Don't do that, you will definitely will have issues in DCS.

Twitch Channel

 

[sIGPIC][/sIGPIC]

Virtual Thunderbirds, LLC | Sponsored by Thrustmaster

 

Z390 Aorus Xtreme, i9 9900k, G.SKILL TridentZ Series 32GB, 1080ti 11GB, Obutto R3Volution, Thrustmaster HOTAS Warthog, TPR, Cougar MFDs, FSSB R3L, JetSeat, Oculus Rift S, Buddy-Fox A-10C UFC, F/A-18C UFC, Tek Creations F-16 ICP

 

Link to post
Share on other sites
Hi All,

Am i the only one having probs in this area. I love these pedals, they feel so smooth but No matter what i do I can't seem to adjust the sensitivity. I only have to move the pedals !/2 an inch either way from centre and i'm at full rudder. Does anyone have any tips or settings for curves on the axis settings. I've looked on line and all I can find is everyone raving about how good they are but nothing about my problem, Firmware is up to date, calibrated using thrustmasters tool, although they do not make sense. According to them once you have calibrated to save the setting you have to unplug the pedals. But when I plug them back in i'm taken back to square one again. Any help would be appreciated before I pull the last of my hair out. LOL :helpsmilie:

 

Uninstall the drivers, device, and select a different USB point. Out of the box the rudders shouldn't need any calibration. What ever you do, do not use the windows calibration tool, it definitely messes up the throw in DCS. If you have done that, go in and delete the calibration by "resetting" the calibration under the windows controller panel.

 

If you must use the TM tool, did you start the program with all the TM devices unplugged? Seems a lot of people miss that important step. When you unplug them the second time the program should continue on. Sounds like you missed a step along the way.

Twitch Channel

 

[sIGPIC][/sIGPIC]

Virtual Thunderbirds, LLC | Sponsored by Thrustmaster

 

Z390 Aorus Xtreme, i9 9900k, G.SKILL TridentZ Series 32GB, 1080ti 11GB, Obutto R3Volution, Thrustmaster HOTAS Warthog, TPR, Cougar MFDs, FSSB R3L, JetSeat, Oculus Rift S, Buddy-Fox A-10C UFC, F/A-18C UFC, Tek Creations F-16 ICP

 

Link to post
Share on other sites

I recived my TPR unit today, and after it assembled, I just plugged in the USB and tried the Mustang, no TM software, no callibration, I went straith to the Batumi Takeoff mission and everthing was perfect (just had to set the correct axis for the brakes and rudder). Remove everthing that you installed and try one more time man.:thumbup:

Intel 8700K@4.7ghz(all cores) / 32Gb DDR4 /WD Black SN750 Heatsink 500gb (DCS Only) / MSI GeForce RTX 2070 GAMING Z 8G / Windows 10 PRO / VPC WarBRD Base + Warthog Stick + Foxx Mount / Thrustmaster TPR pedals / Thustmaster MFD / Thrustmaster Warthog throttle + Monstertech chair mount

Link to post
Share on other sites
  • 1 month later...
Uninstall the drivers, device, and select a different USB point. Out of the box the rudders shouldn't need any calibration. What ever you do, do not use the windows calibration tool, it definitely messes up the throw in DCS. If you have done that, go in and delete the calibration by "resetting" the calibration under the windows controller panel.

 

If you must use the TM tool, did you start the program with all the TM devices unplugged? Seems a lot of people miss that important step. When you unplug them the second time the program should continue on. Sounds like you missed a step along the way.

 

 

When you say TM tool, you mean the TM calibration program? Whenever I plug my TPR in the three vertical columns are shaking like michael J Fox

Link to post
Share on other sites
  • 1 month later...

Yea all the way down on both, it's more noticeable the further you deflect. But no matter the position it kind of dies near center because that's just springs. If they were mounted on the outside of the scissors not the inside and pulled against each other the off center feel would be better, but they'd also wear out much quicker since they would be under tension at rest.

 

You may want to find a smaller higher rate spring that at center would already have a bit of tension on it.

 

For just stiffer overall you can try one of the Motorcycle steering damper mods which increases resistance to movement.

Link to post
Share on other sites
  • 4 months later...

Hey all

 

 

Just installed my TPR pedals and they are just awesome, really love them!

 

 

 

After installing they seem to work fine and the toe brakes work well. However I can't steer the hornet on the ground, it always makes a left turn in a circle and I can't steer to the right side.

 

 

 

Any idea what is getting wrong?

Link to post
Share on other sites

Check that another axis isn't also mapped to your rudder. DCS does a fabulous job of auto-assigning random controllers including xbox controllers to anything it thinks is important.

Twitch Channel

 

[sIGPIC][/sIGPIC]

Virtual Thunderbirds, LLC | Sponsored by Thrustmaster

 

Z390 Aorus Xtreme, i9 9900k, G.SKILL TridentZ Series 32GB, 1080ti 11GB, Obutto R3Volution, Thrustmaster HOTAS Warthog, TPR, Cougar MFDs, FSSB R3L, JetSeat, Oculus Rift S, Buddy-Fox A-10C UFC, F/A-18C UFC, Tek Creations F-16 ICP

 

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...