Jump to content

Frame Rate Stutters While Powered On


Recommended Posts

Good evening.

 

I've experienced massive stutter and freeze of the sim using NS430 in the Persian Gulf map, using terrain mode, expecially when i use high range map (range up).

 

I think is connected with terrain representation when i fly lower than surrounding mountain (with yellow and red obstacles).

 

Problems disappear when i lower map range.

 

Anyone experienced this?

I5-7600K@4,8Ghz - G Skill TridentZ 16Gb 3200 CL14 - Aorus GTX 1080TI - Samsung 950 PRO 512GB NVMe M.2 PCIe 3.0 x4 - Lenovo 24'' 1440p - Hotas Warthog - TrackIR 5

 

DCS 2.5 OB - M2000C - Mig21Bis - A10C - FC3 - AJS37 Viggen - F5E - AV8B N/A - F/A18 C - L 39 Albatros - Bf109 - Spitfire - P51D - Black Shark 2 - Nevada - Persian Gulf - Normandy

Link to post
Share on other sites

I was actually just on the way to post this bug.

 

Basically the heightmap was not meant for anything that can fly faster than the MI-8. I noticed the MiG-21 in particular experiences massive freezing and stutters when the GPS is either in moving map mode or heightmap mode in multiplayer. The problem gets worse the faster you fly as it has to preload in more terrain and I'm guessing that messes with the client sync.

 

This is not just in PG, either. I was having this happen in Caucauses earlier as I flew further north. If you stay within the radius of its moving map, it's fine. But as you move out to the outer ranges, that's when the problems arise.

 

Definitely, definitely needs a more efficient terrain loading algorithm now that every plane can use it. It's only usable now in short bursts, but should be turned off ASAP to prevent stutters. Which is a shame because I was thinking of using it as a replacement for navigation modes in a lot of these planes where you can't put in INS waypoints like the FC3 aircraft.


Edited by Auditor
Link to post
Share on other sites

I talked about Persian Gulf because it's the only map i tried today.

 

So this problem is common with all maps.

I5-7600K@4,8Ghz - G Skill TridentZ 16Gb 3200 CL14 - Aorus GTX 1080TI - Samsung 950 PRO 512GB NVMe M.2 PCIe 3.0 x4 - Lenovo 24'' 1440p - Hotas Warthog - TrackIR 5

 

DCS 2.5 OB - M2000C - Mig21Bis - A10C - FC3 - AJS37 Viggen - F5E - AV8B N/A - F/A18 C - L 39 Albatros - Bf109 - Spitfire - P51D - Black Shark 2 - Nevada - Persian Gulf - Normandy

Link to post
Share on other sites
  • 3 weeks later...

Performance with the Pop-Up window

 

Hello,

 

It seems that on the Persian Gulf map, when trying to access to the moving map or the altitude map on the NS430, the game stutters/freezes completely for minutes sometimes.

 

Also the F10 map runs very slow when the NS430 is in use.

 

Doesn't seem to be an issue on the Caucasus map.

 

I'm running DCS on a known good SSD and 16GBs of RAM.

 

Regards,

Rex

 

P.S. : I've been doing other tests the whole day, will get some tracks tomorrow :)

 

EDIT : Not just a Persian Gulf issue.


Edited by Rex854Warrior

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

Here is a track, when I access the map or the altitude map, it loads and freezes the game, the map for some reason doesn't load at all but still freezes my game when zooming in and zooming out completly for the first time, after that it's mostly fine, it just isn't there.

 

The F10 map is unusable, all of the grid numbers, town names,... appear when zooming out and it's lagging like hell.

 

This happens on all terrains, the freezes when loading the map in the air are alot worse then when on the ground and my luck at getting the moving map to appear on the NS430 is pretty limited, I almost always fly without.

NS430WdwPGProblems.trk

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

My Rig :

 

I7-8700K Stock

ASUS STRIX Z-370E Board

16GB of RAM running at 2133Mhz

GTX1080 FE

 

All of this running DCS at 3440x1440 with everything to the maximum except AA and preload radius.

 

OB and release versions are running on a SATAIII SSD.


Edited by Rex854Warrior

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
  • 3 weeks later...

Is no one else experiencing multiple minute long freezes when loading the NS430 maps ? And that's when they load because sometimes nothing at all appears. Is no one else noticing that with the NS430 pop-up window in use, the F10 map grids all appear all of the time and cause horrible FPS on the F10 map ?

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

The freezes are worse with the Terrain map, after flying for a while, the freezes are every second when climbing or descending into altitudes you have not been to before in this area, and the freezes last longer then a second so the only way to get out of them is to back to a level where the terrain height was loaded, or to just let the helicopter, aircraft crash.

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
  • 2 weeks later...
The freezes are worse with the Terrain map, after flying for a while, the freezes are every second when climbing or descending into altitudes you have not been to before in this area, and the freezes last longer then a second so the only way to get out of them is to back to a level where the terrain height was loaded, or to just let the helicopter, aircraft crash.

 

 

 

Sam problems. 6700k, 32gb ram and 1070 gtx.

Link to post
Share on other sites
  • 1 month later...

I posted this bug on the wrong thread but it happened to me too. As soon as you are setting up the terrain mode, fps drops to something between 1 and 4. Haven't seen that in Caucasus. It is very obvious that only the terrain mode is causing the problem since as soon as you are setting up any other page on the NS430, the fps goes back to normal.

Tested on an Mi8 on PG map near Khasab (lots of mountains around).

Link to post
Share on other sites

The stutters come from the need for swapping when DCS uses all your RAM to load the height map. If the height map needs to be reloaded (pretty much all the time except if you are in a perfect, level flight and also if new terrain comes on the NS430 screen) you'll have a stutter every second until it is loaded. The bigger the scale the longer the stutters get. It is particularly bad on servers like Blueflag, where if you are not carefull you might end up with what looks like a frozen game after starting a climb because your height map is loading and your computer can't keep up.

 

https://forums.eagle.ru/showthread.php?t=218095

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
Thanks Rex.

Considering that my SSD is an Samsung 970 Pro Nvme, 32Gb RAM and 11Go VRAM on a 2080Ti, and still drop to 1 to 4 fps, one cannot really consider this is a normal behavior, no? I can't imagine how it looks like with a 5400 rpm HDD if so much swapping is required for this mode.

 

I myself have a 960 M.2 ssd for swapping but only 16gb of ram and when I start a climb in my Mi-8 on blueflag with the heigh map on a 10nm scale, it just kills my game, last two times it happened to me I had to wait for my helicopter to crash for the frames to come back.

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

The graphical bugs while using the NS430 are not a priority, no tester has reported or commented on the massive stutters that occur while using the NS430 heigh map particularly but also when using the moving map and nothing is being added in terms of navaids for the NS430.

Is the NS430 being worked on ?

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
  • 2 months later...

please ED try to optimize I have stuttering near 30 seconds or so (loading terrain), specially with shadows on (even only with own plane´s shadows). Inexistant in other maps (Nevada or Caucasus). Can we have any idea of when VR optimization will be available?

Link to post
Share on other sites
  • 1 month later...

I'll add a track*, as I haven't seen one posted elsewhere.

 

So this problem is common with all maps.

 

I'm only seeing it in the Persian Gulf (opening extra view ports for the NS430 does drop 10 fps but nothing as bad as in the Persian Gulf, with the Terrain map displayed).

 

Testing the 2D NS430 with the F-5E at Khasab with the 'Terrain' page displayed,

 

• I'm seeing large stutters and freezes associated with frame times of upto 3,957ms i.e. 4 seconds, of which 3934ms is 'simulation'.

 

doing the same but flying through the Caucasus mountain valleys north of Kutaisi -

 

• I see typical frame times of 20ms, of which 2.5ms is 'simulation'.

 

Using NS430 while displaying the 'moving map' page in the Persian Gulf, gives similar 3ms 'simulation' frame times but valley flying has occasional minor stutters.

 

Tested DCS Open Beta 2.5.4.27430

 

* Track file removed as replay F-5 gets stuck on taxiway in DCS Open Beta 2.5.4.30038, see this NS430 Caucasus report for a similar track file.

1821912509_NS430TerrainPerformanceF-5EKhasab2_5_4_27430Screen_190216_001806.thumb.jpg.2e82993f644bb33b0368e93765c7e9bf.jpg

261165565_NS430TerrainPerformanceF-5EKutaisiScreen_190216_005658.thumb.jpg.d50b4097dd95631ec81d220dd1f0e5c1.jpg


Edited by Ramsay
Remove track - it no longer plays correctly in 2.5.4.30038

i9 9900K @4.7GHz, 32GB DDR4, RTX2070 Super 8GB, 1TB NVMe, 6+4TB HD, 1+1TB SSD, MSFFB2 joystick, X52 Pro Throttle, TIR5, Win 10 Pro x64, 1920X1080

Link to post
Share on other sites
  • 2 months later...

[REPORTED]Frame Rate Stutters While Powered On

 

I first noticed this using the NS in the A-10A so I recorded the track on the same mission but in an air start F-5. The stutters in frame rate occur only when the NS-430 is powered on. The pop-up panel does not need to be on the screen for them to occur. If the panel is visible but the NS is powered off, there are no stutters.

 

I did not suffer stutters when testing this on a mission that is empty except for my aircraft, so I suspect my computer, old as it is, is able to cope with whatever the problem is.

 

This problem with the NS powered on has also been noted on my brother's far superior computer, though I do not have a track from that machine that is small enough to be uploaded.

 

Hopefully tracks are able to demonstrate the problem, I am unsure if they work on performance issues like this rather than control issues.

NS-430 Framerate Stutters.trk

Link to post
Share on other sites

First time I opened DCS to record the track it didn't inform me of the update today so I just patched it and recorded another track on the new version of Open Beta. The stutters occurred while the NAVterrain page was selected, the panel did not have to be open for them to occur. I admit I did not test every page in the track as I have other things I need to take care of right now (bad science, I know), but hopefully this gives the developers a place to start.

NS-430 Framerate Stutters 2.trk

Link to post
Share on other sites
  • NineLine changed the title to Frame Rate Stutters While Powered On
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...