Jump to content

Oculus Rift S With DCS World Discussion


Recommended Posts

Performance was never an issue with mine. It ran at 40 FPS all day long and even 80 FPS a lot of the time. My friend has a rig running a 2080Ti, 32gb RAM and a CPU running nearly 5ghz and he doesn’t get any better performance than me. It’s the ASW artifacts and the general degradation of the graphics that I couldn’t live with. You certainly don’t need 32gb RAM and a 2080Ti to make VR in DCS absolutely amazing. It doesn’t matter what hardware you throw at it, you cannot run any VR headset without motion reprojection and with that comes a lot of artifacts, ghosting etc, that broke the immersion for me.

 

I have to agree with this, whilst the op is correct of course the better pc you have the better experience you will have for the most part however I also had decent performance it was never really about that but more about the actual headset and screen tech.

 

For the record also i didn't hate the VR experience, and for the money, the rift s is a brilliant bit of kit for DCS just as long as you're not expecting too much.

Link to post
Share on other sites
  • Replies 2.3k
  • Created
  • Last Reply

Top Posters In This Topic

Certainly can for 2D as I limit mine to 60fps to make TrackIR smooth, but I’m not sure it works like that for VR...I’ve never tried it.

 

No, VR with Rift S uses it's own limiter. 80 fps for non ASW (max), 40 fps when ASW kicks in. With ASW in will go in between, but may induce stuttering particularly visible when down low over the terrain.

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites
  • 2 weeks later...

Do you need to use Oculus Tray Tool to disable ASW or can you do it in the Oculus software?

I don't use Steam, I'm running DCS stand alone set to open in VR automatically, which automatically opens the Oculus software in the background.

I've tried OTT but didn't notice any performance improvements no matter what settings I applied. In fact, I found the image quality in VR to look worse, so I uninstalled it as it just seemed like another unnecessary background process to have running.

I would like to try disabling ASW though to see if it improves the ghosting.

i7-3770 CPU, 32GB DDR3 RAM, Sapphire AMD Radeon 5700 XT, Oculus Rift S

Link to post
Share on other sites
Do you need to use Oculus Tray Tool to disable ASW or can you do it in the Oculus software?

I don't use Steam, I'm running DCS stand alone set to open in VR automatically, which automatically opens the Oculus software in the background.

I've tried OTT but didn't notice any performance improvements no matter what settings I applied. In fact, I found the image quality in VR to look worse, so I uninstalled it as it just seemed like another unnecessary background process to have running.

I would like to try disabling ASW though to see if it improves the ghosting.

 

To disable ASW you can use CTRL + Num 1 - I think anyway. Certainly CTRL + Num 1 to 4 changes the ASW settings.

i7 8700k @ 5.0ghz. Strix GTX1080Ti. 32GB RAM @ 3600. 2x Hyper X SSD’s with DCS on one. Oculus Rift S. Asus PG278-QR. Liquid Series PC with liquid CPU and GPU cooling.

Link to post
Share on other sites
Do you need to use Oculus Tray Tool to disable ASW or can you do it in the Oculus software?

I don't use Steam, I'm running DCS stand alone set to open in VR automatically, which automatically opens the Oculus software in the background.

I've tried OTT but didn't notice any performance improvements no matter what settings I applied. In fact, I found the image quality in VR to look worse, so I uninstalled it as it just seemed like another unnecessary background process to have running.

I would like to try disabling ASW though to see if it improves the ghosting.

 

Keyboard shortcuts:

 

Control-Numpad1: Disables ASW and returns to the standard rendering mode.

Control-Numpad2: Forces apps to 45Hz with ASW disabled. Depending on the application, you are likely to experience judder.

Control-Numpad3: Forces apps to 45Hz with ASW enabled. Enabling and disabling ASW will help you see the effects of ASW.

Control-Numpad4: Enables ASW. ASW will automatically turn on and off, depending on whether the app maintains a 90Hz frame rate. This will be the default rendering mode when ASW is officially enabled in the runtime.

 

Or you can set in the Oculus Debug Tool.

Or you can use Oculus Tray Tool where you can set a game profile along with the SS to apply for it.

I use the OTT for this.

 

For Rift S, the above HZ listed would be 40Hz and 80Hz, rather than 45 and 90 of Rift CV1.

You can read more about Oculus ASW here: https://developer.oculus.com/documentation/pcsdk/1.9/concepts/asynchronous-spacewarp/

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites
Do you need to use Oculus Tray Tool to disable ASW or can you do it in the Oculus software?

I don't use Steam, I'm running DCS stand alone set to open in VR automatically, which automatically opens the Oculus software in the background.

I've tried OTT but didn't notice any performance improvements no matter what settings I applied. In fact, I found the image quality in VR to look worse, so I uninstalled it as it just seemed like another unnecessary background process to have running.

I would like to try disabling ASW though to see if it improves the ghosting.

 

If you disable ASW you might find the frame rates are still good but it’ll stutter. Certainly happens in my case. The only way to get it to run smooth was with ASW on (well, on auto) and it flicked between 40 & 80 FPS. When it ran at 40 with ASW it induced horrible artifacts and ghosting....however, and here’s the weird thing, when it flicked up to 80 FPS it then switched ASW off and it was perfect, although when I tried disabling ASW completely (ie not run it on auto) the frames were great but it stuttered like crazy. It annoyed me so much that I’m back to TrackIR.

If you have any better results then I’ll be interested to hear.

 

*I tried every method too, OTT, without OTT etc etc.*

I also found it worse in the Viper because of its glass canopy. For example, when it was running ASW @ 40fps and you looked ahead and manoeuvred hard in say a dogfight, the horizon flickered and it bugged the living shit out of me. Wasn’t so bad in the Hornet because of the canopy bar that blocked a lot of it. Basically ASW is good, does what it says, but has some horrible side effects that I couldn’t live with.

If anyone can tell me a way to run the Rift S @ 40fps without ASW on and still smooth then I’m all ears!

In the meantime I’m enjoying DCS on my monitor and TrackIR and to be honest, it looks stunning now after all the updates. But.....I’m missing the immersion!


Edited by 30mikemike

i7 8700k @ 5.0ghz. Strix GTX1080Ti. 32GB RAM @ 3600. 2x Hyper X SSD’s with DCS on one. Oculus Rift S. Asus PG278-QR. Liquid Series PC with liquid CPU and GPU cooling.

Link to post
Share on other sites

Had quite a bit of an issue after the update to 18.0.

On the first run of DCS, all fine but if i then would quit and reload DCS, Rift S would show orange led inside after a while, would lose tracking and go black a bit later. Got the message the Rift S lost tracking (i noticed that) and that the display cable was not fitted correctly. However, unplugging directly resulted in the same message again (so it was fitted). Also it was often not possible to close Oculus software, only possible through the task manager. And even then, after a reload of the Oculus software, same story.

The only way to solve was to reboot. But then, first run in DCS all fine, second run same problem.

In the end i uninstalled, removed all Oculus stuff in the Users/Appdata, rebooted and re-installed the Oculus software. All is fine again now.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to post
Share on other sites
If you disable ASW you might find the frame rates are still good but it’ll stutter. Certainly happens in my case. The only way to get it to run smooth was with ASW on (well, on auto) and it flicked between 40 & 80 FPS. When it ran at 40 with ASW it induced horrible artifacts and ghosting....however, and here’s the weird thing, when it flicked up to 80 FPS it then switched ASW off and it was perfect, although when I tried disabling ASW completely (ie not run it on auto) the frames were great but it stuttered like crazy. It annoyed me so much that I’m back to TrackIR.

If you have any better results then I’ll be interested to hear.

 

*I tried every method too, OTT, without OTT etc etc.*

I also found it worse in the Viper because of its glass canopy. For example, when it was running ASW @ 40fps and you looked ahead and manoeuvred hard in say a dogfight, the horizon flickered and it bugged the living shit out of me. Wasn’t so bad in the Hornet because of the canopy bar that blocked a lot of it. Basically ASW is good, does what it says, but has some horrible side effects that I couldn’t live with.

If anyone can tell me a way to run the Rift S @ 40fps without ASW on and still smooth then I’m all ears!

In the meantime I’m enjoying DCS on my monitor and TrackIR and to be honest, it looks stunning now after all the updates. But.....I’m missing the immersion!

 

I had only a quick free fight the other night in the M2000 on the Caucasus map. I tried all Ctrl+Number pad 1-4; I didn't notice any difference in FPS between any of them (I get around 40FPS in all four), but I'm sure there was no ghosting when I used Ctrl+Number pad 1 (ASW off). It was only a quick impression though using the F3 flyby view. I will need to do more flying to be sure.

i7-3770 CPU, 32GB DDR3 RAM, Sapphire AMD Radeon 5700 XT, Oculus Rift S

Link to post
Share on other sites
I had only a quick free fight the other night in the M2000 on the Caucasus map. I tried all Ctrl+Number pad 1-4; I didn't notice any difference in FPS between any of them (I get around 40FPS in all four), but I'm sure there was no ghosting when I used Ctrl+Number pad 1 (ASW off). It was only a quick impression though using the F3 flyby view. I will need to do more flying to be sure.

 

Interesting. I’ve also read reports from people on here who have been able to switch ASW off completely and run it absolutely fine with no stuttering. I most certainly can’t and also a friend of mine with a similar PC to me but running a RTX 2080Ti and also a CPU @ 5ghz, also can’t run with ASW off. Very strange. See how it goes mate....

i7 8700k @ 5.0ghz. Strix GTX1080Ti. 32GB RAM @ 3600. 2x Hyper X SSD’s with DCS on one. Oculus Rift S. Asus PG278-QR. Liquid Series PC with liquid CPU and GPU cooling.

Link to post
Share on other sites
Interesting. I’ve also read reports from people on here who have been able to switch ASW off completely and run it absolutely fine with no stuttering. I most certainly can’t and also a friend of mine with a similar PC to me but running a RTX 2080Ti and also a CPU @ 5ghz, also can’t run with ASW off. Very strange. See how it goes mate....

 

 

I run with it off and no stutters at all and I’m on an old rig running an i5 3570k and vega64. I get 35-60fps single player and 30-40 multiplayer. ASW completely ruins it the odd time I’ve turned it on because of the ghosting.

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites
I run with it off and no stutters at all and I’m on an old rig running an i5 3570k and vega64. I get 35-60fps single player and 30-40 multiplayer. ASW completely ruins it the odd time I’ve turned it on because of the ghosting.

 

 

Sent from my iPhone using Tapatalk

 

Yeah the ghosting is awful and it ruined the immersion for me. Once it flicked to 80fps and it auto shut down ASW things were perfect but when I manually switch ASW off it stuttered like crazy. Very odd and for the life of me couldn’t work out why it was doing it. :doh:

i7 8700k @ 5.0ghz. Strix GTX1080Ti. 32GB RAM @ 3600. 2x Hyper X SSD’s with DCS on one. Oculus Rift S. Asus PG278-QR. Liquid Series PC with liquid CPU and GPU cooling.

Link to post
Share on other sites

If it's useful, these are the settings I'm using btw, with the system specs in my sig. I could turn down the eye candy a bit to get higher FPS but I only have the time to play mostly simple Instant Action missions, so I like to turn up the eye candy as mush as possible. I'm sure I'd have to turn some of the settings down if I played online or heavier missions. I can even just about play missions on the channel map with these settings, although my FPS does take a big drop on that map.

 

ROwhYCy.jpg

 

 

iVqVaF9.jpg

i7-3770 CPU, 32GB DDR3 RAM, Sapphire AMD Radeon 5700 XT, Oculus Rift S

Link to post
Share on other sites

This latest PTC update killed DCS performance, GPU utilisation of 10-20% almost all the time, stuck in 20fps mode and I can't seem to fix it. I've gone back to stable release (v18?) but thats just as bad, and now I cant get back to the release I was using as if I try with Win10 sysRestore then the Rift bricks itself ><

 

Anyone foun d this, or better yet, found a solution?

Developer of XSAF::Camelot  A MoDC with custom GOAP AI model and full custom ground up code

over 1500 members two 24/7 servers and a regular structured op on the weekend

Discord: PravusJSB#9484   twitch.tv/pravusjsb  https://www.patreon.com/XSAF  https://discord.gg/pC9EBe8vWU

Link to post
Share on other sites

@ Topo,

 

I am running the steam edition in Steam VR now.

I was running VR Oculus in DCS steam edition aswell.

 

Again I do not know why the big improvement i coming from.

 

The only small issue is during loading a mission.

THe screen start to "flikker" at a high frequency.

From the moment the mission is loaded the "flikker" stops.

 

Dr Hippo

Link to post
Share on other sites

Oculus Rift S With DCS World Discussion

 

I changed from Oculus to Steam VR and that improved a lot in performance. I have no idea why.

 

 

 

How do you that?i tried with skatezilla utility, but still DCS starts with oculus software

Vincent "Virus" DThe

PC: R9 5900x/RTX2080Ti, 64GB RAM.

Joystick bases: Virpil T-50CM2 with 20cm extension (Center)

Joystick grips: Realsimulator F18

Throttles: Winwing Super Taurus

Hardware: Saitek Combat Rudder, 4x Thrustmaster Cougar MFD, Logitech G13, Winwing Panels

VR: Valve Index 

Monitor: Samsung Odyssey G5, TrackIr v5

Link to post
Share on other sites
I changed from Oculus to Steam VR and that improved a lot in performance. I have no idea why.

 

That makes no sense unless maybe Steam VR on adaptive scaling perhaps.

I mean think about it , instead of going through the Oculus runtime alone you are going through Steam VR runtime - Oculus runtime - Headset.

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites

@VirusAM

 

In steam I enable Steam VR

In the steam library i lanch DCS.

Steam asks me the if I want to run it normal, using steam vr or using oculus vr.

 

Just pick steam vr!

 

@dburne,

I can not explain it why, I always play DCS with a friend. He uses VR aswell and we both experience the same. Improvement after switch from oculus to steam VR.

 

Have a nice day

Link to post
Share on other sites
  • 2 weeks later...

when I´m flying over Nevada, the detail of the roads around my aircraft is fine, but at some distance, it becomes too blurry and fades.

Then I use VR Zoom, and those same blurry roads get detailed again.

 

What´s the graphical setting which controlls this? is it from Oculus, DCS or Nvidia settings?

i5 8400 | 32 Gb RAM | RTX 2080Ti | Virpil Mongoose T-50 base w/ Warthog & Hornet sticks | Warthog throttle | Cougar throttle USB | Virpil desk mount | VKB T-Rudder Mk IV | Oculus Rift S | Buddy-Fox A-10 UFC | 3 TM MFDs | Realteus ForceFeel | 2x bass shakers

FC3 - Warthog - F-5E - Harrier - Hornet - Tomcat - Huey - Viper - C-101 - NTTR - PG - Mi8 - SuperCarrier - Syria - Warthog II

Link to post
Share on other sites
when I´m flying over Nevada, the detail of the roads around my aircraft is fine, but at some distance, it becomes too blurry and fades.

Then I use VR Zoom, and those same blurry roads get detailed again.

 

What´s the graphical setting which controlls this? is it from Oculus, DCS or Nvidia settings?

 

 

I think anisotropic filtering to x16 ( or x8 ) do the trick in DCS or Nvidia settings.

Asus Prime X570-P * Ryzen 5800X * RTX 3080 TUF OC * G.Skill 32GB DDR4 3600MHz * 2 x 256Gb M.2 * Samsung 850 EVO 512Gb SSD * Kingston HyperX 120Gb SSD * Corsair RM850x V2/2018 * HP Reverb G2 * CH Fighterstick/Pedals/Throttle

Link to post
Share on other sites
How do you that?i tried with skatezilla utility, but still DCS starts with oculus software

 

This does not work for a long time. But guys keep posting that they switched dcs from oculus to steamvr. It probably simply means that they changed option in skatezilla's updater.

Link to post
Share on other sites

Oculus Rift S updated itself to 19.0 today.

Release Notes say everyting is about Link except this:

 

Fixed a bug that caused tracking to not work as intended for some Rift users.

 

Well, when it works it works fine, however, i lost Guardian setup twice already today (when i set the Guardian i just define the position in front of my desk and then set the floor level and skip all the rest). Been ages since i had to set this up again.

When it happens, it happens at the start of loading a mission, all of a sudden the screen goes black, and if i look around, i see the Guardian setup screen somewhere hanging beside me. Annoys me a bit since i have to put in a battery in the controller, reset the view point with the controller, start the Guardian and set the viewpoint, set the Guardian floor level, skip the rest (drawing of the fence) and then i can continue.

 

Seems to me like the Rift S looses tracking now and then. And they just smashed that bug...

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...